Software/Internet Explorer does not recognize a current internet connection - Networking, Internet, Wireless Forum - Networking, Internet, Wireless - Dell Community

Software/Internet Explorer does not recognize a current internet connection

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Software/Internet Explorer does not recognize a current internet connection

  • I have started having problems with some programs that require an internet connection. I have a cable modem which is always on and I may be on an connected web site and still some programs will say, "the computer currently has no connection to the internet and is unable to creat one". Or I will get the work offline box and if I click on retry it works. Or still another problem I have is with Windows Media player - when I click on a short video it says a connection is required, when I am on an active site.

    Anyone have any ideas what is wrong here?


  • Ensure your virus-scanning software is up-to-date, and then perform a full scan of your system and files.

    You may need to run a spyware removal tool on your system such as AdAware or SpyBot.

    If the above doesn't help, what is the status of the link lights on both the network interface on your computer and on the cable modem when this problem occurs? If you power off the cable modem and computer for about twenty minutes, then power the cable modem on, allow it to connect to the ISP, and then power on your system, do the problems persist?
  • Cody,

    Thanks for the response. I have done all three steps. Actually I shut the monitor, router, and my computer for about 2-3 hr. after running Spybot and updating Norton. Interestingly I have two computers, this one running XP and an older Dell Dimension XPS-233s and I don't have this problem with the latter.  My problem is on my Dimension 8200. Any other suggestions?

  • What type of network setup do you have?  Are you assigning DHCP addressing from a router or running ICS?
  • J,

    Thanks for the question. I am assuming I am using DHCP addressing because when I look at the Support tab on my local area connection it says. "Address Type Assigned by DHCP", and this IP address is .3 and the Default is .1 When you ask "type" I am using a cable modem>router>2 computers.

  • Can you check in your Internet settings that its got LAN settings - Autodetect enable.

    Find this via - Start -> Control Panel ->Internet Options -> Connections -> LAN settings

  • Hi Sentinel-Master,

    Thanks for your suggestion, but I did verify that it is Autodetect enabled. This is really crazy. All my setting so far look correct. I think it there were some way to remove my network and re-install, that might help. Thanks again for your idea!

  • No your network settings and card are fine - by the mere fact you can browse the Internet and email etc etc.

    Try opening Windows Media Player on your PC - and select the Tools->Options->Network tab, and check that the various network ports are selected UDP, TCP, HTTP & Multicast


  • I checked Windows Media Player and they were all checked. This is really strange. I have the same problem with Quicken 2004. Every time it goes to check an account on the internet it says it cannot detect an internet connection. So it does not seem to be a software problem, I guess? But rather some setting in my computer?


    Thanks for your great persistence!

  • This is so weird - can you try disabling any Firewall s/w you have active on the PC and then re-try WMP or Quicken.

    Start -> Run -> cmd

    Also when you have these Applications open can you issue the command "nbtstat -s" and "netstat", and post the results here for perusal

  • When I run cmd I presume you want me to also run ipconfig /release? If so when I do I get the following: The operation failed as no adapter is in the state permissible for this operation.

    As for the second request, I am sorry but can you help me understand what you mean by "issue the command"?



  • Issue the commands on the command line of the DOS shell - white on black window

    Just do  Start -> Run -> cmd

    nbtstat -s


    and post the results here for perusal

  • When I ran nbtstat-s it said it was not recognized as an internal or external command, operable program or batch file.

    When I ran netstat I got a list of active connections:

    Proto         Local Address       Foreign Address              State

    TCP          NewDell 11:3017          Established

    TCP          NewDell 11:3078 Close_Wait

    TCP          NewDell 11:3079 Close_Wait

    TCP         NewDell 11:3068    Close_Wait

    TCP         NewDell 11:3090     Close_Wait

    Then all  the following had the same foreign address and state:

    TCP        NewDell 11:3220  Time_Wait

                    through  11:3247

    Good luck with this.


  • Yes this tells me that your PC is able to connect across multiple ports to the Internet and therefore the problem is most likely Windows S/w on your PC

    So checking against known Microsoft Knowledge base - I found this alert and known issues

    CAUSE Windows Media Player checks for an echo from the default gateway. If there is no IP gateway, Windows Media Player may try to ping the HTTP proxy instead. If the HTTP proxy is outside your firewall and the firewall filters ICMP packets, Windows Media Player may determine that there is no connection.

    RESOLUTION This issue can be resolved by downloading the latest version of Media Player from the following Microsoft Web site:

    Windows Media Player 7 Does Not Recognize a Connection to the Internet