Dell XPS 13 9360 - Wifi dropping out (or not connecting) and screen flickering - Networking, Internet, Wireless Forum - Networking, Internet, Wireless - Dell Community

Dell XPS 13 9360 - Wifi dropping out (or not connecting) and screen flickering

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Dell XPS 13 9360 - Wifi dropping out (or not connecting) and screen flickering

This question has been answered by killernetworking

Hi 

I just received my new Dell XPS, i7 12gig Ram 9360 and I have the following issues. 

The wifi connection is very poor in that i need to be near the router for it to connect. All my other devices such as a win7 laptop, phone, android tablet and smart tv all connect to my router with no issues whatsoever. I can use my mobile as a hot spot and it connects perfectly with the laptop.

When the laptop connects its very slow and occasionally drops out. 

In addition, the screen flickers off and back on again randomly for a couple of seconds! 

Searching on the web and forums these are issues with the last model? I would have thought these would be fixed in the new 9360 

As far as I can see all the drivers are up to date for the Killerwifi and laptop.  Im really happy with the product but for a amount paid it should be working out the box!


Please can someone suggest some fixes? I am tempted to do a windows reset! 

Many thanks 

Verified Answer
  • I have successfully talked dell technical support into sending me a replacement Intel wireless card. You guys should probably try the same if you're comfortable replacing it yourselves, if not, they will e mail you a shipping label and you can send back your xps 13 and they will replace killer with an intel card. People who replaced killer with intel 8265 report that all wi-fi issues are gone.

  • Hi folks - we have just posted a new wireless driver and software suite that addresses a known issue on a small percentage of systems where the Killer Wireless module will drop the WiFi connection when passing a large amount of traffic. We have worked closely with Microsoft on this, and have identified a fix. This fix has been confirmed with several users that currently have the issue and we have posted a new software package. Please visit the link below to get the new driver:

    www.killernetworking.com/.../e2200-e2400-wireless

    If there are issues after using this, please feel free to contact our support through our website for assistance.

    www.killernetworking.com/.../contact

All Replies
  • Yep tried it and no more drops. No need for intel cards, since this driver it's stable !

  • @killernetworking I have updated the driver and still have a lot of disconnections :(

  • I have just bought a new Dell XPS 9560 and I am very disappointed!

    @killernetworking I have installed your latest drivers, however, I still have problems (13 March 2017) with my connection! It drops off very very(!) often, also with low load.

    I can't navigate with a 1500£ machine...

  • Hello,

    I tried the latest driver as you recommend but unfortunately shortly after my laptop did crash (BSOD). I did roll-back the previous version but I do still have drops of wireless connectivity.

  • Personally for me the wifi works WAY better when plugged. Running on the battery alone, it stinks so bad. It is slower than my Desktop that is running on Vista! I've contacted support. I'm going to see what they come back to me with. Btw updating the drivers definitely did not solve the issue. Tried to attempt changing the power saving mode, but the change wireless adapter option did not exist. Sigh.

  • Even with the new Killer Wifi Driver, Dell still needs to replace the Killer card.   Dell is sending a technician to replace the card this week.  

  • Does this work for Killer 1535?  This shows for the E2200/E2400

  • I updated The Killer suite from here: http://bit.ly/2qtiJpr

    Changed Power settings on battery to Max performance on power Manager plan. Had to update tThe Windows registry to have the option enabled: http://bit.ly/2pjkvcF

    Then went to Device Manager, selected properties on the network card, Advanced Options, Wireless options and selected mode 08 - 11 a/b/g/n

    This fixed the issue for me definitely.

    It seems the default power plan uses medium output when on battery, by changing to max performance it was fixed

  • Small percentage? have you seen all the blogs about this issue? I will ask for the replacement of the wireless card. I can´t even download the driver that you suggested because this problem. It took me an hour to be able to put this post because ot the issue.