Very slow internet browsing on brand new XPS 13 9360 over Wifi. - Networking, Internet, Wireless Forum - Networking, Internet, Wireless - Dell Community

Very slow internet browsing on brand new XPS 13 9360 over Wifi.

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Very slow internet browsing on brand new XPS 13 9360 over Wifi.

This question has been answered by emene

Problem
After receiving my brand new XPS 13 I noticed the internet browsing was very slow at times over my Wifi connection. Expecially with web pages that pull in a lot of contact using ajex calls after the initial page load.
There was nothing wrong with the Wifi signal or the internet connection itself since other devices showed a good internet speed. Also, downloading files over Wifi was good.

Fix
After installing all the latest drivers I finally fixed the issue by disabling the QOS packet sheduler option on the Wireless network adapter. Finally the browsing experience returned back to normal.

Question
While this fix works for me I wonder if this is the recommended fix or if there are any other better solutions.

All Replies
  • I don't think that you will get it.  It really appears that the Killer wireless card is just that bad.  Replacing it with the Intel was the only thing that worked. 

    Yes, it is very sad that is what is required in order to get a premium laptop such as this working properly.

  • Hi everyone,

    I cut my losses quickly and have asked my Dell A/C mgr for a return full refund.

    I will look for an alternative now. The A/C mgr tried to get me to shift over to a Latitude. Lets just say i declined the invitation.  

    Waiting for Dell to come pick up the laptops. I hope the refund doesn't delay to much and drag on too long.

     

  • Hey Jalapeno - can u provide more details on what regedit changes you made to the power options?

  • Looks like the issue is because of the power plan throttling wifi on battery!

    1.Add wireless adapter settings to power settings

    2.Change power saving mode for wirelss adapter to "max. performance". this fixed the issues on my new 9360

    Tutorial on how to add wireless adapter settings is available on eightforums - google "power-options-add-remove-wireless-adapter-settings"

  • I followed the steps suggested by NIKHILJAPS, but the issue remains. Opening webpages and downloading files is awfully slow. I can't work with this machine (Dell XPS 13 9360). It looks like I will have to return the computer. What a waste of time.

  • I just want to add that, in my experience, not only is the web browsing with this laptop slow (Dell XPS 13 9360, Intel i5, 8GB, Windows 10 Pro), it seems that it slows down browsing for other devices connected to the same WIFI network (laptops, phones, iPad). It seems other devices become slow some time after connecting my laptop to the network. Anybody else have this experience?

  • Tried this some time ago. These settings did not help my problem at all. 

  • I tried everything too. I have spent already too much time trying to resolve such issues. I have tried everything with ubuntu 16.10 also with no luck. Please Dell HELP, I want to know if I should return this machine once and for all. Not to mention that it has coil whine too. Those machines don't pass under quality control??

  • Hi Brad,

    I also have same problems concerning WIFI connection and drop outs.

    Calling to support and basically they tell us no own knows this issue.

    I get constant drop outs, speccially when pushing hard on Youtube for example watching a 4K or 8K video, the wi fi just drops and may even disconect the adapter.

    When connecting to an AP, this will crash it, and it's defenetly this PC. We can be all connected (3 or 6 clients, mobile and laptop, all going good) untill my XPS joins the network and "push" everyone out and/or even crash the AP. Solution is powercicle AP and NOT USE XPS, otherwise no one can use that connection. This is absolutely crazy and really upsetting after you've just bought a 2.200,00€ computer!

    I will send you PM with my service TAG.

    Thanks. Xavier V.

  • hello all. had a painfully low internet speed on 5Ghz, was slightly better on 2.4Ghz, went through the thread and could not improve the situation.

    then i found this post www.windowscentral.com/killer-wireless-drivers-updated-fix-xps-15-9560-connection-drop-issue

    i have just updated the suite as per the instructions and works like a charm now. i hope it can help some of you guys.

  • Thank you for suggesting this, it worked for me instantly after I installed the driver update.

  • I updated the Killer 1535 drivers as Dell website recomended, so far so good for 5ghz networks, but when I go to 2.4ghz networks, this thing have a very bad range. I put my Galaxy S7, the wife's iphone 6's and my corporate laptop HP Elitebook 840 G3 and all of them are very similar to speed connection test meters away from the router, but the XPS 13 9360 is very bad on 2.4ghz network, are you experience the same issue? I could not find any comment on the web regarding de 2.4ghz issue in this Laptop/Wireless adaptor.

    Dell, what can we do to have best in class wifi Range also @ 2.4ghz?

    Thanks