BRAND NEW Inspiron 7000 WiFi is Horrendous!!

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

BRAND NEW Inspiron 7000 WiFi is Horrendous!!

This question is not answered

I got my Inspiron 7000 literally an hour ago (15 inch model, i7core, 1TB HD 8GB RAM). It's nice but the WiFi is sickening. It keeps dropping the internet connection and every time I run troubleshooting it gives me a different problem that it fixed. First it was a problem with the WiFi adapter, then "Default gateway was unavailable".  This is unacceptable. I work at home and need a SOLID connection. It's bad enough Dell took nearly 3 weeks to get the thing to me, and now this. I am weary and frustrated. Every other device in my home connects and STAYS connected, so the problem isn't on my end. Do I need to send this thing back? I certainly hope not.

All Replies
  • Wow, thanks for ignoring me. I really appreciate it. Fortunately I managed to fix the issue on my own.Your site listed an a driver update so I installed it-and it promptly uninstalled the driver for my network controller. Great job Dell!  I was able to connect to the net via Ethernet and re-install the driver, and my internet connection has been perfect ever since. Again though, thanks for ignoring my post. 

  • i am facing the same <ADMIN NOTE: Profanity removed as per TOU> problem!!:(:(:( had high hopes when I purchased my dell inspiron 15 7000(15 inch 4th gen i7,1tb,8gb ram) a couple of days back. and its shocking to find the wifi acting sooo weird...it works only if I sit right next to the modem...I have my 5 years old dell studio1555 and that still works like a charm....plz dell u got to do something to sort tis out..i tried updating my network drivers as well..but still the same old story :(:(..very very disappointed!

  • I'm sorry to hear that. Mine has been perfect since I re-installed the network controller. Try re-installing the driver for your WiFi adapter and if you haven't in awhile, see if your router has a firmware update available. Good luck!

  • oh wow..that's quiet relieving to hear.... can you please tell me which is the version of the driver you have installed?? or can you please give me the link to it....

  • Hi, I really need your help with this. I have no clue what is the network controller and how to reinstall the drivers. Could you please give me step by step instructions how to do it? I really need a solid internet connection and I cannot fix this problem by myself... Please, help!

  • Hi GirlFridayNY,

    I'm about to buy a laptop and I'm getting skeptical about this Dell Inspiron 15 7537 which I wanted to buy, because of this wifi issue.

    Could you please be so kind to confirm whether or not the wifi issue has been definetly solved with your driver update? And also, could you please link here the driver you installed? I couldn't find any driver for this laptop on Dell website.

    Many thanks,

    Davide

    GirlFridayNY

    I'm sorry to hear that. Mine has been perfect since I re-installed the network controller. Try re-installing the driver for your WiFi adapter and if you haven't in awhile, see if your router has a firmware update available. Good luck!

  • Update with the issue…

    Ok so now dell support told me that they should change the network card and the wifi antenna of my new laptop. I was taken aback by this and I asked them I don’t want any parts to be replaced. So either return my cash or replace the whole system.

    The customer support agreed to this and replaced the ,laptop. I just received new Dell inspiron 7537 yesterday. Thank s to dell for their prompt service.

    But guess what..!! I have the exact same problem with this laptop as well.

    The wifi doesn’t work even I’m just 5 feet away from the router.

    I tried connecting the laptop via Ethernet port and the internet works perfect, so I don’t think it is the network card issue. I have just updated the drivers as well. But nothing seems to solve the issue.

    Dell should do something about this!!

  • Hi!


    I think you will be very happy with this laptop. I love mine. There are drivers available on Dell's site but you have to provide the service tag of your laptop to access them. You can also simply go to the Device Manager, find the controller, then click the driver tab and update driver. Tell it to search the internet for it and it will find and install it. That's what I did. I've had no problems since!

  • Sounds like an issue with your router. What encryption do you use? If it's TKIP try AES and vice versa. Try upgrading the drivers for your network controller as well. I don't think Dell is to blame here. Mine is working just fine since I updated the driver for my network controller, and a WiFi issue with my tablet (non-Dell) was fixed when I changed the encryption type. When two laptops in a row have the same problem, it's time to look at something other than the PC as the problem. You might also seeing if there is an upgrade available for your router firmware. Another thing to try is to take it to another hotspot and see if it will connect-maybe a friends house or a Starbucks or something. If it works, you'll know for sure it's your router causing problems.

    Oh one more thing, do you get an error message when you try to connect? If so what does it say?

  • See my other posts-you'll find it in the Device Manager in the Control Panel.

  • Hey girlfridayny..

    I went to dell website and downloaded the latest wifi network driver. “Intel centrino wireless-n 7260 AGN/AC/BGN driver” version 16.1.1.3, A01. And have installed it.

    It does connect to the internet. But only if I place the laptop close to the router. 

    The router was initially set to TKIP. Just to check I left the network open and tried, but the same problem.

    I checked in four different network connections at different places. Each of these places network seems to be fine with other devices. I check on my phone and two other laptops and they all work fine. So I don’t think it is the network or the router issue.

    And I’m not getting any errors while connecting.

    One question…. Have you by any chance updated your OS from Windows 8 to windows 8.1??? Because that’s the only thing left for me to do. But I am not able to find the windows 8.1 update in the store. Trying to figure out how to get that.

  • If you can't connect to other hotspots then it is your PC. Have you tried going into Control Panel, opening the device manager, looking for the network controller and clicking update driver? If you can, I'd try getting a USB WiFi adapter and seeing if you can connect properly with it.


    No, I refuse to upgrade to Windows 8.1 because doing so breaks the built-in recovery features. Neither Refresh or Restore works in Windows 8.1 because of Microsoft's stupidity. I value those features more than the features 8.1 offers so I am staying with Windows 8 for now.

  • oh well... so windows 8 is not the culprit eh... i do have a usb wifi dongle...will try that and let know how it goes...

  • I have the same laptop without any issues I have 2.4ghz and I use aes and all I had to do was go to driver properites in advance and from 802.11 for 2.4ghz change the value from auto to 20mhz. I think it has to scn bot 2.4 and 5ghz in all 20mhznad 40mhz band and they it creates a havoc but its been working fine . I always set my MHz In all my laptops because there are so many wireless manufacturers . I choose my routers to be broadcomm ones.

  • K, so I updated to 8.1, and now I have the same issue - i'm not aware it was a problem with 8.0. I've updated the drivers from several sources - DELL thinks they should be at a different level to intel's, so I don't know who to believe. I had the black screen issue,for instance, on Dell's  recommended driver, but Intel's seemed to fix it (which was later). With regards wireless,Intel says I am up to date, but I still have issues (other devices connecting fine).

    I'll keep messing around - trouble is it's intermittent. I can connect to wireless ok, but connection is 'Limited'. Maybe it's Mcafee ?