Unable to connect internet through my wireless adapter

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Unable to connect internet through my wireless adapter

This question is not answered


Can someone please help me with this problem? I've a Dell studio 1555, windows home premium, 4 gb ram, 320gb hdd. Till yesterday everything was fine, all of a sudden my laptop stopped connecting to internet through wireless.I have tried it in safe mode. I have tried to delete the network also but now that left me with inputting the password everytime I want to connect. Its showing all the networks available, and it shows connected. but there is a triangle on the signal. When i disconnect and connect it again, then i get an error saying "windows cannot conenct to wireless network". When i click on the Trouble shoot problems, its showing below

Troubleshooting has completed

Troubleshooter made some changes to the system

problems found

problem with wireless adapter                           fixed.

But still it won't connect to the network. i've been searching in the internet for solution but couldn't find it. In a couple of tech forums people posted same problem for Dell studio 1555. But there is no solution. I think it has something to do with this model? I've been using it for past 3 years without many problems(except my mike is stuck with only yahoo messenger and won't work on skype/gtalk etc)

I tried to download drivers from dell and install, but it gives error saying "This software package cannot be installed on your system. Setup will now exit."

I tried removing the drivers and then rebooted the system. The drivers were then automatically installed by the windows again.  I went to Intel website and it downloaded a tool to my pc to check for old drivers and it found out my adapter was not having new drivers so I downloaded the drivers from there, installed them but its still the same

This is my wireless adapter. "Intel(R) WiFi Link 5100 AGN". Can someone pelease let me know the solution. If you need more information please let me know i shall provide.

Windows IP Configuration

Host Name . . . . . . . . . . . . : ramavadutha-LT
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection 2:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter
Physical Address. . . . . . . . . : 00-22-FB-C8-21-D7
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Broadcom NetLink (TM) Gigabit Ethernet
Physical Address. . . . . . . . . : 00-26-B9-03-35-6B
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::8486:8bdc:acc1:d517%11(Preferred)
IPv4 Address. . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Lease Obtained. . . . . . . . . . : Wednesday, May 30, 2012 7:22:41 AM
Lease Expires . . . . . . . . . . : Wednesday, May 30, 2012 8:22:41 AM
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 268445369
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-83-72-4C-00-26-B9-03-35-6B
DNS Servers . . . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Enabled

All Replies
  • Hi tammasarath,

    Welcome to the Community,

    Which antivirus software are you using ? Have you tried uninstalling the antivirus software?

    If you've already tried uninstalling the antivirus and if the issue still persists,refer to the links given by Rick in the post below:


    Hope this helps,

    Thank You

    Dell | Social Media Outreach | Global Social Media & Community

  • tammasarath,

    Your ipconfig /all log does not show the wireless adapter.

    Places to look to see if the Connection is enabled

    I would look and try reseating the wireless adapter. Instructions HERE.



    What is a Dell Service Tag and how do I locate it? 



    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

    Microsoft MVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

  • Hi Roshan, Thanks for the reply. I'm using Nod 32 and microsoft security essentionals all these 3 years, i never had any problem. after you mentioned, i uninstalled both the antiviruses and still the problem exisits.  I tried to do the below from the link you provided...

    Update the firmware in your wireless router. Manufacturer's website, make & Model needed.

    I did: i went to intel and searched for the new updated firmware, it said my version is 12 and 14 is available, i downloaded and installed using the tool provided by intel, but the issue remains.

    Broadcast SSID(You may want to change this to make it easier to connect)

    Use WPA-PSK(TKIP) Security(WPA Personal). Most wireless devices work best with this type of security.

    I did : my router do not have TKIP, so i left it on AES which i have been using all this time

    Password at least 13 characters long.

    I did: My password is 14 characters long since beginning still i changed my password to 16 characters and still it won't work.

    Mixed b and g mode(n if available)(Use this mode only if using a print server and/or USB wireless adaptrer(s))

    Use channels 1, 6 or 11. Most devices work better on these channels.

    I did: i changed my channell from 13 to 11 still don't work.

    Keep the setting at DHCP.

    Do NOT use Mac Address Filtering

    Please turn off the firewall in the wireless router.

    I don't 've a firewall in wireless router. (I'm using virgin media modem/wireless router)

    Some adapters do not like WPS and may need to be turned off.

    I even tried to disable the encryption and still it won't work.

    Save and exit. Power everything off for 30 seconds. Power everything back on, wait 30 seconds, now try to connect.

    inspite of doing all the above, its not working.

  • Hi Rick, thanks for the reply. i surely can tell you that the connection is enabled. i have to press F2 function key to enable or disable my wireless adapter. problem is not wireless networks, its with the adapter itself. I tried as mentioned in the link "support.dell.com/.../minicard.htm. I unscrewed the wireless card, removed it and kept it back. when i started my laptop, it worked just for 2 mins. it connected i could open google page, but immediately it started showing the triangle on the signal and the problem is the same.

  • what i wanted to say is

    when i tried these two options my wireless worked just for 2 mins. after 2 mins again the problem reappeared.


    Start, all programs, accessories, right click on command prompt, left click run as administrator. Type

    netsh winsock reset catalog

    This will reset the winsock catalog

    When i did the above it asked to restart my laptop, once i restarted it, it lasted for 2 mins, i could get google page and search something, when i tried to open the individual pages it opened the first 2 pages, and later the wireless is disconnected again with the same problem.



    As they stated in the above link, i removed my wireless card and put it back again. after starting my laptop, immediately i connected my wireless network and i could start browsing again. but it lasted only 2 mins. it got disconnected and the problem re appeared. i don't know what to make out from this. is it problem with my adapter or wireless router? because my pad is connected to my network and is working perfectly without any problem.

  • tammasarath,

    You could try scanning for Malware. Download Malwarebytes Anti-Malware save it to a disk or flash drive and try running it. It may or may not find something.

    I suspect since the adapter is not listed, you may be correct, it may be the adapter.

    Does the adapter show in the device manager? Maybe with a yellow exclamation mark?

    If you go to start, control panel, device manager, then clicked on network, right clicked on the your network adapter you should see...

    Left click Uninstall


    Restart your computer.


    After you login, the new hardware wizard will find your network adapter and install it for you.

    What happens?

    Is your computer under warranty?



    What is a Dell Service Tag and how do I locate it? 



    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

    Microsoft MVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

  • No my laptop is not under warrenty. its been 3 years. my warrenty expired a year ago.

  • I did what you said. i uninstalled the driver and re-started my laptop. it automatically installed the drivers. when i try to connect to my network, the same earlier problem re-appeared.

  • tammasarath,

    I use these Recommended Wireless Router Settings I use channel 11. I would make a new SSID to make connecting easier.

    How can I disable wireless configuration services and enable the Windows XP Wireless Zero Configuration services

    How to start Wireless Zero Configuration using Vista/Windows 7

    Did you recently install/reinstall the operating system?



    What is a Dell Service Tag and how do I locate it? 



    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

    Microsoft MVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015