Wireless card seems slow on my XPS 14z

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Wireless card seems slow on my XPS 14z

This question has suggested answer(s)

I just got a XPS 14z.  The wireless signal isn't consistant and it is weaker than my old XPS 1330.  It's actually painfully slow.  Every thing is exactlly the same.  I have my old computer next to the new computer and the wireless signal is working much better on the old computer.  Pages are loading more quickly on the older model.  Is anyone else having problems with how their wireless is performing on their 14z?  There is nothing wrong with the router or internet connection.  Help.

All Replies
  • Here is the current document that is available for correcting WIFI issues with the Intel Centrino 6230 card.

    support.dell.com/.../document

    I believe that most of you have already tried the latest drivers.  I do suggest taking a look at step 3 as it goes over how to configure the notebook for the strongest WIFI signals.

    TB

  • Like I said before, apart from the wireless issues we have with 6230, I'm fond of my 14z. Changing to another brand laptop is not what I intend nor would advise. Dell's service is as good as with any other manufacturers (or as bad if you like.) Also I'm convinced Dell would not ship these units if they already know it would cause problems with all of their costumers. So I must assume the majority of 14z & 15z owners do not have the problems we experience. Yet, I believe we are an important enough minority to be heard and taken seriously. That is why I'm in this thread. Now that Terry acknowledged there is a problem and Dell are working on it, my previous posting is answered. Just to make it clear one more time: even if symptoms may vary, the below issues are always the same:

    1. very poor range with 14z.

    2. intermittant connection with 14z.

    3. none of the above with another device.

    The above happens with both N and G connections.

    Issue #2 can be solved with another driver in my case.

    Issue #1 can be solved with an Atherons card in my case (no bluetooth and no intel wireless display).

    Conclusion: There's an issue with the 14z & 15z combined with the 6320 under certain conditions. A logic assumption to make is that there is an inefficiency related to the power of the antenna signal under these conditions. Possibly: a too big portion of this power is NOT used to maintain the connection. Why? Don't know. Indeed this is complex.

  • Hi uall, Just got my xps 14z yesterday. Ordered it then read reviews. I know backwards, but anyway thought I would get it home and have a nightmare. But it has been just the opposite. I love it, it is not as fast as I thought it would be,and the screen has a small angle of view,but other wise she is up to snuff. I think they are getting things worked out. Have had it hooked up to two different routers, and she hasn't missed a beat. I believe Dell got this one right. will cheeck back later if things change.

  • I bought the 14z during black friday and had a terrible time with the wifi drivers.  Recently I installed the new ones from the intel website, not the dell website.  Its the Intel® Centrino® Wireless-N 1030.

    downloadcenter.intel.com/SearchResult.aspx

    link again

  • Thanks @RASHAUNNY, After trying everything else, this seems to have finally got my xps 14z working comparably to my 5yr old laptop.

    Kind of frustrating to find that a brand new high end laptop needs this sort of screwing around with to get wifi preformance up there, in 2002 that was expected, but in 2012 it's a poor show.

    Otherwise, I'm happy with the machine.

  • Ooh I'm so glad this helped someone out, I kept my three forum links open for a week before I got around to making an acct and posting that link!  I had just installed a SSD and now I have two hdds and I was really bummed at the wifi performance...its embarassing.  

    READ ME__________________________________________

    NOTE:  Please search ebay for cdrom hdd caddy and purchase an adapter for the cd/dvd rom drive and install a second hdd in this lappy.  With this configuration and a small ssd in the main bay and a storage drive in the cdrom bay the computer performed well above its price tag...boot up time is 11 seconds from the time of pressing the power button until all 15-20 of my firefox tabs load in the browser, that mean the internet connects almost instantaneously!  An excellent setup.

  • Great post ... :>

  • Hi there,

    I just received my replacement Computer, after I had tow technicians here to exchange the wireless card. First it was same issue with the Computer, but after I had the latest driver installed, it did speed up, just like my old Insprion 13z.

    Holds the connection and runs as it should be.

    So far, it seems that the newer models, do not have this isssue anymore.

    It took a long time, but it seems that was it.

    Good Luck everybody.

    maze

  • I had the same problem with a Dell XPS 17, I went to http://www.intel.com/p/en_US/support/detect/wireless and used their update utility, which replaced the driver and software and solved the problem.

  • I've installed Intel's latest drivers 14.​3.​0.​6 - and this indeed seems to have solved my issue. The range is now much better.

  • This is going to sound random, but I reinstalled the operating system using the Dell Recovery Image. Fixed the problem for me...

    Updating the driver, regardless of how I did it, made no difference.

  • what card exactly did you replace your Intel with?  What other cards can you replace the Intel card with?  Thanks in advance.

  • Hello

    Any updates on this post? i just got a new xps 14z. Increasing the roaming agressiveness as Terry proposed really helps. It is now just as good as my six year old laptop. Ofcourse I got the latest drivers from Dell. But anyone tell me whether it is better to have the Dell drivers or the drivers from Intell?

  • Go here: www.intel.com/.../wireless. The driver suggested is 14.3.1.1 and it is by far the best driver yet for the 6230.

    Good Luck!

  • Hi.  I just got a new laptop yesterday, 4/20. It had the same slow internet speed problem.  I have done the driver re-do's. I have been on the phone for about 2 hours with Dell tech support while they had control of the Dell 14z XPS trying to figure out why it had a speed of 24 to 33 in safe mode and 4 to 8 in regular. Can you help? I think I should just send it back. I've already done a clean install of Windows 7 with the disk, redone the internet drivers as you suggested, the tech verified that I had the latest drivers. Even he was stymied. He said he was calling it a 'class C' problem and would have to get back to me. Honestly, I don't have the patience to deal with a problem like this with a brand new machine out of the box. Thanks for any help you can give me.