Dell Inspiron 15R - wireless internet very slow - Networking, Internet, Wireless Forum - Networking, Internet, Wireless - Dell Community

Dell Inspiron 15R - wireless internet very slow

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Dell Inspiron 15R - wireless internet very slow

This question is not answered


I purchased a Dell Inspiron 15R at the weekend and I am having problems with the wireless internet speed.


I have Virgin Media broadband in the UK, my package is 50Mbps.  This is via a Virgin Media super hub and is only 1 month old.


The internet speed on my new Dell is very slow in comparison to my old laptop (an HP) so I tested the connection using  These are the results:


Dell Insprion on wireless

Ping 35ms

Download speed 0.44 Mbps

Upload speed 2.15 Mbps


Dell Inspiron hard wired to router

Ping 25ms

Download speed 43.16 Mbps

Upload speed 4.73 Mbps


HP on wireless

Ping 28ms

Download speed 16.88Mbps

Upload speed 4.64 Mbps


HP hardwired

Ping 29ms

Download speed 16.16 Mbps

Upload speed 4.61 Mbps


As you can see the HP is consistent on both the wireless network and hard wired but the performance of the Dell is excellent on a wire but terrible on wireless.


Does anyone have any ideas what may be causing this?


Some further info - I bought Norton 360 with the laptop, the above results were achieved with that installed.  I have since uninstalled that and there was no difference to the  I then turned off the windows firewall and again it made no difference to the results.


Thanks in advance.



All Replies
  • ClaireP235,

    Thank you for using the Dell Community Forum.

    I found this list to possibly increase you wireless performance.

    Right-click on the 'My Computer' icon on your computer and choose 'Properties'.

    Click on the 'Hardware' tab and then click on the 'Device Manager'.

    Now, find the 'Network Adapters' section and click on the little plus-sign to the left.

    Find your wireless network adapter and right-click on it and choose 'Properties'.

    This is where things will get different depending on the brand of your laptop and wireless card and which drivers you have installed. Browse through the different tabs and look for settings such as 'Power Management' or 'Transmit Power'. Adjust the settings to either disable the power management or increase the amount of power used by the network card.

    Now, test your wireless signal strength to see if you still have the same weak wireless signal you had before. The chances are that you will notice an increased wireless signal strength.

  • Thank you for that Jesse, I am at work now but will try your suggestion this evening and report back.

    I should also have said in my original post what operating system - windows 7.

  • Just to update.  Tried the suggested fix and it didn't work.  Contacted Dell and the support guy tried various fixes and nothing worked.  He booked a service call to replace the wireless card which was yesterday.  Works fine now but should note the card fitted was an intel centrino 1030 and it was swapped for an intel centrino 6230.

  • deleted due to wrong reply

  • Hello,

    I'm in the same boat, only using a 2wire wireless router. I've also tried to turn off bluetooth accessibility throughout my system. I just bought my laptop a couple of weeks ago; is there no way to improve the 1030's speed/access? Or is replacing the device the only solution?

  • update the drivers from INTEL site select your operating system download drivers install and restart and all works well !

    SOURCE : i had same problems and solved them myself !

  • Unfortunately, I tried this and it didn't work. Ended up having the network adapter replaced (by Dell, as part of the laptop's warranty), but had the same problems all over again. I've returned it... and bought a Mac! Way pricier, but no built-in attempts to upsell me on anti-virus software, data storage, or other products - more importantly, it worked the way it was supposed to right out of the box.

  • Most likely, it is your wireless router. Older router work well with 802.1g&b and your new laptop is probably an 802.1n

    you will either change your router setting to use the 802.1 n (may or may not work)

    but, a new router that supports 802.1n should do it. You can always try it out and if it doesn't work for you, you can return the router.

  • please read before posting it does say "This is via a Virgin Media super hub and is only 1 month old." and everyone else said they had the "same problem". so i dont think it could be an old router. the problem is a conflict between the centrino  1030 card and the virgin superhub no other problems on any other router.

  • Thank you a lot James! This helps me perfectly. I decided to create an account at 1:30 to write you how glad I am becouse of youre help.

  • im glad that worked for you and thank you very much for taking the time to create an account and say thanks. James....

  • Hey there!

    Thanks, the driver update seems to work for me too. At least until the moment with different test,, skype...etc

  • @ weilah can you be more specific ? i can help more if you want just post back here or email me direct <ADMIN NOTE:email address removed per privacy policy~RK> thanks....

  • actually i said that all is working like it should! so, no more problem :) the driver did the trick!!


  • sorry just read this at the end and must have got confused "At least until the moment with different test,, skype...etc"