Forums

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Centrino wirelessN 1030 intermittent connectivity on brand-new laptops

This question has suggested answer(s)

Hi,

 

I saw some other mentions online of intermittent internet connectivity using the factory-installed Intel Centrino wireless-N 1030 card on various new Dell computers running Windows 7, but didn't see any resolution to the problem.

 

I can connect directly to my router via an ethernet cord, but trying to use the wireless card gives me intermittent connectivity.  I will pretty quickly lose the ability to load a new page if I'm browsing with IE or Firefox, and can regain it (temporarily) by disconnecting/reconnecting or letting the wireless manager troubleshoot, during which it resets the wireless adaptor.  Doing a continuous ping of my router gives me anywhere from 30-70% data loss and lengthy round trips (I am currently one foot away from the router).  Other (ancient!) computers work fine on my router; I have updated the router's firmware/reset it many times, etc).  I didn't specifically go download a new driver for the wireless card, but going into its properties and having it search for an updated driver results in it reporting it already has the most up-to-date driver.

 

I spent a lot of late nights talking to Dell support, and their eventual fix (after a complete reinstall from the factory setting partition) was to set up my home network as a WEP, which I'm not happy with due to it's poor security compared to WPA2/WPA.  This appeared to resolve the connectivity issue (why??).  But I feel like I should be able to use WPA2 security with a brand-new laptop.  So I changed it back to WPA2/WPA and tried installing all the critical updates that Windows Update could find, including SP1, and then looked at some continuous pings of various webpages and of my router itself.

 

Then I noticed my ping round trip time was awesome and they were 100% successful while my computer was plugged in with the power cord, but this unfailingly changed to reporting unsuccessful pings and having 1000ms round trips as soon as I disconnect the power.  Seems like the on-battery power settings are starving the wireless card???

 

Also, I'm sure my initial intermittent connectivity (before the complete OS reinstall) was still occurring while plugged in with the power cord, so I'm not sure if the reinstall fixed some aspect of the problem, or whether the appearance of success while plugged in now is just temporary.  Perhaps my card is just bad and I need a new one?  I was hoping you could help me attempt to resolve this with power setting changes.  If that is the fix, it would certainly help other users as well --- I'm using the factory default power settings and the factory-installed wireless card (and I couldn't choose a different wireless card when I built my laptop), so I assume this is a widespread problem.  Thanks!!

 

Fox

All Replies
  • Well, going to "change advanced power settings" under the Dell power plan (via the control panel/power settings) let me change the on-battery setting to "maximum performance" by going under:

    wireless adaptor settings/power saving mode/on battery:maximum performance

     

    This seems to give me nice short ping times whether I'm plugged in to the power cord or not.  Is there anything other than attempted internet use and watching a continuous ping to let me know whether I can conclude this problem is resolved (and therefore not try to return my computer to Dell before I've owned it too long to be able to do that)?

    Thanks!

    Fox

  • I'm having the same exact issue on my Dell Vostro 3450. Dell Support, please look into this. I would return my laptop if this doesn't get resolved soon.

  • Same problem here with a Dell Vostro 3750. Dell's going to get another one returned, if there is no resolution.

  • Guys,

    I followed this recommendation from the "Welcome, PLEASE READ FIRST" thread.

    Actually WPA2-PSK(TKIP) Personal Security is the way to go but not all wireless devices will work with WPA2. So this is why we are currently sticking with WPA-PSK(TKIP) Personal Security.

     I don't know why WPA2 is less compatible if all your devices support it. So far switching to WPA-PSK(TKIP) security has worked fine. No dropped signal for1.5 days now. Noticeably, printouts to my wireless printer takes less time than before, when it used to take a minute and sometimes not print at all.

    My setup:

    Comcast/xfinity service

    Netgear WNR1000v2 router now reconfigured to WPA-PSK(TKIP) security,and set to 150 Mps g/n only mode

    Vostro 3450 laptop

  • Yes, that solved the problem for me too on vostro 3350. going to "advanced power management" and setting it to maximum performance.
  • I have a Vostro 3450 and, sorry to say, but this answer is bull.

    Using WPA2/TKIP instead of WPA2/AES will limit the data rate to 54 Mbps which is the same as not having N-mode at all.

    See yourself:
    http://www.intel.com/support/wireless/wlan/4965agn/sb/cs-025643.htm 
    (Data rate will not exceed 54 Mbps when WEP or TKIP encryption is configured)

    You will have the same effect if you set "N" to "deactivated" in the adapter settings. Disabling "N" always gave me full performance regardless of being on battery or mains.

    In my case, the "N"-mode on this Centrino module is heavily unstable (regardless if on battery or plugged-in). The "high performance" setting in the energy options made only little difference.

    In contrast, my old Asus 1000H EeePC netbook with a cheap Atheros chipset is rock-solid in "N"-mode on the same AP without having to tune any setting.

    So, something *is* definitely fishy here.

    Regards,

    Pete

  • Oh, one addition: The answer was meant to the post of "arielagustin".

    Note: I've also re-installed Windows 7  from scratch using the DVD, including Windows 7 SP1 later-on. Made no difference.

    This could very well be a hardware issue, since "N"-mode uses MIMO and needs a different antenna setup as the "b/g" modes. So, if an antenna cable is faulty or not plugged-in correctly, this may only affect "N"-mode.

  • I have the same problem. I have XPS 15 L502X. I can't even load pages and buffering a video on youtube is a mere dream. I don't have much information on WPA2 PSK or TKIP. I have changed my power options as one user said. I can't see any difference. I am from UK. I haven't called dell about the problem as I thought to read some reviews first or similar problems faced by N-1030 users. I am going to call them tomorrow. I also saw some users thinking to return their laptops. Is it possible? Can any Dell service person can come and replace my existing N-1030 with itself or with any other one I ask,provided that I pay for that.

  • Same problem here on my XPS 15 L502X but with the N-6230. Strange thing here is that it works on some other wireless networks without problems. But on my main network I have these problems. Other laptops and wireless PC's have no issues at all.

  • This has fixed my issue.

    "Well, going to "change advanced power settings" under the Dell power plan (via the control panel/power settings) let me change the on-battery setting to "maximum performance" by going under wireless adaptor settings/power saving mode/on battery:maximum performance."

  • Changing the power options did the trick, Thank you JJH77 for sharing this . 

     

    Thank you 

  • yeah ! great trick ! And i hope that  DELL gonna solve it very quickly !

  • Here is what I found. First of all it works out of the box with an install of ubuntu 11.04. FTW

    *hates windows

    Besides that I was looking at the advanced settings on the card and it was set by default to 20mhz range only. Changed it to auto due to router settings.

    My Asus RT-n16 was set to: wireless mode AP, N-only, auto channel, auto channel width, wpa2-aes. (These settings worked on linux but not windows fail)

    After changing the router and the card from "auto" to the 20mhz range in DD-wrt it works flawlessly.

     

    And if you don't know: right click adapter > properties > configure > advanced > 802.11 n channel width band > 20mhz only        AND

    http://www.dd-wrt.com/site/index

     

    Hope this helps ladies... Smile

  • Going to "advanced power management" and setting it to maximum performance also solved the problem for me.  Thanks to all for the suggestion.

  • Please tell me what my next step should be.  Daughter is at college with brand new Vostro 3450.  Was working on school network during summer but drops the connection multiple times during the day.  She runs the Troubleshooting which then allows her to connect and 30 minutes later the connection is dropped again.  The laptop works fine when connected to the internet via the ethernet cable.  Here is what has been done by the IT support at the school.

    1 -  Deleted the Intel wireless utility as they thought it was "fighting" with the Windows software for control over the wireless.

    2 - Increased the power for the wireless card to "high performance".

    3 - Reinstalled Windows 7 to eliminate that there is a software issue.

    4 - Replaced the Intel Wireless Card with new part sent by Dell.

    Now the IT supports recommendation is to "get a new system" and that perhaps the Vostro's wireless card is "not compatible with their network".  For Dell computers they sell the Latitude to the students.

    My daugther likes the Vostro.  She doesn't want to give it up.  Wants the system to work.  She had the laptop during the summer session and had problems with connection.  The Windows software was reinstalled thinking there was a virus (although no evidence of one) and then she had no connection problems for the whole summer.  She came home for 2 weeks and returned  back to school and then the system would not work again.

    I don't know what to do.  Can I buy a USB wireless adapter for her to temporarily use until I can figure out how to fix this problem.  Personally, I think there is a design flaw with the vostro.  Is there anything else I can have done with this system?

    thanks Gidget