Dell 1397 WLAN mini-card can't find internet connection - Networking, Internet, Wireless Forum - Networking, Internet, Wireless - Dell Community

Dell 1397 WLAN mini-card can't find internet connection

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Dell 1397 WLAN mini-card can't find internet connection

This question is not answered

I've got a Latitude E6500 laptop with Windows 7, 64-bit.  I've tried connecting to three wireless networks and each time the wireless card manages to connect to the router, but is unable to connect to the internet.  When I connect using the ethernet I have no problem and I'm able to connect to the wireless using other devices.  I've downloaded the latest BIOS and windows drivers.  I've ensured the security is configured correctly, the wireless is on, the password is correct.  Why is this such a headache?


All Replies
  • If possible,  I would temporarily remove the Wireless Security from your Router and see if you can get connected through Wireless.  Once you have established a wireless connection without security, you can proceed from there and re-establish wireless security on the router and client.

    You should only be  using WPA2-PSK  AES and NOT WPA or WEP


  • I have been looking for an new driver for this network card, the driver that is shipped with the new Dell's in not compatible with Windows 7, or the wireless card is not compatible with Windows 7. When upgrading to Windows 7 after running the verification utility the WAN card comes up as incompatible? There seems to be nothing posted on the site referring to this as being a problem?  

  • I'm having the exact same problem with my Inspiron 1440.  It too is Win 7, 64-bit.  Like you I've tried updating drivers, quadruple checked all settings etc.  I took the notebook to Best Buy and they connected right away to their wireless.  I took the machine to my workplace, and it also connected there.  I tried an Ubuntu live CD with no luck at home.  I tried setting up a different brand of wireless router at home, but still no internet.  Then I disabled the 1397 WLAN mini-card and plugged in a spare USB wi-fi dongle.  I finally was able to get to the internet.  This has caused me quite a lot of frustration.  It just shouldn't be this hard.  So here are my choices:  1)  Let the notebook have a USB thingy sticking out the side;  2)  Take it back to Best Buy and pay a probable 15% restocking fee;  3) Research and find out what routers are being used at Best Buy or my workplace and buy one of them. 

  • Same problem with the Dell Inspiron 1750.   There is some kind of problem running Windows 7 with the WLAN 1397 wireless and there have been no new drivers posted to the Dell Drivers and Downloads site.   I would suggest to anyone placing a new order to make sure you avoid the WLAN card.

    If anyone has a solution, please reply.


  • I am new here, so don't chew me up. I just, as of 7/23/10, received an Inspiron 1750 with the same network wireless card in it. I have a Wireless Cisco WRT160NV2. I have a PS3, a Wii, several laptops and PCs on it running both wired and wieless connections running any anything from W2000 to now this Windows 7 that came on the new laptop. I have the same problem. I have been dinking with this for hours now. I have tried all the obvious paths, no firewall, Autoassign on the DNS, opened the router up without security and I can not connect to the router at all, The laptop "sees" the router but I can not connect to it. There is another unsecure router somewhere in my neighbor hood that I can connect to. Which makes me think there is an issue between Dell and the Cisco. Any ideas on this as well as what you were experiencing? Did you get a resolution yet?



  • In my case, I had to get a new WiFi-Card for the 1750...

  • Look for latest drivers for the wireless adapter

    Look for a firmware update for the router

    I would download WireShark and do a packet trace.  Is it just not "seeing" your wireless router or is it seeing the router but not receiving an IP address?  Start from the basics and go from there.  Make sure you have enough IP addresses in your DHCP IP Pool. 

    Hope this helps narrow it down. 


  •  John Nashville,


    Some of the network cards work better when you go to the device manager, click on network, your wireless adapter, advanced and change the Antenna diversity from Auto to AUX.


    What type of security are you using on the wireless router? Try channel 11? Try mixed mode?





    What is a Dell Service Tag and how do I locate it? 



    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

    Microsoft MVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

  • Thanks for the responses.

    Status - WellI guess I can mark this one down as, " Owner got too excited about his newlap top and went stupid". Yeah I know, doh. It should be noted that this Refubished Laptop did not have any real documentation with it and I am new to the Windows7 world. Things are a bit different in Win7, but hey for $389 whatcha want?

    Anyway the resolution for me was as simple as entering the MAC address of the new LT, into the Linksys MAC filters section of the Linksys software for the WRT160NV3. And I do not mean the Linksys Advisor, use the browser and eneter  Complete connection suddenly after that, go figure.

    To find your MAC addresses in WINDOWS7, go to the START button and in the "Search programs and files", space to the left of the "Shut down" button, type in "CMD". In the black box that pops up, enter this, "GETMAC" and press ENTER.

    Presto,  your Physical Addresses, or MAC addresses,  are displayed.

     As a note, in my case, the following is true:

    All firewalls, spam filtering, etc., in Windows7 Home Premium are enabled.

    Security on the router is setup for WPA-Personal (PSK) and of course with Wi-F1 Protected Access Password.

    I am broadcasting the SSID, not a big deal.

    Both IPV6 and 4 are enabled in the connection properties for the 1397 WLAN mini-card. No sharing is setup since I have the only WIN7 system in the house.

    Driver in use is the stock driver, Broadcom 7/7/2009 ver

    Otherwise, I do not recall any other changes I made to the default settings. All the Advanced setting are default 





  • John,


    Glad you got it working! Yes Thanks for posting back. I didn't think about Mac address filtering. I usually don't recommend people use this as it make problems for most of the people that aren't quite sure what to do. I usually let them do these Recommended Wireless Router Settings


    Take care,





    What is a Dell Service Tag and how do I locate it? 



    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

    Microsoft MVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

  • I have had this problem with my neices laptop at my house and now at her apartment.  It is an inspiron 15xx running the wlan 1397 card.  It would not connect to WPA-PSK and even had problems with WPA-PSK2.  I have spent many hours searching messaging boards, looking for updated drivers (there are none) and fiddling with settings on the card itself and the router.  I finally figured it out, at least on an ATT wireless UVERSE box.  To fix the problem I disabled WI-FI protected setup.   That fixed it!!


  • I have a similar problem with my recently purchased Dell Inspiron 1545 with the 1397 Mini Card and 64 bit Windows 7.  After some wrangling and patience I was able to connect to my Linksys router but when I reboot or come back from Hibernation, the network connection fails for 5-10 minutes while the connection repairs itself.


    The wireless connection spins throughout the process.


    It eventually reconnects and I am able to move forward.


    Any ideas? I've upgrade firmware and drivers to the latest.





  • STUDIO 1555, Win7 64bit

    Since I have been in Switzerland, this card is there are new parameters to deal with..thus making me bad mouth DELL a LOT.   It would not see the WIFI signal from the hotel, yet I could see all the others available.  AFTER MUCH much looking, I finally found a driver to update the card.  So finally, I thought I had gotten the right driver.  I was able to see and connect to the WEP signal.  A week later, it suddenly stopped working.  It still sees the signal, but unable to connect due to some reason who knows. ..maybe they changed their password?  Doubt it.

    At the same time, my focus is to get my magic jack to work again.  I have been getting an ERROR 3 on the magic jack as if it was not connected.  Tested it on another computer via ethernet LAN:..magic jack works perfect.   Did the same by connecting my laptop to via LAN...and it worked fine.    Yet when connected via WLAN..failed.  So here is what I have deduced from connecting via ethernet cable.   Since I am able to connect with the cable, AND the ERROR 3 goes away. ....this isolated the problem.  The problem is the 1397 WLAN card.

    The card seems to have an issue picking up WEP signals, which is type I have to connect to.  It also has a compatibility issue with Magic Jack...

    Again, I can get on a different WLAN, yet not able to get Magic Jack to work.

    Have wasted WAY to many hours dealing with this stupid issue!!!!! I am burnt out!

    MY there a driver that can fix this problem? If so, is it one from DELL? I have tried 2 so difference.

    I appreciate ANY help to this issue.


  •  RMC-studio1555,


    You said...

    Since I have been in Switzerland, this card is unpredictable

    Are you still there or at a new location?


    Did your Studio 1555 come with Windows 7 64-bit or did you upgrade and install Windows 7 on it?


    Try running Finding System Information remove your product ID and post the rest on the results back here.





    What is a Dell Service Tag and how do I locate it? 



    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

    Microsoft MVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

  • I am still in Switzerland. 

    2 weeks ago, I had to do a reinstall of win7 64 after since it would not boot into windows.


    OS Name:                   Microsoft Windows 7 Enterprise
    OS Version:                6.1.7601 Service Pack 1 Build 7601
    OS Manufacturer:           Microsoft Corporation
    OS Configuration:          Standalone Workstation
    OS Build Type:             Multiprocessor Free
    Registered Owner:          xxx
    Registered Organization:  
    Product ID:               
    Original Install Date:     3/8/2011, 9:37:08 PM
    System Boot Time:          3/20/2011, 12:54:18 AM
    System Manufacturer:       Dell Inc.
    System Model:              Studio 1555
    System Type:               x64-based PC
    Processor(s):              1 Processor(s) Installed.
                               [01]: Intel64 Family 6 Model 23 Stepping 10 GenuineIntel ~2100 Mhz
    BIOS Version:              Dell Inc. A06, 4/23/2009
    Windows Directory:         C:\Windows
    System Directory:          C:\Windows\system32
    Boot Device:               \Device\HarddiskVolume3
    System Locale:             en-us;English (United States)
    Input Locale:              en-us;English (United States)
    Time Zone:                 (UTC+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna
    Total Physical Memory:     4,055 MB
    Available Physical Memory: 2,809 MB
    Virtual Memory: Max Size:  8,108 MB
    Virtual Memory: Available: 6,743 MB
    Virtual Memory: In Use:    1,365 MB
    Page File Location(s):     C:\pagefile.sys
    Domain:                    WORKGROUP

    Hotfix(s):                 10 Hotfix(s) Installed.
                               [01]: KB971033
                               [02]: KB2425227
                               [03]: KB2475792
                               [04]: KB2479628
                               [05]: KB2479943
                               [06]: KB2482017
                               [07]: KB2484033
                               [08]: KB2485376
                               [09]: KB2505438
                               [10]: KB976902
    Network Card(s):           2 NIC(s) Installed.
                               [01]: Broadcom NetLink (TM) Gigabit Ethernet
                                     Connection Name: Local Area Connection
                                     DHCP Enabled:    Yes
                                     DHCP Server:
                                     IP address(es)
                                     [02]: fe80::6156:c400:59a2:c82b
                               [02]: Dell Wireless 1397 WLAN Mini-Card
                                     Connection Name: Wireless Network Connection
                                     Status:          Media disconnected