Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Limited or No Connectivity

  • I keep getting this error message on my Dell Dimension 4700 Desk top.
    Limited or no connectivity. You might not be able to access the Internet or some network resources.  This problem occurred because the network did not assign a network address to the computer. 
    When I try to repair it says : Windows could not finish repairing the problem because the following action cannot be completed: Renewing your IP address.
    I did try ipconfig and followed the instructions to release and ping the IP address. Didn't work.
    My desktop is connected to DSL - I have a laptop that runs through a wireless router - it still works and connects to the internet. 
    I have tried system restore. Didn't work
    I have called my internet provider - my connection is working. They talked me through resetting my internet connection.  Didn't work
    I have tried re setting everything by turning modem,router (Dlink 624 - but obviously this is still working ) and computer off (followed instructions 3 times) Didn't work
    Please help!!!
    Thank you so much in advance if someone can HELP ME!!! :smileysad:
  • I'm having difficulty understanding your setup.  You say that your 4700 connects to dsl and your laptop connects through a router.  Does this mean that you have the desktop connected to the dsl modem at the same time that the router is connected to the modem?  It seems to me that you should have the 4700 connected to the router and the router connected to the dsl modem.  How does the 4700 connect?  Is it by USB or ethernet?
  • Yes you're right, my Desktop is connected to the router and the router is connected to my modem.  It is connected by ethernet.
  • To help troubleshoot this problem, go to Start > Run and type cmd then click OK. In the command prompt window that opens, type ipconfig /all then hit the enter key. Write down the output from this command or select it and save it to a txt file, then copy this output into a reply to this message.
  • Steve,
    Output received:
    Windows IP Configuration
    Host name....... : lovemomanddad
    Primary Dns Suffix......: (blank)
    Node type ........:Unknown
    IP Routing Enabled......:No
    WINS Proxy Enabled.....: No
    Ethernet adapter Local Area Connection:
    Connection - specific DNS Suffix.... : (blank)
    Descripition.........: Intel(R) PRO/100 VE Network Connection
    Physical Address ........: 00-11-11-8E-15-D2
    Dhcp Enabled....... : Yes
    Autoconfiguration Enabled ......: Yes
    Autoconfiguration IP Address.....:
    Subnet Mask........ :
    Default Gateway ...... : (blank)
    Thanks for responding Steve!
    PS ...and don't try to tease me - yes the PC was a gift from my parents lol
  • Does the link light next to where you plug the ethernet cable on the computer and the link light on the router port both light up when the cable is plugged in at both ends and both devices are powered on?  Have you tried using a different LAN port on the router?  Have you tried a different ethernet cable?  You might also try temporarily disabling any firewalls running the computer.
  • Steve,
    Yes both link lights are on.  I have not tried another cable or used a different Lan port.  I will try that. 
    I have disabled Windows firewall and Norton and deleted Zone Alarm.  I disabled my connection, enabled it and also tried the repair tool.  This didn't work either.
  • Try a different LAN port first and see if that works.   You can also try running the diagnostics on the network adapter.  It should be in the All Programs menu under Intel Proset Network Diagnostics.   If that doesn't find any problems, try downloading and installing the latest drives for your network adapter:
  • So now I have tried 2 other Lan ports - no luck still!
    Tried finding Intel Proset Network Diagnostics - can't seem to find it in All Programs and I also did a search. 
    I will have to get a different ethernet cable. 
    Sorry to be a pain... but just want to make sure I'm doing this right...Device manager---Network adapters I delete the Intel(R) PRO/100 Network connection and then reinstall it?
  • If you go to that web page I linked in my last post, you can download both the latest drivers and the diagnostic utility.   Just download them, move them to the 4700 and run them from there to install.
  • I figured that's what it was - I went ahead and deleted the driver already still not working.  I will try the diagnostic now.
    Soon this computer is getting thrown out a window!
  • Don't throw it out the window!  If it is a faulty network adapter or faulty cable, they can each be replaced for about $10 - much cheaper than a new computer.
  • OK last attempt today!
    Driver deleted and reinstalled. Still no change.
    Diagnostic ran...not sure what to do next.
    Ran Diagnostics and PHY loopback failed and so did Link... so now what?
  • Hehe just teasing.
    K also did the Network Connectivity Test and it failed.  I will get a new ethernet cable tomorrow.  Hopefully that's all it is.  I've tried almost everything else. 
    Thanks again!
  • So, are the lights on when you connect the desktop with cable to the router?
    Why don't you tell us what are the network settings on the laptop which is working? Maybe the Desktop can't get the IP automaticaly because someone disabled the DHCP in the router?