Can't connect to internet after installing Windows XP SP2

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Can't connect to internet after installing Windows XP SP2

  •  - Have been using the Dell wireless set up with my laptop for the last 3 to 4 years with a 1150 Truemobile card and 1170 base station.
     
    - Was WEPsecurity enabled - but must have cancelled it because I noticed was not secured.  Decided it was time to fix it at the same time that I (finally) installed Windows XP SP2.
     
     - Since then, I can't get to internet thru wireless router.
     - DSL modem works fine - I can connect with wires
     - Wireless connection works fine - I can connect to base station. 
     - Device status seems ok - flashing lines between laptop/base station/DSL.
     
    - Took my laptop somewhere else - could connect just fine. 
    - I am relatively sure all my internet settings on the base station are fine (PPPoE)
    - have cycled power, reset modem, reset base station a million times.
     
    - I can send and receive email wirelessly
     
    What am I doing wrong?

    Message Edited by anna c on 07-28-200611:13 AM

    Message Edited by anna c on 07-31-200609:18 PM

  • So are you saying you can send email but Internet explorer will not connect?
  • Well I could but I can't any more.

    I put the same wireless card in my old Latitude and I can get to the internet thru it.

    Is the Truemobile 1170 not compatible with Windows XP SP2?
  • As far as I know all wireless cards are compatible with SP2
  • The 1170 is the wireless base station, not the card.  The card works,   because I can use it on the other computer (using Windows 98)