Venue 8 Power Button Problem since Creator Update - Windows Mobile Products - Mobile Devices - Dell Community

Venue 8 Power Button Problem since Creator Update

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Venue 8 Power Button Problem since Creator Update

This question has suggested answer(s)

I did the WIn 10 Creator Update the other day, and since then I've been having problems with the power button.  The normal pressing of the the button for a few seconds will no longer start it up. Based on a rather old tread I found, I've been able to get it working by holding down the power button for 10 seconds, releasing it, the pressing it again.  I'm not happy with that.

I 'm pretty sure this is a software issue, since once it's up and running, the power button works flawlessly for going into sleep mode.

Does anyone know of a fix?

Please don't respond with charger or battery solutions.  That is NOT the problem.  The battery is at 100%.

All Replies
  • Update - After hours of research into similar problems, I may be on to something.  

    If I turn off "fast startup", the power button seems to work normally again. I've tried shutting down and powering up several time with fast start up disabled, and so far it works.  Went back to fast startup enabled, and had to press the power button several times to boot up.  Disabled it again, and back to normal.  Of course it takes a bit longer to shut down and boot up.  I'll see how it goes over the next few days.

  • Well that wasn't the answer.  After being shut down for several hours, I had to hold th power button down for extended periods several times to get it to boot again :-(

  • Just to update further, this issue is still going on as in intermittent problem.  Regardless as to whether it is set for fast startup or not, sometimes it will boot up within 3 to 5 seconds some times it requires multiple times of holding the button down at various lengths of time.  It seems to fail the most after a long period of being powered down, but sometimes it will work correctly first thing in the morning.

    I can't say for sure if this was caused by the Creator update, or if it was just a coincidence.  Maybe it's the same issue that others have reported.

    A new twist is that this morning, while holding down the power button, the LED flashed amber, indicating that the battery was too low to start it up. However, on the next push, it booted up within a few seconds, and showed a 100% charge.  Confused   I did read in some forum, that a similar power up failure was caused by a bad battery contact.  I don't see how that is possible, but maybe a contact is somehow getting flaky. 

  • Continuing with my misadventures, after I last posted, I decided to go ahead a check for tarnish, or something on the battery connector that may be causing the problem.  I found a YouTube video that showed how to remove tha back of the tablet in order to replace that battery.  Good enough.  I carefully followed the instructions, and heard a sickening snap.  Sad  I had cracked the corner of the screen.  Furthermore, I still couldn't get the *** back of to see if there was a connection problem.  At this point, I was totally *** and frustrated.  I looked at today's Fry's Electronics promo specials, and saw that for today only, the Lenovo Miix 320, 10.1 inch, 64 gig. Windows 10 tablet with detachable keyboard was on sale for $129.  As I type, it is installing the latest Windows updates.  That 8" screen was too small anyway. 

    Once I got the Venue 8 Pro back up again (which wasn't easy), I saw that the crack was to the right and below the viewing area, so it would still be usable if I could depend on it powering up.  I might try to get to the battery again just to satisfy my curiosity.  I'll post back if I find something.  BTW, this Lenovo overcomes some of the Venues short comings.  It has a mini HDMI port, a full size USB port, and a separate power port.

  • Thank you for your message.


    Please try updating the BIOS to the latest version.


    Ideally, the bios have to be updated first & then upgrade needs to be completed.


    Click on this link www.support.dell.com enter your device service tag & flash the bios. Update bios even if you have the latest version. Make sure that the device has full charge while updating bios.

    Dell-Sreejith Ramesh
    Social Media Support
    #IWork4Dell
    Dell Support Videos
    Drivers and Downloads
    Driver order

     

  • I was on the latest bios shown on the web site.  I believe it was A14.  I twas on what ever BIOS it had long before the problems started.  At any rate, I can't do anything with it anymore.  When I attempted to open the case as shown in a YouTube video, in an attempt to check the battery, I cracked the screen.  At first it looked as if the damage was limited to a corner out of the viewing area, and the tablet still functioned (once I could power it up).  This morning the damage looked much more extensive, and after several minutes of trying to power it up, it no longer worked properly.  The screen was unresponsive to the touch, and it would start launching programs on its on.  I knew I was going to regret trying to open it, but it wasn't working right anyway.  I'm going to miss it.