Latitude 5175 Bitlocker issue - Windows Mobile Products - Mobile Devices - Dell Community

Latitude 5175 Bitlocker issue

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Latitude 5175 Bitlocker issue

This question has been answered by afanasievvv

Hello. Recently installing new BIOS .22 I have got somehow BSOD “CRITICAL_PROCES_DIED”. BIOS flashed successfully but on each time on start system requested Bitlocker code. So I switched Bitlocker off and decoded SSD. Now it works normally but I can’t switch Bitlocker back getting the message “internal error has occurred”. I’ve tried to clear TPM from BIOS but it doesn’t helps. SSD hardware test passed successfully.  

Do you have any suggestion how to fix the bug?

Thanks.

Verified Answer
All Replies
  • By the looks of it, BIOS ver .22 has been pulled from Dell's support site. I'd assume because the BIOS is half-baked and has issues. If you can, I would revert back to .20 until they fix it.

  • Thank you. I've tried this already before cleaning TPM. The issue persists. I think the key is in TPM settings or Dell security software.  

  • upd: Yes exactly this new BIOS is underdone, now it's disappear from Dell support. Today I've go a new BSOD in my collection "whea uncorrectable error" So I moved back to .20 version. Unfortunately BitLocker still not working...

  • New .24 BIOS fixed the issue with TPM.