Latitude 10 ST2 not recognising battery - Windows Mobile Products - Mobile Devices - Dell Community

Latitude 10 ST2 not recognising battery

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Latitude 10 ST2 not recognising battery

This question is not answered

I've had this problem for a while, but decided to revisit it in the light of this article from Dell blwo. In a nutshell, no battery I put into my ST2 (I have tried 3 different ones, one brand new) is recognised. The Bios & Chipset are at the levels indicated in the article below. However, MS Windows device manager does recognise that there is a battery present - just the Dell FW does not. Anyone have any ideas? I've tried all the usual battery-reset attempts but with no luck.

=

All Replies
  • Hi D8SMT ,

    Is the battery fail to charge?

    Could you please confirm the status of battery in BIOS?

    Also, please click my DELL-username and write me a private message with the service tag and your Name for case records.

    Let us know if you have any other queries.

    Dell-Vijay A
    Social Media Support
    #IWork4Dell
    Dell Support Videos
    Drivers and Downloads
    Driver order