Dell Venue 11 Pro (7140) won't turn on (another!) - Windows Mobile Products - Mobile Devices - Dell Community

Dell Venue 11 Pro (7140) won't turn on (another!)

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Dell Venue 11 Pro (7140) won't turn on (another!)

This question is not answered

There's been quite a few of these posts over the last couple of years...it seems to be a common problem. I had a 7140 and I let the battery drain (left it open overnight). The next day, I plugged it in, and saw the normal charging light. However, it wouldn't boot, even after I left it plugged in for several days. 

Now, I get no feedback from it at all -- no light when I plug it in, no haptic feedback, no nothing. It is completely nonresponsive. I've tried plugging it in via the USB plug (using the original, OEM charger) and via the dock connector (using a standard, OEM dock and power adapter).  Same both ways, so it's not the USB port itself that is the problem. 

I've read through the other answers on this forum, and I've tried unplugging the battery and re-plugging it in, and unplugging the battery and CMOS (labelled RTC on the motherboard?) and then re-connecting both of them, but neither of those changed anything. 

So, is there something else I can try? Would replacing the battery help? I wouldn't think so, and I don't want to sink another $50 or whatever into it if it's a lost cause, but I'd like to have it working again; it seems really bizarre to have it just fail completely just because the battery drained! 

Thanks!

All Replies
  • I should also add that I've tried holding down the power button for minutes at a time, and holding down the power button for a long time and then immediately pushing it again, either briefly or for a long time. Neither gives any response at all at this point, although for the first day or so after the battery drained I'd get a little bit of haptic feedback or a white indicator light that way.  

  • I have the same issue, can't believe there is no fix for this. Dude I got a dell :-(