Forums

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Dell Venue 11 Pro (5130 Atom Bay Trail) Stylus issue

This question is not answered

Hello,

I have gotten my tablet for about a week or so and I am really disappointed in the stylus which is a deal-breaker for me. It´s inaccurate and just not usable in a professional sense. Palmrejection sometimes does work and sometimes doesn`t. One day the stylus clicks where I tell it to and the other day it´s off by some millimeters, or just dancing around the tip of the pen. The stylus keeps writing although the tip doesn´t touches the surface anymore (see picture below) and so on...

I am a student and thought it would be a nice idea to have a tablet with a digitizer to take notes with a stylus during class and write directly into the script of the profs, but atm it´s just not possible and as far as I have noticed, I´m not the only one who thinks this way. 

I have taken these pictures to show you what I mean. On the top I drew some lines with a ruler. The bottom two lines show how it could and should work (aside from the end of the lines where it just points in another direction). The rest of the lines are just plain <ADMIN NOTE: Substitute character removed as per TOU> and I want to point out that I didn´t rush to draw these lines, I did it in a calm and slow motion.

I just don´t get how DELL could release a product which is clearly not ready for what it is meant to be and has bugs all over the place. 

Here are pictures of me trying to write and another to show you that it is not just my handwriting that sucks.

My final question is, is this a hardware problem or just a software problem ? If software, are firmware-updates coming out in the near future ?

PS: I´m from Germany so if some parts I wrote sound weird, that´s why ;D

All Replies
  • Hardware problem. They tried working around it in software, but there's only so much that can be done there.

    Good news is that it is something you might be able to fix yourself:

    http://forum.tabletpcreview.com/dell/59959-dell-venue-8-pro-active-stylus-fix-me-least.html

    Beyond that, Dell has promised a fixed version in some nebulously defined near future.

  • Thanks for your reply. That´s too bad, I really like my Venue 11 Pro, but the stylus is an absolute must for me. I don´t get how Dell didn´t see the issue with the stylus. As for your link, I will try it and see how it works out. If it still doesn´t work, which I think will happen, I`ll wait til the fixed version comes out and wait  for reviews on that

  • Hi, did the new firmware proposed in february solved your problem? Do you have the Rev A00 or Rev ao1 stylus?

    Regards.

  • No, sadly it didn´t. I installed every update that Dell would throw at me over the last 4 months, but not one made a difference. And since Dell won´t or can´t change anything about how the stylus works I´m now selling my Venue Pro and hoping that my next tablet will do a better job. For me this tablet was the first and last I ever purchased from Dell.

    Hope you´ll have more luck. Regards

  • Thanks for the feedback. Really sorry for you. Do you have the A00 or A01 stylus? the problems which appears on the pics seems really related with a spongy spring of the nib, specific to a lot of A00 stylus.

  • Just to add, in case you weren't following other threads, for some reason dell haven't released the latest touchscreen firmware for the 5130, but you can install the march update for the 7130 on the 5130, and it makes a huge difference.

  • I tried the new drivers, but the touch response goes away and I miss regular touch response.  and will the the updated 5130 I have issues with the stylus stops working.  so I have to choose good touch performance or ok stylus performance

  • I find something similar - touch response was better before the update, but stylus is far better afterwards. Hopefully Dell can get this sorted soon....