Dell Venue 8 Pro WiFi Issue

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Dell Venue 8 Pro WiFi Issue

This question is answered

it seems either way I disable the Wi Fi by the 'switch' itself or 'Airplane' mode it is a pain to get it on and have to manually 'disable the entire WiFi and then enable it joggin the WiFi off and on til it seems to catch on I am trying to turn it back on. I am only trying to turn it off to save battery right now but is this normal? Will a fix be forth coming because i'ts a pain right now.

All Replies
  • Would it possible to post the Wireless Adapter Driver version it shows for you after the update?

    TIA

  • Driver Version 3.7.2.45425

  • Ha my WiFi stopped working today. I guess I'm not so lucky. I hope dell fixes this soon.

  • I have started four Dell Venue 8 pro tablets since November 14: two 32GB both with great WIFI, and two 64GB from Costco both with serious WIFI issues.  Both Costco 64GB tablets have intermittent connectivity and weak signal out of the box, and the same behavior using the updated Dell Qualcomm Atheros WIFI driver.  Windows Updates do not help or change anything.  Both 32 GB tablets have perfect WIFI with no drops and excellent signal.

    The 64GB WIFI was so bad out of the box it took several retries to logon with a Microsoft account and set up Windows.   The network connection kept dropping during the 64GB tablet setup while the 32 GB tablet sitting right next to it had 100% signal.  Forget about downloading Dell drivers. I had to download the drivers using a different pc (the 32GB tablet) and transferring them via Micro SDHC card.

    There are some differences between the 32GB and 64GB tablets.  The 32GB mother board product is 09RP78 and the 64 GB mother board product is 0RK4PK. The Dell Wireless 1538 adapter is the same, supposedly.  Also different are the available wireless network security options at Control Panel> Network and Internet> Network Connections> Network Properties Security tab:

    The 32GB tablets have Security Types: Open, WPA2-Personal (default), WPA2-Enterprise, 802.1X, and CCKM.  
    The 64GB tablets have Security Types: Open, WPA2-Personal, WPA-Personal (default),  WPA2-Enterprise, WPA-Enterprise, 802.1X, WAPI Certificate, an WAPI Shared Key.  I'd prefer to use the more secure WPA2 security if possible, which is the default setting on the 32GB tablets.

    When I change the 64GB tablet security setting from WPA-Personal to WPA2-Personal it renders the WIFI inoperable.  Cannot connect to my 2Wire router at all.  Once the security setting is changed to WPA2-Personal you can no longer access the Network Properties Security tab to change the security setting back!  Are you serious?  The only recourse to regain WIFI connectivity is to start over and reload the operating system from scratch. Sad  There may be a registry hack but I'd prefer to not go there.  Reinstalling the driver does not change the security setting so it's not an option.

    Does anyone have a solution for the newer batch of 64GB tablets supporting stable WIFI connectivity and WPA2 security?  I would expect this is not a hardware issue but rather a combination of drivers and Windows 8.1 software? 

    I'd love to keep the 64GB tablet but come on, bad WIFI out of the box, frustrating startup, and no way to fix it on two tablets in a row?
    After investing a couple of days on this, maybe I'll return them all and wait until the bleeding edge pains are over.  The 32GB tablet is fantastic and stable but does not have enough storage to justify keeping the device.

     

     

     

     

     

  • The 64GB tablet lost WIFI entirely today.  I even rebooted my U-verse 2Wire gateway to make sure it was not a network problem.  5 computers and 2 phones connected no problem most using WPA, and my other Dell Venue 8 Pro 32GB tablet using WPA2.  Resetting the 64GB tablet now fails to initialize Windows since an internet connection is required, so I cannot perform the setup.  Back it goes to Costco Monday morning just like the previous one.  At this point I'm keeping my 32GB Venue 8 Pro since the WIFI is solid from day one and it's stable. 

  • Could it be your 64GB models are (or originally were) devices for the Chinese market?

    As far as I know, WAPI is a Chinese Mainland only wireless security protocol (required by Chinese authorities to be installed on all devices operated in China). My US market 64GB Venue 8 Pro did not come with WAPI installed. The wireless encryption methods available on my 64GB model are exactly those you see on your 32GB models.

    You might be able to just un-install the WAPI components (they are an optional download on Dell's support page for my Venue 8 Pro) and see if that improves things.

    __________________________________

    drahnier (Latitude 10, Venue 8 Pro 64GB, 2x Venue 8 Pro 32GB)

  • I have the same problem with 2 brand new Dell Venue 8 Pro 32GB.  I tried one out of the box, and one with all updated drivers -- same challenge.  It does look like it's related to connected standby but I've had cases where I was browsing then it simply stopped.  I can see other SSID so the adapter's still available.

     

     I have a DLINK and a Cisco router -- both are experiencing this issue -- but only with the Dell Venue 8 Pro -- all other devices are working fine with wifi.  Any update on possible driver updates?

  • Same here on the Dell Venue 11 Pro (which has the same wifi adapter and same 45425 driver, which I have uninstalled and re-installed multiple times along with the Trusted Execution driver and chipset driver and display driver). I have a Linksys E4200 wifi access point, but I have taken the tablet on two trips now where I've used it with unknown models of hotel and airport access points, and same problem. I also agree that somehow it is connected with Connected Standby not working. From another computer on the network I can see when it loses its connection, and it is impossible to wake up the connection again remotely. The tablet is set to never go to sleep - I think only the wifi adapter is going to sleep. It doesn't wake up unless you disable and then enable it, either from the charm or sometimes from Device Manager.

    One difference I have from your experience is I have never seen this happen when I'm actively using the tablet. I only see it when the tablet is sitting unused for at least a half hour. But this time interval is variable and sometimes it stays awake for several hours before falling asleep.

    It seems from following a couple of different forums that a lot of people are having this problem and Dell has not come up with a solution yet. A couple of people have tried exchanging their tablets for new ones, and the same problem still arises on the new ones. I hope Dell is at least looking for a solution. Maybe it will help with the Miracast problems we all are having, too.

  • I bought both 64GB tablets at my local Costco store, so I doubt they would be configured for the Chinese market.  Taking the second one back today since the WIFI is no longer connecting at al.  Wondering if it's worth the hassle of trying yet a third device.  I Really would prefer the 64GB even though my 32GB tablet is stable and has solid WIFI.  I certainly do not plan on contacting Dell support and living through the offshore shuffle.

    User MaximeB just reported similar WIFI issues with two 32GB tablets, so maybe it's not a difference in the mother boards or Dell WIFI adapter.

    MaximeB.  Can you please check the Security setting and available Security Type and Encryption Type values on your 32GB tablet's WIFI connections?

    Access the info by selecting: Control Panel > Network and Sharing Center > Change Adapter Setings > double click the WIFI connection > select Wireless Properties > Security tab.

    Is the current setting WPA2-Personal? or WPA-Personal?  Are both options listed in the drop down?

    Is the encryption type AES? or TKIP? Are both options listed in the drop down?

    Thanks

     

     

  • I'm currently traveling for a few days but I'll check with someone at home tonight.  If I remember right, it's WPA2-Personal with TKIP+AES (or just AES)

     

    Is this for troubleshooting or is there a preferred settings to have?

     

    note: right now, at my travel location, it's using WPA2-Enterprise with AES.  it's been running fine for 2 hours, including some time that it should have gone on connected standby.

  • Ajdellaj, not sure if it is useful for you to know this for a 64GB Venue 11 Pro, but I followed your instructions and the answers on this device are:

    Security type is WPA2-Personal. WPA-Personal is not available on the drop down. The other options listed are No authentication, WPA2-Enterprise, 802.1X, WAPI Certificate, and WAPI Shared Key.

    Encryption type is AES and this is the only option offered on the drop down.

  • Thanks PAULINBELLVUE. That matches the available WIFI security options on my 32GB tablet that is working perfectly with 100% signal and no dropped connectivity, even after sleeping for hours.  It wakes up and is perfectly connected to WIFI.

    I read that Microsoft dropped the WPA security options from Windows 8.1.  Maybe Microsoft has now put the WPA security options back into Windows 8.1, and broke the software in the process of doing so.

    It seems that the tablets configured with the additional WIFI security options including WPA-Personal may have a different version of Windows 8.1 installed out of box.  Dell drivers don't seem to make a difference.   I'm leaning toward trying a third 64GB tablet and taking it to a place with a different WIFI  than my home(Starbucks or the library), set it up there and see what WIFI options are used to connect, and what options are listed.

    Does anyone know if there is a way to interrogate the available security and encryption options in Windows 8.1 while there is NO WIFI connection?  So far I can only get to these settings when a WIFI connection is active, which is apparently normal.  My brand new Dell XPS 8700 with Dell 1703 wireless adapter running Windows 8 behaves the same way.  The WIFI connection must be active to see the available security and encryption settings.  The XPS 8700 shows ALL security options available and connects perfectly using WPA2-Personal and AES.

  • All this talk about Wifi connecting issues but I hear NOTHING about the radiation problems with it ???

    Have you tested your unit ??

    I tested my Ipad 8 & it pulses out every 6 to 10 seconds & some times with a double pulse.

    It reads at levels up to 11,000 uW/m2 with wifi on  !!!!!    My cell phone when in use reads ONLY about 5 to 121 uW/m2 .

    That's almost 100 times greater radiation levels & at almost a constant output while you use that IPAD.

    I became dizzy & nauseated within 5 minutes of being near it. I bought these Ipads as gifts for my grand kids but will in NO WAY allow them to use them & will now return them. Do you know what damage or harm you will be doing to yourself or your kids ??  Google "Dangers of Wifi".

    RS

  • WTF? iPad 8?

    Sounds like you misplaced your tinfoil hat!

    (and only one post, eh?  take your fear mongering elsewhere pls)

    rschranz

    All this talk about Wifi connecting issues but I hear NOTHING about the radiation problems with it ???

    Have you tested your unit ??

    I tested my Ipad 8 & it pulses out every 6 to 10 seconds & some times with a double pulse.

    It reads at levels up to 11,000 uW/m2 with wifi on  !!!!!    My cell phone when in use reads ONLY about 5 to 121 uW/m2 .

    That's almost 100 times greater radiation levels & at almost a constant output while you use that IPAD.

    I became dizzy & nauseated within 5 minutes of being near it. I bought these Ipads as gifts for my grand kids but will in NO WAY allow them to use them & will now return them. Do you know what damage or harm you will be doing to yourself or your kids ??  Google "Dangers of Wifi".

    RS

  • Hi,

     

    I'm using WPA2-Personal with AES at home.  Wifi breaks often with that, but funny, so far, while traveling with either WPA2-Enterprise or open (hotel), no problem...

     

    @Ajdellaj, you are using WPA2-Personal with AES and it's working fine?

     

    I'll try changing the router's configuration when I'm at home to see if it fixes -- but I would think that WPA2-Personal+AES is probably the best I can (easily) have at home, no?