Dell Venue 8 Pro not charging?

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Dell Venue 8 Pro not charging?

This question has been answered by jfreiman

I purchased this from amazon and it came fully charged. I used it for roughly 3 days and I let it die last night watching a video. I left it charging 3 hrs today with the device off and when I powered it on the batter only says 2% charged. I am using the provided charger that came with the device and the light is on when it is charging

Verified Answer
  • Another problem may be the extremely poorly designed Port on the Venue..  It has a USB Micro-A Port, and they ship a USB Micro-B plug.  Sure, the plug works, but the port is rectangular and the plug is trapezoidal.  (See attached Pictures)..  Kinda like putting a round plug in a square hole.  It can be plugged in either way, but only works one way, and if you plug it in wrong, you may break something.  A hint would be that the USB image on the plug itself needs to be facing the FRONT of the Venue when you plug in..  Wide part of the plug down, narrow part of the plug up.  

    Also, the document kind of shows a contradictory picture of the USB plug.  It shows the metal part of the plug upside down..  Anyway, see the two pictures that I've attached for clarification.

    Thanks,

    BigDellDude

      Narrow Side is supposed to be UP.

  • my Father had the exact same problem.  We called Dell Support and after some discussions the representative said they would send out a new unit.  The rep was nice, but it seems a shame that Dell could not get this correct.  This seems so basic, and I have to give their technical design staff a 0 out of 10.

  • Dell supplied the wrong charging cable. The port is rectangular and the plug is trapezoidal so it can be plugged in either way, and if you plug it in wrong, you can bend or break the pin block. I handed mine to my wife to see which way she'd try to connect the cable and she immediately tried plugging it in upside down. This is a serious design flaw and Dell needs to recall them all and replace the connector. There's no way in this day and age of computing that it should be possible to plug in a connector upside down like this and then destroy the device. It's only a matter of time before every one of these Dell Venue Pro 8 units is damaged because of this issue. Dell screwed up the design and customers are paying for the mistake. This is 100% Dell's fault. They need to make it right.
  • Add me to the list of unhappy users with broken USB ports.  Broken from normal charging use.  I plug it in to charge it and it bent the pins.  This is not considered abuse.  Dell is going to be shipping a TON of Venue 8 replacements until they finally replace this port with the proper port.  Meanwhile, gradually losing their customer base.

  • I just received the "repaired" tablet back from Dell and opened it up.

    SAME INSANE MICRO USB TYPE AB CONNECTOR AS ALL MY PREVIOUS LEMONS.

    ALSO, WINDOWS REGISTRATION IS BLOCKED BY MS SERVER, SO ITS USELESS -- AGAIN.

    At what point will Dell give me a refund?????   This is a nightmare -- and I've lived through actual "nightmares" and traumas.

All Replies
  • Same exact problem. I just bought the tablet yesterday. It came charged and I used it all of about one hour. It died. I plugged it in using the supplied charger and nothing. The charger light was on and is no longer and I can't get it to power up.

    So, while I  appreciate your detailed response, how can I do that when I can't get the tablet to power up again? 

    I am on a business trip so this is incredibly inconvenient. As of now, I plan to return it when I get back home. 

    <sigh>

  • On a practical note, I would suggest trying to exchange it for a charged one at a Microsoft store or elsewhere, explaining the whole thing. Honestly, I think that being unable to charge it is a sufficient explanation itself. And then, having got a new one that comes pre-charged, you can follow these simple steps and live happily ever after :-)
    I am afraid I do not have an answer to that exact pressing and terrible problem... I am not with Dell, and if I was, I would have implemented that minor fix as part of the pre-installation. Still, having overcome this problem, I like the tablet a lot, as it offers an incredible combo of a great Full HD screen, light weight, and complete Windows functionality combined with a very affordable price that no other offering on the market has. I also think that the one with  Atom is the best, because one can find better alternatives to pricey i3 or i5 ones or ones with bigger SSDs.
     
    Kind regards,
    Leo
  • Thank you, Leonidg. That is certainly a more positive and practical way of approaching my frustration! Much appreciated and I'll give it a try. I also like the tablet a lot (from my brief encounter with it) and I use all the same apps for work on my Windows 8.1 Sony Vaio. It is perfect for work. Thanks, again!!

    cheers,

    Aimee

  • I have the dell venue 8 pro and I can't see the dell command power manager on my dell support page, there is a bios update and some other update but not the "command power manager .... can anybody send me a link where I can download this app for my dell venue 8 pro. Did anybody solved this problem for the venue 8 pro? 

  • Here are the links for those who missed them. Please look at the version of Windows you have installed first!

    64-bit version (1.0): http://www.dell.com/support/drivers/us/en/19/driverdetails?driverid=1NX71 (haven't found 1.1 so far)

    32-bit version (1.1): http://www.dell.com/support/drivers/us/en/19/driverdetails?driverid=15FFG

    Enjoy!

  • Thanks Leonidg, but installation of the file you link starts but   will not finish... I am sure there is a conflict with another file already installed on the dv8p. If you look at the IMPORTANT INFORMATION at he link of the download page ... It says ...

    DCPM is a successor to Dell Feature Enhancement Pack (DFEP). DPM and DFEP should not be installed on the same system"
    Leonidg, you think this is the problem, where is  the DFEP on my dell and  should I cancell it in order to install the file you link DELL COMMAND POWER MANAGER ?
  • Hello,

    I am not sure I can resolve this remotely :-). Can you tell me your Express Service Code or Service Tag, so that I could double-check the Dell support site? Also, do you see any traces of DFEP installed on your system trough Control Panel (Programs and Features)?

    Honestly, I do not think that preinstalled software should be different on your Venue 8 Pro and my Venue 11 Pro, and I had no problems installing the DCPM, but it was a recommended install, that's how I discovered it. So seeing your config and available SW might help...

  • the message when it stops the installation is telling me :

    The target system can  not be identified as a Dell Power Mananger supported system. the installation will exit.

    my service tag is :  

    <ADMIN NOTE: Service tag removed per privacy policy>

    thanks for your help

  • edit

  • Hello,

    I've looked at youth available installs, and strangely enough, despite the systems being similar in most aspects, yours (8") does not support the Power Management app (which explains the broken installation).

    I would humbly suggest to install a couple of updates, primarily the BIOS update as of 11/26, as it might fix the problem. I would also install the Intel TXEI driver, the URGENT Panel Touch firmware update, and a couple of Network ones. But the BIOS one might fix it for you - this whole problem is most probably due to the inability of the computer to activate charging (it works and does not discharge when connected to the power adapter)...

    All the best of luck!

    Leo

  • Leonidg, I think the file you linked is not compatible with the dell venue 8 pro.... look at the compatibility list .... dv8p is not there, this is why is not installing... do you have a link were I can download the file compatible with dv8p please?

    Systems
    Dell Venue 11 Pro (5130)
    Latitude 3330
    Latitude E5440
    Latitude E5540
    Latitude E6440
    Latitude E6540
    Latitude E7240
    Latitude E7440
    Precision M4800
    Precision M6800
  • thanks, I did the BIOS update yesterday and still is not working, I an going to do the other updates you suggest , finger crossed. it is amazing that dell is releasing a tablet with this kind of problem....

  • I did all the updates you suggested and is now charging ... god bless leonidg... thanks a lot, I hope the problem won't come back.

  • This assumes you can get the darn thing to power up in the first place. I'm in the same situation as others here. Worked for a couple of charge cycles now absolutely nothing. My problem is I live/work between the UK and the US. I bought it in NY and then travelled back to the UK for an extended holidays stay. I won't be back til the new year. This is where Dell falls flat on it's face. Dell UK won't provide ANY support for a US bought product. You can't even get email support. Hopeless! I had a similar problem with an Asus Ultrabook and they provided support anywhere. Dell - learn a lesson! As it stands I now have to wait until I'm back in NY in January before I can get mine replaced.

  • I am sorry, obviously you didn't install any of the updates I did or did you?

    It did work for me after the updates of the BIOS and the others  ... but the charge did go only up to 99%  I was waiting quite a lot for it to go to 100% but it didn't and still it was showing 99% then it went from 99 to 98 % and I then unplugged it, so really it is not working all that well but al least now s charging... before the updates it wasn't.