Dell Venue 8 4.4 KitKat glitches - Android Mobile Products - Mobile Devices - Dell Community

Dell Venue 8 4.4 KitKat glitches

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Dell Venue 8 4.4 KitKat glitches

This question has been answered by Chicago_Jeff

I got the update around 12am CST. Since then I have noticed the following:

Random screen freezes

SD card not registering

Apps not working

Lower tolerances to internal heat build up

Jerkiness when scrolling on the web and Facebook.

Does anyone know if Dell did a soak test of this build before they released it?

Verified Answer
  • Hopefully that screen shot uploaded correctly.  Does anyone else have an image like this when using Streetview in Maps?  This is another bit of 4.2 weirdness on my Venue 8.

All Replies
  • My micro SD card will not mount at all since the KitKat update.

    I haven't discovered any other issues as of yet, though.

    Thanks for starting this thread.

  • I felt it need a good bug list. I have read of others getting the KitKat update and the tablets bricking. I have a feeling the list will get longer in the next 24 hours as more people update.

  • New glitch, Venue 8 will not charge past 60%. Worked great before the update, now my device is beginning to be plagued with bugs.

  • Duplicate posting not allowed. Only use this one:
    http://en.community.dell.com/support-forums/mobile-devices/f/4585/t/19582798.aspx

  • i feel you, unfortunately there is not much we can do about it now... fortunately I tried rebooting it like a million times and the freezing has stopped. I just noticed that the new update messes around with your apps. i.e. VLC suddenly stopped playing videos due to some hardware issue created by the new update. on the other hand, since the SD card is read only, the torrents stopped working as well... after experimenting for a long time i managed to download torrents on the  tabs memory using apps from the playstore wont work. Hope we get another update soon!

  • I'm not sure why people say the sdcard is read only in KitKat.  Maybe I'm not understanding something.

    I opened a word file stored in dropbox using kingsoft office

    Edited the file

    Created a "documents" folder on sdcard1 using esfile explorer.

    Chose "Save as"  my word document to my new folder.

    Went to the folder using esfile explorer, found the file and  opened with kingsoft. It all seems to be working fine to me.

  • I think that they are experiencing the new lame "security" feature where apps can not longer full write access to the card unless they belong to a specific group, I think it is media_rw.

    There are work arounds for that, but unfortunately I am in the "No external SD at all" category. With 4.4 the external is not recognized at all no matter which microsd I try. If I revert back to 4.2 it works fine.

  • I'd recommend that anybody experiencing excessive glitchyness with the kitkat update do a factory data reset.

    Just start with a clean install and reload your apps.  Also make sure your date, time and time zone are correct.  I would think that should clear up any possible compatability issues with apps etc.  If you are still having problems after the reset it is more likely caused by the update.

  • Yeaah same is happening here..its restarts again and again...heats up...and hangs since i've updated it

  • Did a factory reset.

    Reloaded everything.

    Still having the same issues.

    Can't quite understand how it can mess up this badly.....

  • Mine was freezing up after the update.  Dicovered my time zone was wrong.  Reset the time zone and everything works perfectly now.

  • I've also had problems with the 4.4.2 update:


    Screen freezes

    Black Boxes appear when scrolling in several apps and even the home screen

    Apps crash

    I've reset it to factory settings, but the problems remain

    I also tried resetting the date and time, per another commentator's suggestion, without any luck


    Please help, Dell!

  • Add random restarts and screen dimming to that list.

  • I successfully updated to 4.4.2 as well.  It has not been as stable and smooth as 4.3.  I have some similar bugs as others:

    1. Web browsers and selected apps with embedded web content have random black boxes covering portions of the app (e.g. Browser, Amazon, Play Newsstand)
    2. Some but not all attempts to expand to full screen video cause the tablet to reboot
    3. Periodic error message of com.android.systemui has crashed; resets my walpaper to the default and on screen navigation buttons no longer display;  have to reboot to restore navigation
    4. WiFi periodically turns off and will not turn back on in settings; reboot device will enable WiFi
    5. No longer able to connect to HMA VPN

    Anyone who has not updated from 4.3, I would recommend that they wait until Dell has further Kit Kat updates ready.

    Jeff

  • You nailed it Jeff.

    Thought I was the only one with the exact same problems.

    Waiting on a fix and have advised my wife to delay update on her Venue 7.