Forums

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Android 4.3

This question is not answered

Receiving Android 4.3 update now on Dell Venue 8! Thank you Dell! Even more happy with my purchase now! 

All Replies
  • Just recently got my Dell Venue 8 Android.  It indicates it is running 4.2.2.  I understand you received 4.3 (Is that Kit Kat?).  Did you need to do anything to get it, or does it automatically update when Google/Dell whomever pushes it to the device?

    Thanks

  • I went to Settings >About Tablet > Software Update and clicked on Check for Updates and it began to download the software. I'm pretty sure Android 4.3 is still a version of Jelly Bean,  4.4 is Kit Kat.  Good luck! 

  • I guess we in Canada, as always, are going to have to wait ;-)  I just checked and tried to do a System Update. It indicated I am current, and yet I am still seeing 4.2.2. on my info page. I imagine Dell is pushing the update out slowly, or perhaps the update for Canada isn't ready yet.

    Thanks for replying.

  • Yeah,  it's a fairly new device so I'm even surprised I received an update before next year. Not too many changes but Android Trim support should help with the speed on the tablet.  I think that's pretty cool. 

  • im in Halifax NS and I had my venue 8 since last week future shop sale (149) and I updated to JB 4.3 about 2 days ago. the update is there you just have to click check maybe a few times and if not reboot device and try again.

     

    btw do you have the touch screen freeze issue that a lot of people are facing as well?

  • After the update, when you go to Settings>About, what version does it say?  Mine still says 4.2.2.  Any way I can tell if I really have 4.3?

  • If you c 4.3 you have it if not then you don't, when you check about tablet system update you have to hit check now to start the process it should update found android 4.3 then just click and DL it   there was another update prior to this one it was about a 6 MB file size if you already downloaded  and installed that do it again and it. Should. Be The. New. One 

  • I also bought the Venue 8 at FS, the first day of the sale (they sold out by the next day).  I'm on the West Coast of Canada.  When I tried to update, the tablet using the steps indicated,  it indicated "your system is up to date", but it was still reading 4.2.2.  I am going to try again now....  I just tried again, and when I hit the "Check Now" icon, I get that same thing, only the time of the check changes to current time.

    Very odd...

    No, my touch screen has doesn't freeze, however it is a bit non-responsive at times, particularly around the edges of the active screen area near the corners.  But that might also have something to do with the apps I am using.  Hard to say...

  • I exchanged mine yesterday because of the screen freeze issue  and now  it's working perfectly,  when I try to update to Android 4.3 system doesn't show update available,  but this leads me to believe since the update on my other venue 8 file size was only about 165 or so MB which  ISNT A full firmware size,  I'm thinking dell pushed  that out to users who were experiencing  issues with their devices or something 

     A few Ppl  on here said they didn't get the update  but their screen isn't freezing  do I dunno I'm cool with 4.2.2 for now knowing 4.3 is coming now especially that the tablet works the way it should now 

  • My tablet downloaded the update for 4.3 last night. I hit the button for "Reboot and Install" nothing happened. I powered it down, and back up again, still nothing. Look in About tablet, still version 4.2.2. Check for updates, "System is up to date." I am totally lost and a little irritated at this.

  • I had the same thing happen.

    I did a system reset in hopes that would help, no dice.

    Very annoying.

  • Check , make sure that your battery level is above 30 %.

  • it is/was fully charged. was fully charged when I downloaded the update initially. It downloaded 165 MB of update and asked if I wanted restart and install it. I clicked on restart and it just dropped back to the system update page claiming it was up to date

  • Same with mine, it was fully charged and I left it plugged into the charger anyway just to be safe. It did the same thing that happened to Rob.

  • Really good question as to how one is supposed to know if the info screen still indicates 4.2.2. 

    I *think* my unit did an update also, as many people have reported, it did say one was waiting for me, and it appears it downloaded something after I asked for updates on the info page, although it was pretty fast for 165MB, and then it indicated my system was up to date.  However, the info is still reading 4.2.2.

    In another thread I started about the rear camera quality, someone indicated that 4.3 would make some improvements, but I don't see any difference in the camera image quality, so I have no idea if 4.3 is really installed or not.  So far my system has not indicated any "other" updates for the IS are coming or available.  Don't know what that means.  Also, my tablet was nearly at full charge when all this happened.

    The more I am seeing Android at work, the more I realize open source needs a gatekeeper. ;-)