Venue 8 - Automatically cuts off at 20% - Mobile Devices Forum - Mobile Devices - Dell Community

Venue 8 - Automatically cuts off at 20%

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Venue 8 - Automatically cuts off at 20%

This question has been answered by LynnTexas

I have a Dell Venue 8 7000 that is just out of warranty (of course) at being just over one year old.  Recently it has started cutting off instantly at 20% battery life.  It no longer alerts me to the battery saver option which should pop up at 15%.  It just cuts off and cannot be powered on until I plug it in.  When I do plug it in, it says 20% life and charging.

Is there any fix to this?

This tablet was a gift to me to help during my sister's cancer treatments and doctor visits.  I travel with her over an hour each way to the hospital and spend up to 14 hour days at MD Anderson waiting between appointments or getting various treatments/tests done.  This tablet helps keeps us sane and distracted during long days.

I worry it is on its last legs though despite being only a year old.  I can't afford a replacement as even this one was a gift.  Is there any fix for this or answer to what is going wrong? I don't want to lose it.

Verified Answer
  • Bumping this in case any users have suggestions.  Still searching each day for a way to fix this. :(

All Replies
  • Hi LynnTexas,

    Thank you for writing to Dell Community Forum.

    Please update the BIOS to the latest available version from Dell Support site.

    Please click my DELL-username and send me a Private Message with the Dell Service Tag number and your email address.

    Note: please don't mention the service tag or email id on the public forum as it contains your personal information

    DELL-Akshatha M
    Social Media Support
    #IWork4Dell
    Dell Support Videos 
    Drivers and Downloads

  • I would consider having a local computer store replace the battery. But first, try Step 1 here.

  • @Dell-Chris M

    Thank you for the response.  I did try that already and it is still cutting off at 20%.  I figured even though I don't install much on there, maybe an app was causing a problem.  The factory reset provided no such luck though.  I'd do the battery replacement but I can't afford it.  I'm spent as it is helping with my sister.  Not to mention the cost of the battery ($62!) and service fee to get it fixed could probably just net me a new Kindle if I even had that kind of money.  I really wouldn't want one, but at least the one my mother has lasted longer than my more costly Dell.

    @DELL-Akshatha M

    I'll get the service tag to you as soon as I can.  I am hoping it is listed with the Dell account of the person who gifted it to me.  Even with my tablet being in a hard protective case since I got it, the info sticker on the bottom was quick to fall off.  I'll see if I can get the tag.  It was a newly purchased device direct from Dell, not a third party, so hopefully the person who gifted it to me can help with that info.

    Also, I have the 7840 Android version.  I'm not seeing anywhere to update a BIOS.  The system update says there is nothing new to get though.  If I go the recovery mode for the device, all I see there is "apply update from ADB" which doesn't sound right.  If that is it, let me know and I'll give it a try.  I had previously gone to this menu though to try "wipe cache partition" as suggested by another user, but the device is still cutting off on me.

    Thank you both for the responses so far. Any help is greatly appreciated with this.

  • @DELL-Akshatha M

    I sent a private message with my email and service tag as requested.

  • Bumping this in case any users have suggestions.  Still searching each day for a way to fix this. :(