Windows 10 Anniversary Update Dell Latitude 12 Rugged Tablet (7202) - Mobile Devices Forum - Mobile Devices - Dell Community

Windows 10 Anniversary Update Dell Latitude 12 Rugged Tablet (7202)

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Windows 10 Anniversary Update Dell Latitude 12 Rugged Tablet (7202)

This question is not answered

The Windows 10 Anniversary Update seems to have caused some further issues on my Dell Latitude Rugged Tablet 7202.  I was hoping that the update might fix my existing issues (fingerprint reader, CVUSBDRVBus_513, GPS, etc.) but instead, it has created more.

So far what I have noticed is that after installing the update, the Active Pen stopped working. This was resolved by reinstalling the driver.

Same results with the Rugged Control Center.  It tries to load but get stuck at the title screen.  Reinstalling the Rugged Control Center seems to fix it.

Also, there are now 2 items listed under "Other devices" in Device Manager:

  • BcmNFCBus_257 (new)
  • CVUSBDRVBus_513 (pre-existing prior to the update)

Does anybody have any suggestions for fixing these devices?

I am still reviewing my device for other issues. The tablet has been listed as being test for the Anniversary update found on the list posted here:

Has anybody else experienced any issues with the Windows 10 Anniversary Update on the Dell Rugged Tablet?

Mike

All Replies
  • Hi Mike64738,

    Thanks for posting.

    Apologies for the issues you've been having with your tablet.  According to the Dell OS compatibility website, it appears that the Latitude 12 is not supported for Windows 10 Anniversary.  

    Have you backed up your data and tried a factory restore?

    Post back if you need additional assistance.  Thanks.

    Regards,
    Robert

  • Hi Robert,

    Thanks for your reply.  First one since I posted this on August 10th.  

    The Latitude 12 is listed as being supported, but under "Latitude 7202 Rugged Tablet."  I still have an outstanding ticket with Dell and my issues are still unresolved.  

    Out of the box, the tablet had issues, but was partially functional.  The issues were mostly due to Windows 10 being installed, and at the time, not tested by Dell.  It should not have shipped in that condition.  Unfortunately, I could not downgrade to a tested version of Windows (7 or 8) since my order shipped with licensing for Windows 10.  I was hoping that the Anniversary update would have resolved my issues, alas, it did not.

    I have been back and forth with Dell support going through various factory restores, driver updates, driver reinstalls, bios update, etc., without much success.  Much of my time has been wasted, especially considering that support is on the other side of the world (Philippines.)  We were supposed to have another troubleshooting session last night, but they never got back with me regarding scheduling and the technician I am working with keeps going on vacation.

    I'm at the point where I'm hoping I find an undocumented workaround to deal with the issues, kind of like what I did with my Alienware M18x R2 laptop.  I was able to workaround those issues based on feedback from a 3rd party user community, not from Dell (again, more wasted time.)  I'd really like this tablet to work for me in the field and I need it to perform when it is expected to perform, but at this point, it is not ready and I do not trust the reliability of this device.

    With all of the man hours I have spent researching and supporting my Dell devices (desktops, laptops, PDAs, printers, tablets, etc) over the years, I probably have enough experience to be a level 3 support technician.

    Mike

    p.s. My current gripe at the moment is the random behavior of the 7202 when coming out of sleep.  I'm not sure if it is going to wake up properly, reboot (losing work from my previous session), wake up but not show anything on the display forcing a hard shutdown and cold boot, or being totally unresponsive and forcing a battery pull and cold boot.  *sad face*

  • Thanks Mike.  Good luck with that, as I would not be able to provide you with 3rd party workarounds for this issue.  

    If you feel you need further assistance, then please contact our Unresolved Issues department.  You will need your SR #.  Thanks.

  • Hi,

     My company has 19 of the Dell Latitude 7202 Rugged Tablets out in the field. I had a very similar experience to Mike.  The tablet was really only partially functional out of the box.  Wifi connectivity is erratic where other devices are consistent.  Dell Rugged Control Center was guaranteed to crash on startup right out of the box without an update.  

      This was all manageable until the Windows 10 Anniversary update which has caused so many problems with the touch interface and especially the onboard camera which we were depending on.  I don't understand how this device can be listed as supported and the camera no longer works on almost any of the devices.

  • All,

    Are you still having various issues with the Anniversary Edition on the 7202?

    I have certainly had issues with the tablet coming out of sleep state and the touch screen becoming completely unresponsive, but so far the WiFi connectivity has been solid.

    Thanks for any feedback,

    Mike

  • Hi Mike,

    Yes, I am still having issues with Windows 10.  Not sure if it has the Anniversary Edition yet since I re-imaged the device the other day from the current disk image from the Dell Support site.  I had to ship my device back to Dell to have the display replaced since there was an issue with the Active Stylus tracking.  I have done some initial testing since the re-image, but the display calibration failed after phoning home and receiving automatic updates.  Now the pointer jumps all over the screen, as it had prior to the re-image.  I suspect the auto update messed up the calibration.

    Prior to this and prior to replacing the screen, I was able to get the GPS to work, but the Active Stylus, fingerprint reader, and sleep/hibernation concerns were still outstanding.  Now, with the new display and re-imaging, I have to redo my testing and configurations.  

    I plan on running further tests this week.  Right now, the display/pointer is the main concern.  Once that has stabilized, I will troubleshoot the Active Stylus, fingerprint reader, and GPS.  It is difficult to troubleshoot with the pointer going all over the place.  I do know that it is a software issue since the pointer does not behave that way in the Dell Diagnostic screen, prior to booting the OS.

    I really do hope to fix this and have this device running reliably as it should.  I just wished that Dell had thoroughly tested the device prior to selling it to me with Windows 10.  It would have prevented all of my personal hours spent troubleshooting, which should have been spent using the actual device.  I'm not sure if there were similar issues with Windows 8.1.

    The Dell 7202 is supposed to be a replacement for my aging 10-year old Fujitsu P1610 convertible tablet/notebook.  The P1610 still works, but it is slow and runs Windows XP, but it still does inking like a champ.  I just hope to get the 7202 to at least the same inking capacity and eventually use some of the additional advertised features.

    I will make sure to keep you guys informed of my progress.

    mike64738

  • Quick question Mike, does your sleep troubles occur when you come out sleep/hibernation after unplugging the AC? I have similar problems with my Lat 11 5175, except it seems to only occur after charging and pulling out charge cable then waking. I found that it may have something to do with Intel Dynamic Platform Thermal Framework drivers on my 5175,

  • kurosawabobby: I set the tablet to not sleep if it is plugged in.  The sleep/hibernation issues I encountered were when the device was already running on battery and I wanted to save the battery by putting it into sleep mode, like when I'm in between meetings.  Wake up is unpredictable so I ended up just shutting it down all the way and cold booting at my next meeting.

    As for the continuing saga of troubleshooting the 7202 tablet, I was able to continue the troubleshooting this evening.  I successfully booted into Windows Safe Mode and navigated without the pointer jumping all over the place.  I was able to procure a list of the Windows Updates that were sent to the device after the reimage.  Here are the KB#'s:

    KB3211320

    KB3213986 (Windows Security Update)

    KB3194623

    KB3197099

    KB3176937

    KB3214628 (Security Update for Adobe Flash Player)

    Unfortunately, I tried researching a few of them and the ones I started checking were either cummulative updates or updates that replaced another update, which replaced another update, ad infinitum.  I did not have the time to journey down the update trail to try and understand which one to remove.   I have put in an inquiry with my current support technician who I hope will have an answer or can at least point me in the right direction.  If anybody knows which one I should remove to resolve the jumping pointer issue, please do respond.

    Thanks!

    Mike

  • All,

    New day - new issues with the 7202.

    Desk docking station ports decided to stop working. I updated(or confirmed up to date) every driver that could possibly have an affect but to no avail. There was no power surge, new software installed over night nor any windows updates that ran. The tablet charges fine on the dock, but the 2nd monitor, keyboard, and mouse stopped working so there is not much use for the $600 dock. Has anyone else seen this?

    Also this week - we purchased a new Dell battery for the 7202 and on boot it says the battery is unrecognizable and will not charge properly.

    I reached out to Dell support to shockingly get no direction on the issue.

    As always - any feedback is appreciated.

    Mike