Dell Venue 11 Pro 7130 Won't Power On/Has Blank Screen - Mobile Devices Forum - Mobile Devices - Dell Community

Dell Venue 11 Pro 7130 Won't Power On/Has Blank Screen

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Dell Venue 11 Pro 7130 Won't Power On/Has Blank Screen

This question is not answered

Sigh. I'm a bit desperate. Please bear with me.

My Venue is about 1 year old, and while it has been a bit glitchy (occasionally powers off unexpectedly, won't wake from sleep mode, and most annoyingly, has a loose power port that makes charging rather CHALLENGING), it works well enough to be enjoyable. However, today, out of the blue, the tablet won't completely power on. I press the power button, the tablet vibrates, the charge light is on, the tablet heats up, the fan whirrs, but all I get is a blank screen. I've tried holding down the power button for 20 seconds and holding both the power and up power buttons, but neither work. 

Has anyone else had this problem? How can I fix it? Conveniently enough, my warranty expired less than a month ago. Yippee.

I'd appreciate any help you could give me.

All Replies
  • Does anyone know where I can get help for this problem?

  • The after-warranty Dell service quoted me $19 to identify the problem, $219 for new parts, and $110 for onsite service to change the part. She didn't tell me what she thought the problem was, but I suspect it is the CMOS battery as discussed elsewhere on this forum. I don't have the tools or expertise to address this problem myself, so if I want my tablet fixed, I will have to shell out $338 for a tablet I bought a year ago for $519. 

    This is my last Dell product.

  • Dear taritac,

    I'm sorry to see that no one has responded to you, let alone made any useful suggestions.
    I've joined this community after seeing your posts. My Venue 11 Pro 7130 has run into, from the sound of it, the same problems you have described.

    I've been using it for more than a year now after purchasing it as a refurbished device. I had many issues in the first half year of use including unprompted freezing and power-offs that rendered the device unusable for more than a month. I was thankfully able to fix these issues after spending hours and hours looking through the many complaint threads on this site and others. In the wake of that triumph though, new travails. I discovered that perturbing the tablet while it was seated on its mobile keyboard could cause immediate shutdown. I also had to replace my power adapter not once but twice, as it seemed to be failing. These replacements were free for me because my tablet was still under its 1 year warranty. But, alas, last month -- my warranty having expired a few weeks earlier -- my 7130 called it quits again in a most expedient manner.

    If I try to power on the device by holding <Power> for a few seconds (with a confirmatory vibration), the screen displays no signs of life; touching the Windows logo still yields haptic feedback, and I can hear the fans spinning up, feel heat from the device, hear "disc sounds", etc. No activity from the screen.

    I have held <Power> for 20 seconds and then only a few – nothing. I have held <Power> for 10 seconds, released, and held for 10 more – nothing. These are both solutions that are floating around these forums [1]. I have repeated these processes with the tablet plugged in, unplugged, mounted on keyboard but unplugged, and mounted on keyboard and plugged in. Nothing.

    I have removed the main battery, held <Power> for 10 seconds to discharge completely, plugged in, powered on, and “hot inserted” the battery. Nothing.

    <Volume+> + <Power> gives a vibration and a repeating sequence of four orange flashes from the LED, but no screen activity. <Volume-> + <Power> gives a vibration only, and no screen activity. It seems I cannot boot into BIOS. I have even opened up the tablet, disconnected and reconnected the CMOS battery, charged, powered on [3] . . . Nothing!

    I’m at a complete loss, and I’m disheartened to hear that you’re being quoted such high prices for even the faintest hope of a fix.

    Please, if Brian B. or anyone else one these pages has a helpful suggestion, could you point us in the right direction?

     

    [1]   en.community.dell.com/.../19542134

    [2]   en.community.dell.com/.../19542134

    [3]   en.community.dell.com/.../19635406

  • Thanks for your reply, THEMEANROAD. Looks like we're stuck with a lemon. I am going to contact Dell's CEO. They should be ashamed of selling terrible products like this that fail completely in little more than a year. 

  • Hey guys - sorry to see you both seem to have experienced something similar to what I posted just yesterday here -->  en.community.dell.com/support-forums/mobile-devices/f/3824/t/19651808 

    My system also died without warning and responded similarly upon attempting to reboot. I too had a loose charger that often fell out of the receptacle. I replaced just the cord (from USB to micro-USB), not the adapter,  and have had about 24 hours with my system up and fully functional after charging with the replaced cord for just 2 hours. Wondering if a similar tactic might help either of you?  

    Try searching Dell's accessory listing to see if they sell any of the adapters/chargers for their ruggedized laptops individually, sans system. They are tested to US Military rugged standards 810 and 461F. The spare cord I had on hand is certified to those standards (aka tougher than Chuck Norris) and is capable of handling the 24W Dell AC Adapter's input/output requirements with ease.

    Another option, since both of you mention recently expiring warranty - call Dell customer support and ask if it's possible to extend your very recently expired warranty or to purchase an after-warranty protection plan.  I was able to do that for a Dell laptop shortly after the warranty expired, but It's been more than a year since. Not sure if that's still the Dell policy (window after expiry in which you can still extend warranty). Can't hurt to try.

    If there's no option to extend your warranty or buy a protection plan, seek out a higher quality USB cable to try. JEM cables are a stateside firm that makes a good product - not sure if they sell DTC but I'm sure they'd point you to a retailer if not. Should be able to snag a cable for under $15 USD. Again, can't hurt to try.

    Cheers mates,

    G

  • Thanks G1MUTH. I actually did request to extend my warranty, and I received NO RESPONSE. I filled out the form online, received an automatic reply saying that someone would contact me within 2 days, and I have heard nothing since. I guess that's my answer.

  • Same issue with my Dell Venue 11 Pro 7140. Often times blank screen happens for almost a week and the worse thing happen yesterday when I open an Error Code: 0xc0000034 Missing File /BCD appeared on the screen.

  • I was experiencing the same problem. My V11 Pro 7130 would not charge the USB Port just stopped working. Dell wanted to charge me over $200 to replace the motherboard. I wasn't going to do that.

    Someone suggested that I use the connector for the travel keyboard to charge it. They indicated that the AC adaptor for the Dell Latitude tablet would fit that connection. I tried it as I couldn't use the travel keyboard I purchased as it is defective also (that's another story) and it worked.

    You can find it on Amazon for $30.88. Its listed as follow:

    Dell Original 19v 58v 30w AC adaptor for  Dell Latitude ST Tablet.

    It could be that your USB charging port is just not working. A suggestion. Hope this helps.

  • Gents,

    I ran the same issue approx. a month ago.

    The warranty just expired and the device "dead". PErfect construction from DELL.. congrats.

    but.. I didn't give up. I put the device to dock and started to play.. I played alomost two weeks..

    Battery out - battery in tries to start... I succeed.

    Let's reflash the BIOS -don't need newer, can be the same, just re-flash it. That go to WIndows update and turn it off!

    Since I made this mine is working fine.

    Good luck!

  • well, i have the same problem right now so i come here. Hope that methods can help.

  • Just curious if you were able to fix.  I've got a v11pro7130, symptoms sound identical.  With a similar failure symptom pattern curious what cause is & if user fixable.

  • Does anyone see a screen when the fan goes on and off?