Streak 7 won't charge - Mobile Devices Forum - Mobile Devices - Dell Community

Streak 7 won't charge

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Streak 7 won't charge

This question is not answered

Only 6 weeks after purchasing my Dell Streak 7, it stopped charging when I plugged in the charger. Once in a great while I could get it to charge, but most of the time it would not. I called Dell's customer service and their solution to my problem was "Charge your tablet." Once I finally convinced them that it wouldn't charge, they sent me a new charger to try. When that didn't work, they sent me a box to send in the tablet for repair.

A couple days ago, I sent it in. Today I got a call from them from someone I could barely understand who told me that there was a problem with my Window's computer and that there were error messages due to things that I had on the hard drive. WHAT? I sent in an android-based tablet, not a windows computer! And it doesn't even have a hard drive!

I asked him if he was talking about my tablet. He said "yes." I said, "Well then why did you say Windows Computer." He hung up.

I am frustrated and worried that I might not even get my tablet back and may get another person's computer instead, if anything at all. They really don't seem to know what they are doing, and I can barely understand the people I have to talk to when calling customer service. Does anyone know how I can speak to someone at a higher-level, preferably in the United States? I don't know what to do anymore.

All Replies
  • We had the same problem with the streak we bought.  Wouldn't charge after 1 month.  I did contact Dell, yes it was a foreign person, and they sent us a new tablet.  It took a while.  You can track the transaction on the website.  I do have to say that it is a poor design.  The replacement tablet wouldn't charge after 2 weeks.  This time they sent us a charger in 2 days.  The new charger works.  I thought getting a dock would be more stable way to charge because the design of the powerplug is junk, but the Dell docking station won't charge the unit.   I am really disappointed.  I wish there was a way to get a refund but the help guy from Dell said they don't give refunds.  I will just keep sending them back. 

  • Dell no longer makes DS7...I guess, as a result, support is going to be spotty. I brought DS7 (after it's been discontinued) just to see how Androrid works....not yet sold on Android...but I do not have ICS...Well, Dell isn't going to upgrade DS7.

  • I am having this same problem! Plugged up the streak last night, woke up to a low battery and now it wont charge at all!  This thing is the biggest piece of <ADMIN NOTE :Profanity removed per TOU policy> I have ever purchased. There is always something wrong with it. The first couple weeks after I got it, it had a google looping bug that took me forever to figure out how to stop. Then a couple weeks later, the door to the sd card broke on its own, and i cant even keep the sd card in the thing without duck taping it!  Just a piece of <ADMIN NOTE :Profanity removed per TOU policy>. Really disappointed in the thing. I will never buy another Dell product as long as I live!!

  • I was having the same problem.  Plugging in my Streak 7, but it wasn't charging...  Tested out the power supply, and it was good (plugged my cellphone cable into the brick - worked fine).  After a bit of looking on the forums and not finding much useful, I went after what some of the postings hinted at... the connector.

    So I looked closely at the plug-in on the Streak chassis and the cable.  The cable plug has a single blade in the middle with power contact & probably data contacts that is surrounded by a metal shield.

    The plug-in port on the streak is kind of a U-shaped dual-blade with corresponding contact facing to the middle...  The design is for everything to dove-tail together when plugged in.  The cable's power bladed in the middle, the Streak data-blades hugging up to the cable blade, then the metal shroud on the cable helps snug it all together.

    On closer inspection, I found that the U-shaped blades in the streak had gotten pushed wider and the cable shroud was going to the inside and covering the contacts in the Streak.

    I used a pushpin and tried to "close up the U" by gently moving the two blades in the streak towards each other to make room for the metal shroud to go around the outside.  I also tried to open up the shroud a little bit on the cable to help things fit together nicely.

    Following the adjustments, I was able to gently ease the plug into the streak and it promptly started charging!!!  Issue resolved.  Kept my Streak from being a chewtoy for the dog...

    Good Luck!!

    Disclaimer:  Do this at your own risk.  Be gentle with manipulating the blades.  Make sure the cable is not plugged into the charger.  Your mileage may vary.

  • This recommendation worked for me and solved the same issue.  Thanks for posting this.

  • welll i think there must be some misunderstanding, CC representive may be got confused.

    Mazhar Ik is Tech blogger and do some research on Mobile n Tablet  in indian market ..

  • Thanks for your suggestion.  I made the adjustment to the U-shaped blades, and the DS5 is taking a charge.

  • I was having the same problem.  Plugging in my Streak 5, but it wasn't charging... 


    I followed what scooterx wrote on 13th April 2012... It worked... Amazing...


    Thanks buddy

  • Same problem with no charging on Streak 7, was about to toss it. Thought I would look online one last time. Thanks! Worked like a charm.