Problems staying connected to wifi - Dell Latitude ST (1535C Half MiniCard Atheros based) - Mobile Devices Forum - Mobile Devices - Dell Community

Problems staying connected to wifi - Dell Latitude ST (1535C Half MiniCard Atheros based)

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Problems staying connected to wifi - Dell Latitude ST (1535C Half MiniCard Atheros based)

This question has suggested answer(s)

I have some Dell Latitude ST Windows 7 tablets and I am having major problems getting them to stay connected to wifi. They have the Dell wireless branded 1535C pci-e half minicard, which is atheros based and is running the only and latest driver I can find ( They are running the out of the box Dell windows build.

The devices connect to wifi, get an ip address and work for a bit but stop working after about 30-60 seconds and you sometimes have to completely reboot the tablet to get it to connect again. Basically you notice network activity stops and you get a limited connectivity exclaimation mark on the wireless icon in the systray. A repair/troubleshoot does not rectify the fault.

At the moment I have gone back to a simple WPA2 AES pre-shared key wlan. However it was the same with 802.1x authentication (PEAP). We are using a Cisco controller based wireless network. 1142N APs, controllers running version Although see my thread on the Cisco forums that suggest this may be a widespread problem with corporate style wifi with multiple APs.

This device does connect to a few wifi on standalone home routers but this is hit and miss.

There is obviously a problem with the wireless driver, but I can't find a newer version to try. These devices are totally unusable at the moment for us.

All Replies
  • I also have the same problem before where I kept connecting my Windows 7 tablet via WiFi until I found out that it was my Internet connection that wasn't stable..

  • firionicable it wont stay connected to the local lan on wifi let alone the internet. We have no problems with other clients.

  • I'm not running my ST as it was shipped from Dell. I had to try windows 8 on it. I'm running windows 7 pro with all the drivers on the dell site installed. I experienienced this problem sporadically. I uninstalled the Atheros software. In device manager scanned for changes, windows installed the same drivers that shipped with the Atheros software. It has been stable for 2 days. I think I'm running the Dell drivers without the Atheros software. Hope it helps.

  • How do you get just the drivers instead of the Ahteros software?  I've been unable to extract just those files without installing all the other unnecessary programs.

  • i think i uninstalled the software and was given the option to not delete the drivers close to the end uninstall process.

  • Good day Robert i am running win 8 as well but my system crashes saying irq equal or less after installing the atheros driver? I have tried to go back to win 7 pro but the system freezes after 4 minutes and comes slowly back and freezes up again I can see there is a conflict in the device manager. but not in win8 Please give me a instruction to solve this. and do i need to install net framework 3.5?

  • When I tried windows 8 consumer preview I also could not install the entire Atheros stack. I remember I experiemented by not selecting all of the features offered by the setup installer. Specifically, I think I ignored the bluetooth and when prompted I chose to let 3rd party provide the user interface. When I went back to windows 7, I did a restore from image selecting an image that I had created (using windows backup) before I started the Windows 8 experiements.

  • Thank You Rob it is working super not crashed yet I still can not get blue-tooth to work I hope it will later. when there is windows 8 drivers for everything.

    Once again thank you very much for the help.

  • We could not get BlueTooth working either. Seems Windows 8 has some OOTB drivers that report BT is working, however, we've never been able to get them working. We have also observed problems with the webcams. The front one doesn't work. Video playback is sporadic.

  • Hi again,

    I am having same problems with camera can not remember if it works with creative software i am not using my camera. 

    Video playback i can try ti fix i installed vlc and xbmc vlc does not work for me even music is bad. 

    Installed xbmc it  plays but the touch does not work. After xbmc is installed with codecs windows media player works great as long as you do not stream mkv. I have streamed mp4 in 720p flawless and a sample in 1080p wmw it is only a sample have not tried a movie but it looks like it can play it.

    Apperantly only windows media player works the in build new video player does not work.

  • Hello,

    Can you tell us the drivers you downloaded from dell?

  • I'm also testing windows 8 and I want to share what I have discovered so far:

    1. The freezing ISSEN talks about is for n-trig drivers, you should remove from device manager the one that has "boot" in it, but you have to enable the option for "Show hidden devices" after setting an environment variable, you can find more information about this here:

    2. The WiFi Card supports B/N/G but reality is just B/G maybe there´s a firmware/driver update to fix this issue I do not know, but what I know is that I have two ISP at home one is through cable modem + linksys WRT54G2 (supports B/G) and the second through OTN HG866 that supports (B/G/N). When I connect to my linksys router I can browse the web without any problems, I keep connected and never loose connection, but when I connect to the HG866 after 5 mins I loose connection, what I did to test this I changed the HG866 configuration to just B/G and voilá! last night I stayed connected downloading Office 2010 SP1 for x86 and x64 in two languages each. Maybe is not a problem from the Wifi card just from my router but the configuration options are limited on both sides so my workaround is just to use WiFi-G.

    3. When I installed Win 8 I discovered that you must not enable/disable flight mode, it will give a BSOD, altough not the traditional BSOD it still is a BSOD you should try enabling/disabling from device manager or from network connections. I must test connectivity now that I found the wifi-N issue.

    4. Somewhere I read that skype can detect both cameras and from there can also windows, I tried skype but never tried windows after that. I realized that the driver pack from dell is not entirely a driver is an application to access both cameras.

    5. there s a beta driver from n-triger for Windows 8 you can find it here:

    6. You can also try to install ubuntu later verision 12.04, although it has some minor issues you can resolve like display driver and wifi connetivity, it works fine.

    7. Kaspersky also has a preview version for Windows 8 you can try it but not highly recommended to uninstall, I tried to install aventail and to enable an exception so I can connecto to my workplace but I couldn't I had to disable traffic scanning by port not by app so I tried to uninstall it but I ended up formatting. Also Aventail does not work on Windows 8, I do not know if there's a preview version for Windows 8.

    that's all for now...

  • At first I thought it was my WIFI router, but in my case it turned out to be the Dell WIFI drivers for this tablet.

    I fixed this issue by installing the latest driver from Dell for the wireless card, however you must be sure to completely remove any pre-existing WIFI profiles!  I had to do this to a dozen of these tablets, some of them didn't take and had to be done again so this procedure isn't quite 100% but is in the right direction.

    1. Get latest drivers from Dell, I used

    2. You MUST remove any existing wifi profiles, whether manual or pushed via Active Directory.  If profile was pushed via AD undo it, "gpupdate /force" on the tablet and make sure those profiles are GONE!

    3. From Control Panel > Programs and Features: uninstall Atheros drivers and related software.  There should be 2 items to remove, don't reboot until both are uninstalled.

    4. Reboot

    5. Install Dell driver pack you downloaded earlier

    6. Reboot again and try connection.

    It seems that if there is some remnant of a previous profile it will continue to have problems.

    Don't just install the new driver onto of the old driver, that won't work.

    In my case this made a drastic improvement in connectivity and throughput.  Prior to this I had been fiddling with WIFI radio settings with only limited success.

  • I Solved the Wifi Problem on Tablet ST Windows 8:

    Download the latest Driver (Win7 32) on Dell Site (actually I used ST_Network_Driver_GTTFD_WN_3.1.2.85-7.4.0_A06.EXE)

    If you try to install you'll have a error about not supported platform.

    Below the install button you can extract the driver in a folder. Do that!

    In the extracted folder you have a file "win732.exe"

    Launch this exe, this will extract other file in C:\Users\yourusername\AppData\Local\Temp\ folders looks like {025ABC33-DADD-497E-B06C-F722BDC6AB8E} (don't know if are all the time the same but check the creation date of the folder.

    Inside this folder there are a lot of ini files like "0x040a.ini" and at the end there is the important file "Atheros Installer.msi"

    Open a command prompt (administrator) and run msiexec /a "C:\Atheros Installer.msi" /qb TARGETDIR=C:\Extracted_files Set your own path of C:\Atheros Installer.msi

    At the first time I had a error like it cannot extract everything, if is so run a second time.

    You'll have all the driver inside your extraction folder.

    Delete/Uninstall all old Atheros Driver you installed before (Everything), reboot the tablet.

    Go in the Device Manager, right click on the Wifi Network device, Click on Update software driver,Browser my computer for driver software,Point the path of your extracted msi folder, check the included subfolder.....

    It'll wil lfind the driver automatically and you'll use the wireless with the Windows Zero configuration and will not install the Atheros software.

    Thats it.....on my case work fine without interruption or other.

    Hope this solution is helpfull

  • I was unable to extract the Atheros Installer.msi file.


    I tired running the under Admin command prompt, from the Explorer, NADA.


    Yes I would like the drivers without the bloatware. Frankly just something that works with Win 8 RTM would be fine.