Dell Streak 7 Locks up,,has power but will not turn on or off.. what to do?? - Mobile Devices Forum - Mobile Devices - Dell Community

Dell Streak 7 Locks up,,has power but will not turn on or off.. what to do??

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Dell Streak 7 Locks up,,has power but will not turn on or off.. what to do??

This question has been answered by otnos

I just got my Streak from Dell just over a month ago.  This is the second time this has happened.. not sure whats going on.  It has power , you can tell because the sidebar is lit up  but cant get anything to come on the screen at all. I have tried to turn it off but that does not work. Last time this happened I had to wait an entire day for the battery to run down and then recharge it for it to work again. I just downloaded the upgrade to honeycomb a few days ago and some of the apps dont work now which is a total bummer. Dont much care for the way the widgets are used in this upgrade.. Will let the battery run down again and see what happens..wondering if this has happened to anyone else do I just have a bad defective model or what.  If this keeps up will definitely be sending this in for service..

Verified Answer
  • How to resolve Dell Logo Boot Loop:

    Make sure your tablet is fully charged, hold the "volume +" button and "power" button down until you boot into recovery menu. Choose factory reset. You may have to try several times with the volume + and power button to get into recovery.

All Replies
  • HI i had similar occur couple days after honeycomb update ..the emergency recovery (Formatt) sorted it for me and has been fine since id charge her up first though then force off with the pin option

    Smile  Hiya From UK Smile

    Dell Streak-7  Force Shutdown / Hard-Reset / Safemode / Recovery  info

  • Honeycomb is not perfectly stabled and you are going to run into problems and freezes, this is expected because we are Google's beta tester. When this happen, you don't have to let the battery run out. There is a reset button, its located next to the SD card slot. Its in the little pin hole. Just stick a pin or paperclip in and press the reset button. Your ds7 will reboot and you're back in business.



  • And what happens when that doesnt work. last night during game play, ds7 froze. It wouldnt shut off thru power button so I had to use the pinhole reset. since then when i turn it on, it freezes on the dell logo screen. Havent gotten help but i noticed a trend of this for the past 2 weeks thru posts and reading trying to find a problem solver for myself.


  • Mine did the same thing yesterday. I ended up doing a factory (software only via the volume up+power button) reset. Lost my data and settings. Fortunately I hadn't spent too much time customizing it yet so it didn't take too long to get back up and going. I've had several lockups since then today. Most often seems like during or shortly after software installation. Also happens sometimes when I turn it on or off to quickly. 

  • I just updated to Honeycomb 3.2 and my upgrade from adroid 2.2 went fine. But, following my next restart : My Streak7 froze on startup. All I was capable of doing was to shut it down by using the pinhole reset. I noticed that when my Streak7 is pluged in for "charging" then: On power-up the system freezes. I have repeated this error (On power Up and charging). The Streak7 does power Up correctly when "not connected and charging". After a good power Up, it is possible to connect the charging cable without a freeze problem.

  • I ended up contacting Dell and they said it was a manufacturing issue and sent a box with prepaid label to send it in to have it serviced. I should be having it returned shortly.


  • Dear Kyle43

    I had similar problem with my Dell Streek 7 as well I have also had mine for almost a year.  I have figured out the problem the solution is very simple.

    On the side where your SD card is inside the compartment to the left of the SD card slot you'll see a small pinhole use a needle or a safety pin to push inside the whole this will temporary turn off the battery it directly only do this for 2 seconds then you can turn your device on and all is well.

    You do not have the use the widgets the new update has this device is extremely versatile with the new update 3.2 I highly recommend it it makes it run faster respond better and you can do a hell of a lot more.

    I hope this answer fixes your problem.

    Sincerely your friend: Dagmarr2001

  • I am having the same trouble with 1 of the 2 tablets I got Thanksgiving day. Today is the first time this happened! I am trying to call Dell mobility Tech Support.  Will let you know what they said.Have you tried calling Tech Suppport?

  • Thanks for your help.  I read your post and rebooted my tablet while I was holding for Dell Tech support.  You saved me a lot of time waiting for support to answer.

  • I am having the same problem, trying to get through to tech support, on hold 27 minutes and counting, did you ever get this resolved?

  • I just got off the tech line - - waited 46 minutes.  The person was helpful and knowledgeable but unfortunately my system is still not working.  My issue is when it starts up all I get is the DELL logo. I have hit the reset button (next to the SD slot) to get it to cut off.  Rebooted several times with same result.  The tech guy said " Hold the "Volume +" button and the "ON" button at the same time and then a menu would come up on the screeen.......but all I got was the DELL Logo. He then said to let the device charge for a couple of hours and try, I've got to wait a couple of hours and then we'll see what happens.  If all else fails, he said Dell would issue a service tag but I'm not sure if I want to send it back to get "fixed" or just return it to Best Buy before my return privilege runs out.

  • I have to admit that I've been very disappointed with the Dell Streak 7. I had one bundled in on an order for a laptop and had been hoping to centralize one of my larger clients around them but I've found that the consistent power and lockup problems make that impossible. We use the Google App stack heavily and all of the higher ups have been clamoring for tablets. We've always shied away from the iPad since there's very poor to non-existent support for Google Apps and I had hoped to use the Streak product line since we purchase mostly Dell desktops and laptops. It appears that even Dell  knows this product was a lost cause as- just two weeks after my purchase- the entire product line simply ceased to exist. I'm now just hoping that Dell (or more likely a third party) will take the time to rewrite the software and work the lockup bugs out of it. Until then it has become the most expensive Angry Birds platform I've ever owned.

    As for a bit of advice for your problem, if you DO manage to get it out of the boot-loop (keep trying the Power Button + Volume Up trick- you'll likely need a full factory restore), make sure you completely power the device off between uses. This seems to avoid the "sleep mode" lockup since it never has a chance to go to sleep. Though having to wait one to two minutes every time I want to check something in Evernote or update my calendar means that I use my Droid X more often then not.

  • this just happened to me too after only a few days.  i have been contacting dell for weeks about it with no luck! they did suggest pushing in that little button inside where the card goes but it didn't work for mine. after going through troubleshooting with about five reps, they finally told me that they would send a box for me to send it back, but that was over a week ago. I would try to return it.  Hope you have better luck than me!!!

  • That's not a (good) solution... Smile

    I've had mine since the end of November, 2011 and it locks up frequently. I had high hopes for this device, but it's just too frustrating to use. The battery life is not great either, maybe 2-3 hours of web browsing, email checking, not even watching videos or listening to music...which really I can deal with, but the lockups for no apparent reason are just too much. I hate to say it, but I wish I would have saved up for an iPad...