For Inspiron systems 1525,1526, 1420, 1520, 1521, 1720 and 1721 if the computer refuses to shutdown and keeps saying shutting down, then follow the steps below.

 

  1. Go to BIOS
  2. Select Onboard Devices and press enter and then change AHCI to ATA under SATA Operation.
  3. Select Onboard Devices and press enter and then turn off the Flash Cache Mod.
  4. Selcect Performance and Press enter and then change the HDD Acoustic Mode to Performance.

And if the issue still persists or if you find some of the options missing, then you need to download and install NSS and Chipset and then update the display drivers (Before installing the display drivers, uninstall the old drivers and reboot).

Once all the three drivers are installed reboot again and then check for the issue.