IE 7 opens up with the runonce page everytime with a time out error. Changing the homepage does not work

Solution:  

  Click Start > Run and type the following into the Open box:
gpedit.msc
Click OK.

  Using the left hand pane, navigate as follows:
User Configuration
  > Administrative Templates
    > Windows Components
      > Internet Explorer

  In the right-hand side pane double-click on Prevent performance of First Run Customize settings

  Change the setting for Prevent performance of First Run Customize settings to Enabled and use the drop-down box to select Go directly to home page

 

 

 

  Click OK and close Group Policy

  Restart Internet Explorer 7

There are a couple of other possible fixes as the Gpedit is not available in Windows XP Home edition and in Vista

First involves a registry edit. 

  • Click Start > Run and type the following into the Open box:
    regedit
    Click OK.
  • Using the left-hand pane, navigate to the following registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main
  • In the right-hand pane, right-click on RunOnceHasShown or  RunOnceComplete and change the value to 1
  • Close Regedit and restart Internet Explorer 7

Alternatively, making the following tweak to the trusted sites also seems to work:

  • Click Tools > Internet Options
  • Click on the Security tab
  • Click on Trusted Sites and then the Sites button
     
  • Add the following site to the trusted zone:
    *.msn.com
    Click Add and then uncheck the Require server verification (https:) for all sites in this zone and click close
  • Click OK

After doing any of the above you will have to reset your home page to whatever it was you used before by clicking on Tools > Internet Options and typing the URL into the Home Page box.