Blank screen when booting on Inspiron 8500 -- BIOS screen does not display

Laptop

Laptop
Laptop computer Hardware and Software discussion

Blank screen when booting on Inspiron 8500 -- BIOS screen does not display

  • The past week or so, my Inspiron 8500 laptop will not show the BIOS screen or the Windows XP boot screen.  When I turn the laptop on, the screen is blank (appears completely off) for a couple minutes until it comes on and the Windows XP login screen shows up.  This is frustrating as I have no way to get into my BIOS setup screen (or if I do I won't be able to see it!)

    Has anyone experienced this problem?  Any recommendations on what to try?  I recently upgraded to the latest version of the BIOS (A06) -- I'm not sure if that is related to the problem or not. Also, I've tried hitting the "CRT/LCD" hotkey while it is booting, but that doesn't seem to help.

    Cheers,

    Brett

  • I just started experiencing a similar problem.  I started up my laptop one day and the LCD didn't work.  I though that it was probably the backlight or something like that, so I hooked it up to a monitor.  The monitor appeared as my primary.  If I enable the LCD and extend my desktop to the LCD, it comes on and it appears to function normally. 

    However, because it's not the primary (and no amount of Fn-F8 pressing helps)  All my desktop icon are on the other screen.  So, I can't really use it without plugin it into a monitor.

    Anybody have any ideas.  BTW, this is an 8500 with the A5 BIOS and XP.

    Thanks,

  • I just found the solution to my problem.  The switch that detect whether the screen is closed or not was stuck in the down position.  Here's the post that did it for me: http://forums.us.dell.com/supportforums/board/message?board.id=insp_video&message.id=118832

    Thanks

  • Thanks, that worked!  That also seems to have been the cause of an intermittent problem I've had with the "special" keys on my keyboard (the one button ones for volume, mute, play, stop, etc.).  They were not working because the grey peg was stuck down.  Do you have any suggestions about how to keep the peg from getting stuck?

    Thanks again for the help!

    Brett

  • Nope, I'm just another bumbling user like you.  Sorry. 
  • Actually, I just heard back from Dell support on this issue.  The bad news is that the switch has to be replaced.  The good news is that it's a user-replacable part.  Here are the instructions:

    http://support.dell.com/support/edocs/systems/ins8500/en/8500/sm/index.htm

    It's sorta buried in the keyboard section under the "central control cover"