Forums

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

AMD Radeon HD 7970M Driver Issues

This question is answered

Greetings everyone,

I have recently performed a clean install of Windows 7 on my Dell Alienware M17X R4 system. Because of this, I need to reinstall all of my drivers. I used the Resource CD that was provided with my system, and installed my chipset drivers and then my graphics drivers. However, when installing my driver for the AMD Radeon HD 7970M graphics card, I seem to have run into a problem.

When I click 'Extract' to install the driver from the CD, everything extracts and installs fine; my problem is after I reboot my system. When I login to my account, a balloon flashes at the bottom right hand corner of my screen (on the taskbar) that says something along the lines of 'Installing device driver software'. A few seconds later, the balloon re-appears and says something like 'Device driver install failed'.

When I click on the balloon, I see that Windows Update has acquired the driver for my AMD card, but there is a red X next to 'Device is unplugged'. I may not have gotten the names of these correct; however they still display the same intentions as if they were correct.

Does this mean that I cannot use my AMD card? And how would I fix this problem? The last time I performed a clean install of Windows, there were no problems installing the drivers for my system and then updating them.

Any help would be greatly appreciated.

Best regards,

-F

Verified Answer
  • Hi Flamasone,

    Thank you for providing an update on the status. I suggest you to install the drivers in correct order provided in the link below:
    http://dell.to/X1IKGu

    You will need to install the Intel driver first and then install the AMD drivers. Please let me know if you need further assistance.

    Thanks and Regards,
    Rajath N
    Dell Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

All Replies
  • Hi Flamasone,

    It can be annoying when the video drivers fails to install. I suggest you to download the latest drivers from the driver download web site by punching in the Service Tag:
    http://dell.to/QjjZDA

    Please let me know about the status.

    Thanks and Regards,
    Rajath N
    Dell Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • Greetings,

    I tried your suggestion to install the latest video drivers from Dell's' site. All of the features of CCC are updated; however, I encounter the same problem when I reboot my system.

    When I reboot the system, the same thing happens. A balloon flashes at the bottom right corner of the screen, at the taskbar, saying 'Installing device driver software'. A few seconds later another balloon appears saying something like 'Device driver software not installed'. When I click on the balloon for more information, a window appears. The window says that Windows Update has acquired the driver and is ready to install it; however there is a red X next to 'Device unplugged'.

    I might keep trying, but I'll wait for your reply. And please do tell me if you need more information.

    Best regards,

    -F

  • Hi Flamasone,

    Thank you for providing an update on the status. I suggest you to install the drivers in correct order provided in the link below:
    http://dell.to/X1IKGu

    You will need to install the Intel driver first and then install the AMD drivers. Please let me know if you need further assistance.

    Thanks and Regards,
    Rajath N
    Dell Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • Greetings,

    Thanks for supporting me in my situation here and replying promptly.

    I followed the link and found the correct installation order for all of the drivers. I discovered that I had installed some of them in the wrong order. I'm going to try again now and I'll tell you the updates. Hopefully this will fix my problem.

    Anyway, the list says to install NSS first; however, on my Resource CD, there is no option for NSS. And, on the Dell driver download website, NSS does not appear within the System Utilities tab; only the motion sensor driver. This might not be a  problem, but I'll try now and see if anything goes wrong.

    Best regards,

    -F

  • Hi Flamasone,

    Thank you for your reply and for the update. The link provides generic information that is applicable to all Dell systems. Hence, some of the drivers or applications may not be available for your system model.

    Please let me know about your findings.

    Thanks and Regards,
    Rajath N
    Dell Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • Greetings,

    Thanks for the support, and sorry for the late response. I've been lately overloaded with work, so I was finally able to respond now. I followed what you told me, and reinstalled Windows with the updated system drivers, so my problem has been solved. Thank you.

    Best regards,

    -F