Pre-boot assessment error 2000-0332, Inspiron 7720 - Video - Laptop - Dell Community

Pre-boot assessment error 2000-0332, Inspiron 7720


Laptop computer Forums (Audio, General Hardware, Video)

Pre-boot assessment error 2000-0332, Inspiron 7720

This question has suggested answer(s)

I own a Dell Inspiron 7720 laptop. A few days ago, I got a suggestion from a Dell program to update my BIOS, which I allowed. The update didn't seem to bring up any additional windows or a progress bar to let me know how the update was going but I didn't think too much of it and let the computer do its thing.

Generally I just leave my laptop on nonstop and put it to sleep whenever it's not being used (I remember reading somewhere on the Windows 8 user start guide to just let it sleep instead of turning it off). Yesterday, I traveled home for Thanksgiving while my laptop was in sleep mode. When I tried to turn on my laptop, I noticed it was no longer in sleep mode and had turned off instead. No big deal, I thought, but when I turned it on, I got an error screen along the lines of

PXE-### Media test failure, check cable

PXE-###: Exiting Intel PXE ROM

I was left at the boot screen, which allowed me to run the diagnostics. I let it run and came across the error code 2000-0332 in the pre-boot assessment screen, which told me something was wrong with my video card memory (video memory integrity test discrepancy). Upon a little bit of research on this code, it may have something to do with my BIOS and that I should try to flash it. However I haven't been able to do this through the USB (I get the error "invalid or damaged bootable partition" when I leave the USB stick in on startup) nor the CD (doesn't seem the .exe on the CD is detected).

I tried getting to the BIOS screen by pressing F2 at the Dell logo but I always end up at the same screen which lists me my legacy boot options (I don't get the typical BIOS screens that lets me change my default settings, boot order, etc). The listed choices were Removable Drive, CD/DVD/CD-RW drive, Second Hard Drive, and Network. Pressing F12 does the same thing. I noticed that  primary hard drive isn't listed so I though maybe something was wrong with my HD, but the pre-boot assessment shows that it is working fine.

I'm really out of ideas on what to do. If worst comes to worst, I can try to exchange it for another since I'm still within the exchange period but I would rather keep my current laptop and its information.

All Replies
  • Hello, I'm having the same diagnostic error with my dell laptop. Have you found a resolution to this error? Thanks, Joe.

  • I had the same exact issue yesterday, and got on my work laptop for a chat session, and now Dell is sending a tech to my house - potentially to replace the motherboard and hard drive!  I am in tears, since if the hard drive is replaced, YEARS of work will be lost, since I migrated all my data from my previous computer.  There has *got* to be a solution to this...

  • If you don't have a backup, remove the hard drive, mount it in an external USB case, and attach it to a working system by USB.  Copy your data files to the working system.

    Going forward, you absolutely must buy a backup drive - all hard drives eventually fail, and your data is only as secure as your most recent backup.

  • What did you end up doing?

    The only reason I ask is, I have just bought a new dell laptop and I'm getting the same error?

  • I ended up having to have a Dell tech come and replace my motherboard.  It is now working fine!  (did not have to replace the hard drive, thank goodness!)

  • I own a Dell inspiron 5720 and i have the same problem. 

    ERROR CODE: 2000-0332

    VALIDATION 95010

    It seems that DELL is selling damaged products. 

    It is a shame. 

    My main problem is that i bought the notebook in US

    and i am in Argentina now, and it is not easy or fast

    to transfer warranty...

    i hope DELL responds...

  • Hi Andresmou,

    I am sorry for the experience. As the error is related to video memory, I suggest you to install(flash) the latest BIOS and run the diagnostics again. You can download the latest BIOS from the following link by punching in the Service Tag and by clicking on the "Drivers & Downloads" tab:

    Please let me know the test results.

    Thanks and Regards,
    Rajath N
    Dell Social Media and Community Professional
    Order Status :
    Download Drivers :

  • I have the same problem with my video card failing the diagnostic test.  I want to try your install (flash) of the latest BIOS, but I don't know how to do this if the computer won't boot up at all.  I've downloaded the BIOS driver and saved to an external drive, but don't know how to install this file on the malfunctioning computer since it won't boot.  Any suggestions?

  • Hi,

    It is impossible for me to install Flash, because the computer does not boot up at all.

    Thank you.

  • Hi jebeare and Andresmou,

    Thank you for your reply and for providing the requested information. I suggest you to send the information requested below via Private Message, so that I can check the warranty status and provide the options available:

    1. System Service Tag:
    2. Name on the Account:
    3. Phone number:
    4. E-mail address:
    5. Shipping Address:

    To send a Private Message, click on my name in Blue and then on "Start Conversation".

    Thanks and Regards,
    Rajath N
    Dell Social Media and Community Professional
    Order Status :
    Download Drivers :

  • I have the same error too: 2000-0332, validation is: 74222.  It complaining about the Video Card : Video Adaper memory test failed (integrety test discrepancy)

    cannot boot anymore after a windows 8 update!  Why did that brick my Dell.  I do have a old firmware, version A12 on my Dell Inspiron 5720 laptop

    I also tried some recovery CD, without any luck.  Can you give us a .ISO instead so we can download it, and burn it ourselve to try it, it will be faster than waiting for a shipped cd.


  • Problem is now solved, by me :)

    At this forum ( i found the utility to boot to a DOS, command line utility, Dell 32-bit Diagnostics v5158 :

    It is pretty easy, you execute it and it will ask you where you want to put it, you said USB, but put a 1G usb key, my 2GB didn't work

    Then, before you eject the disk, i copied the A17 firmware update that i needed from :

    Then, on the Inspiron 5720, you boot, press F2, go to the boot option and choose Legacy boot.  Press F10 to save and quit.    Put the usb key inside, reboot, then press F10, choose boot from USB DRIVE, and i saw a menu, with 3 choice, none of them is the right one, so i press: CTRL-C, say Yes, then i am in a DOS prompt, in a D:\ witch is the RAM disk.

    I did:


    Then i typed the name of the .EXE of the firmware update, it copied extract everything, then reboot and did the UPGRADE!! finally i am back in Windows 8 with A17 firmware updated !

    I put the bios boot back to the other choice instead of Legacy before booting back to win8

    I did some picture while doing this, i'll try to post them this week.  SO the key was :

    - the Dell 32-bit diagnostics

    - a small usb drive + the .exe firmware

    - select Legacy boot from the bios

    - c: and execute the firmware.

  • I was asked to attempt to repair a friend's laptop with this same exact issue.

    I know this sounds strange.  As per the suggested answer, I created a USB disk with the new BIOS flash drivers.  The disk was a 2GB disk, and I was having issues loading from it.

    However, the error when attempting to boot (in Legacy Mode) was that there was a PSEx cable error.  Also, the legacy loading screen was asking to boot from the second hard drive.  I decided (on a whim) to swap the hard drive from one bay to another in the laptop.  After doing that, I got an "Operating System Not Found", so I thought that this would not fix it.  However, Diagnostics now reported that everything was good.  Complete green check marks across the board.  After, I went to the F12 booting, and changed the booting from Legacy to normal.

    Windows booted.  No BIOS update or flashing.  It was bricked following the Windows 8 update, and changiong the hard drive to the other bay for whatever reason fixed it.

    I thought this might help some people having this same issue.

  • Thank you. This solution resolved the issue for me.

  • Hi,

    I am using Dell inspiron 5420, suddenly it got stop.

    When i took it to Dell service center they found two issues in this.

    1. HDD issue, window not booting.

    2. MBD issue:Video graphic error in ePSA test (2000, 0332 error)

    Dell team has suggested me to replace HDD  as well as MBD. This will cost me Around  19K INR

    Now what should i do?

    As my laptop is out of warranty now.

    Please suggest how can proceed with this ?

    I can replace my HDD only but not MBD.

    Any suggestion please.