[Inspiron 17R] How do I completely disable iGPU?

Laptop

Laptop
Laptop computer Hardware and Software discussion

[Inspiron 17R] How do I completely disable iGPU?

This question is not answered

I've already posted this to Intel's forums and had no answer given: http://communities.intel.com/message/165285#165285

So I recently bought an Inspiron 17R with Intel HD 4000 / nVidia GT 630M and I already hate Intel/Dell guts. The picture quality of Intel's iGPU is [censored] horrible and Dell does not allow you to force discrete graphics in BIOS. Please either release a fix for dithering on iGPUs or even better, let us force a proper GPU in BIOS, currently this option is not there on Dell's BIOS.

I am starting to think of returning this Dell laptop and getting an Acer or whatever because they allow forcing a proper GPU in BIOS.

All Replies
  • There is no way to disable the Intel GPU.

  • @ejn63,

    There was a BIOS switch in my old laptop, and according to some Googling there used to be one in Dell laptops until they removed it from their BIOS.

  • Just found out that once upon a time in the past Dell had released a BIOS upgrade for Vostro 3550 to bring back the most critical switch in BIOS:

    Can we pretty please have the same thing done for Inspiron 5720?

  • There's a problem with dithering on my new Inspiron 17R SE Premium, so I would really like to have this option. Or at least having a fix for the Intel HD Graphics 4000 drivers.

    I am going to install the new A03 BIOS, but I don't think it will give me a solution. So I really hope a future update will correct this issue.

  • Took the laptop to a Dell SC. They refused to listen about dithering and iGPU and just ordered a new display. I REALLY hope that they are right.