Nvidia Geforce GT 555M Problem

Laptop

Laptop
Laptop computer Hardware and Software discussion

Nvidia Geforce GT 555M Problem

This question is not answered

I have a XPS L702X running windows 7 and seem to have a problem with the Nvidia GT 555M 3gb Graphics Card.  The laptop is a year old, have another 2 years warranty.

Basically I was playing a game, then suddenly the screen started to freeze displaying blocky ZX Spectrum style colours then froze.  I had to do a hard shutdown.

Since then the graphics card is showing up under device manager as "Windows has stopped this device because it has reported problems. (Code 43)" and when I try to go into the nvidia control panel I get the error "You are not currently using a display attached to an NVIDIA GPU".

I have tried uninstalling nvidia drivers, reinstalling the ones from the dell website, then I tried installing the latest from the nvidia website, and even tried the beta drivers all with the same results.

I am sure the graphics card is no longer functional but I thought I'd post here just in case.

Any help would be much appreciated!

All Replies
  • Hi sjiwork,

    Welcome to the Community,

    To make sure its not a driver related issue,try uninstalling the Nvidia driver using the Driver Sweeper(this helps to make sure all previous version of the drivers gets uninstalled from the system completely).

    Download  this tool from the link below and save it on your system(one which says installer) :

    phyxion.net/.../Version-3-2-0

    Once you download  and save the above tool,reboot the system to safemode,(tap F8 on start up). Use the tool to uninstall the nvidia driver in safemode.After uninstalling reboot the system to normal mode and reinstall the Nvidia driver from the link below:

    www.dell.com/.../DriverFileFormats

    If the issue persists run hardware diagnostics, tap F12 on start up (dell logo),select Diagnostics,press enter.

    Post back any error code/message.

    Thank You  

    Dell | Social Media Outreach | Global Social Media & Community




  • Thanks for your swift reply. I went through the steps and I still have the same problem.  The diagnostics showed up no issues, this is expected as it just tests the motherboard graphics card as far as I am aware.  

    Do you think this is as malfunctioning graphics card ? If so where do I go from here, I have another 2 years warranty on the hardware.

  • Hi  sjiwork,

    Since you've performed the above steps and still the issue persists,it could be hardware problem.Please accept my friend request,click on my user name,click start conversation and private message me your system service tag number,along with your full name,address and phone number.

    I will check on your system warranty and get back to you with repair options.

    Thank You

    Dell | Social Media Outreach | Global Social Media & Community




  • Hello. I got a "Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)" Error code after I did this. Please help.

  • Hi DrewsterRooster,

    Welcome to the Community,

    Sorry for the delay in response.To fix this error you may have to edit the registry of the system.But this error is common for DVD/Cd drive not getting detected in Windows.So is the DVD drive working fine?

    Alternate option would be to back up the data and reinstall  the Windows on the system.Editing registry may cause other problems on the system if its not done accurately.

    Read this post where user  brownj00 fixed a similar problem by editing the registry : www.tomshardware.com/.../454-63-hardware-code

    Hope this helps,

    Dell | Social Media Outreach | Global Social Media & Community




  • I have been having the same exact problem

    I did the steps above but like sjiwork, it didn't help

    Let me know if you can help

  • Hi Lenovo_User ,

    May I know your system model number.To further check please post the exact error message you get on your system.

    Is your system under warranty?

    Thank You

    Dell | Social Media Outreach | Global Social Media & Community




  • It is the Lenovo y570. Windows has stopped this device because it has reported problems. (Code 43)

    My system is under warranty

    Thanks

  • Hi Lenovo_User,

    If the system is within warranty please contact Lenova technical support team to get the graphics card replaced.As in case of  sjiwork we had to get the Video card replaced to fix this issue.

    Dell | Social Media Outreach | Global Social Media & Community