Laptop screen turns off but system doesn't sleep when shut. - Video - Laptop - Dell Community

Laptop screen turns off but system doesn't sleep when shut.

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Laptop screen turns off but system doesn't sleep when shut.

This question has suggested answer(s)

Hello!

I have an Alienware M14x laptop and fairly frequently when I close my laptop, the screen will shut off but the actual system will not. When I reopen it, the screen stays off and the system seems to still be going but no matter what I press, the screen does not turn back on. To fix it, I just turn it off then back on using the power button. I know my laptop is still running because the fans are still running and the lights on the front and on the keyboard are lit up. I don't know if this is a common issue or not but it is really annoying.

Any help would be greatly appreciated! If there are any other details that could help, feel free to ask!

Thanks!

               -S.

Verified Answer
  • First I find out that a windows command can tell you if you have something that prevents sleep mode. Run the command window as administrator and use the command: powercfg -requests.

    If you have my problem, and SRVNET is active, you will see this:


    SYSTEM:
    [DRIVER] \FileSystem\srvnet
    An active remote client has recently sent requests to this machine.

    2. To add SRVNET to the exempt list, perform the following from the command prompt (EXACTLY as displayed below.  DRIVER MUST be written in caps):

    powercfg -requestsoverride DRIVER "\FileSystem\srvnet" System Awaymode

    and for good measure (not sure if necessary but I did it anyways)...

    powercfg -requestsoverride DRIVER "srvnet" System Awaymode

    3. Once it is all said and done, it should look like this after running:

    powercfg -requestsoverride

    [DRIVER]
    \FileSystem\srvnet SYSTEM AWAYMODE
    srvnet SYSTEM AWAYMODE


    4. Enjoy sleep mode again.

    Credit is to JohnnyN at http://yabb.jriver.com/interact/index.php?topic=79201.0

     

All Replies
  • Check the power management settings for your OS.

    my Dells:
    Optiplex 3020 - Windows 7 Pro 64-bit / Linux Mint
    Precision M6300 - Windows 10 Pro 64-bit
    Latitude D620 - XP Pro SP3

  • The only relevant settings I can see involve what happens when I close the lid. It was set as expected (When on battery/charging, go to sleep). For the sake of not stressing out over it I've set to to do nothing when its shut (by nothing it means just shut off the screen and not the system) and to sleep if I tap the power button. This is fine for now but I would still like to get it to sleep just so that I save some battery. If there is a specific setting I should be looking at, let me know.

    By the way, Im using windows 74 (64 bit) w/ Alienware Command Center (little freeware program that came with the laptop that helps control the settings for the touchpad, lights, power etc)

  • That is odd.

    I am running Windows 7 (64-bit) on a M6300 and I have it set to do nothing when I shut the lid since I am using an external monitor, but if it is inactive for a greater than a certain period of time, the laptop does go to sleep. Maybe you should try disabling Alienware CC and try just Windows 7 settings.

    my Dells:
    Optiplex 3020 - Windows 7 Pro 64-bit / Linux Mint
    Precision M6300 - Windows 10 Pro 64-bit
    Latitude D620 - XP Pro SP3

  • I am having the exact same problem. So you are not alone.

  • Alienware Command Center and the Windows 7 settings are actually directly connected (if you change one, the other will change too). I tried it anyways but it's still happening.

  • Hi,

    I am experiencing the exact same problem. Has anyone found out a way to stop this?

    ~geekatcomputers

  • I found the solution to my own problem. I run uTorrent on this laptop and while searching through the preferences in an attempt to up the bandwidth allocation I stumbled upon an option that says "Prevent standby if there are active torrents". Apparently the program was stopping my laptop from sleeping every time I closed it while downloading something.

    For those with the same problem, if you open uTorrent, go to Options>Preferences>General and it should be down at the bottom. I don't know about other downloaders but I would bet there is a similar option.

  • First I find out that a windows command can tell you if you have something that prevents sleep mode. Run the command window as administrator and use the command: powercfg -requests.

    If you have my problem, and SRVNET is active, you will see this:


    SYSTEM:
    [DRIVER] \FileSystem\srvnet
    An active remote client has recently sent requests to this machine.

    2. To add SRVNET to the exempt list, perform the following from the command prompt (EXACTLY as displayed below.  DRIVER MUST be written in caps):

    powercfg -requestsoverride DRIVER "\FileSystem\srvnet" System Awaymode

    and for good measure (not sure if necessary but I did it anyways)...

    powercfg -requestsoverride DRIVER "srvnet" System Awaymode

    3. Once it is all said and done, it should look like this after running:

    powercfg -requestsoverride

    [DRIVER]
    \FileSystem\srvnet SYSTEM AWAYMODE
    srvnet SYSTEM AWAYMODE


    4. Enjoy sleep mode again.

    Credit is to JohnnyN at http://yabb.jriver.com/interact/index.php?topic=79201.0