Blank White Screen on Dell Inspiron 15 - N5030

Laptop

Laptop
Laptop computer Hardware and Software discussion

Blank White Screen on Dell Inspiron 15 - N5030

This question is answered

Hi everyone,

I am trying to fix this problem with my wife's laptop and its really frustrating. Its Dell Inspiron N5030 and its just over a year old. Unfortunately the 1 yr warrantee has expired and this problem started happening for the past 2 -3 months. The problem is, when you start the laptop, it has a complete blank White screen. I have read quite a number posts around and many have suggested that this is usually a loose video cable connection, or a bad lcd video cable or a problem with motherboard. I will explain the steps I've done so far and hopefully someone here can guide me on what I can do next to resolve this issue.

First of all, when this problem started happening, it was very unpredictable. Meaning, sometimes the laptop starts fine but sometimes the white screen appears. But as the weeks went by, the white screen begins to appears more frequently and now it appears all the time. This is what i've found so far:

1) When connecting an external monitor, the external monitor works fine. The weird thing is, sometimes when I connect the external monitor, the laptop white screen disappears and the laptop lcd screen begins to function again. I had this as a work-around for a while. Everytime the white screen appears, I connect the external monitor and remove it when the laptop screen works again. But eventually this stopped working as well.

2) When the white screen started to come up all the time, I noticed that the problem goes away when I remove the outer cover of the screen. (the black frame around the screen that can be removed by pulling it from the screen).

3) Last week, I removed the lcd screen and took it apart to see if there was any loose connection at the back. I noticed there is no loose connection and the inverter was fine as well. However, I noticed that the black cord (of the video cable) that runs from the back of the lcd screen to the mother board was sorta jammed around the hinge area. I fixed this cord so its seated properly and made sure that the outer frame doesnt push this cord at the hinge when I put everything back again. When I did this, the laptop started to work fine for the next week without a problem but today the white screen started to appear again!!

So based on the what I've seen, I think that the cord is getting jammed around the hinge and hence causing this problem. But I am not a techinical person and not sure if its correct. Its just a guess..So I dont know what do I do next? Does it mean that the video cable is stuffed or is it just the jamming on the hinge causing this issue? Do I need to change the complete lcd video cable or is there another solution by moving this cord away from the hinge to fix this problem from happening? What do I try out next?

I appreciate any assistance and I thank you for taking your time to read my post. 

Verified Answer
  • Hi Everyone,

    Here is an update on the solution for this problem with Blank White Screens. I have finally fixed it and this time I know for sure that this problem is definitely fixed.

    First of all a big thank you to "randypittes" for figuring out the solution first and sharing it with everyone. Much obliged!

    After putting up with this white screen problem for several months, I finally bought the "LCD Video Cable" from ebay and replaced it. Its been 2 weeks now since I changed this cable and the problem did not re-appear! I wanted to give it couple of weeks first and see if the problem comes back again before I jump into conclusion and now that my laptop is working perfect again, I know for a fact that this problem is surely fixed.

    So those of you having the same issue, do the same. First start off by replacing the LCD video cable and this should fix the white screen issue. It only costed me $20 from ebay (including delivery to sydney) and its a lot cheaper option than trying to replace the screen itself. If this did not work for you, then you can look into other options. But I would say, this solution should fix most of the white screen issues that all of you might be experiencing.

    Here is a guide I've put together on how I went about changing my Video cable in my laptop. I'm sure this may be helpful to other newbies like me:

    Step 1: First of all, make sure that you first download the manual for your laptop. Simply google your laptop model and you should be able to find the manual for it on how to replace its parts, etc..It is really handy when getting started.

    Step 2: Refer to this video on how to remove screws around LCD screen and how to get to the video cord at the back of LCD:

    Step 3: Refer to the Dell manual downloaded and refer to how to remove screws at the laptop base and how to remove the:

        a) Palm Rest

        b) Keyboard.

    Step 4: Once you remove the palm rest and keyboard you can get to the motherboard with the Video cable connected.

    Step 5: Replace cable and re-assemble everything to the way it was.

    Thats it! And Good Luck everyone! You all need it... :-)

    definitely
All Replies
  • Anyone??

  • Hi,

    Welcome to the community. I see that you did some troubleshooting steps. Sounds like a hardware problem. Its really hard to tell which specific part is causing the issue. I can tell that the issue is intermittent. Possible points of failure are the LCD Cable, LCD itself and the port in the motherboard where you plug in the video cable. I suggest to check again connectivity of cables. If this will not work, probably you need to replace the whole LCD kit.

    Hope this helps,

    -Elijah

    Dell | Social Media Outreach | Global Social Media & Community

  • thank you Elijah...I guess I will next try and see the connection of the LCD cable to the motherboard. I havent checked this connection to the motherboard yet since I guess I would need to dissemble the keyword and the other parts to get to it. I have just downloaded the servicer manual for this laptop model and I'll see how I go with it. fingers crossed!

  • Hi,

    Yes you need to remove the Keyboard of this computer to reach the cable inside. Good thing you know computers well. Let me know if need assistance, Goodluck!

    Thanks,

    Dell | Social Media Outreach | Global Social Media & Community

  • Good thing you know computers well. 

    DELL-Elijah O
    Hi,

    Yes you need to remove the Keyboard of this computer to reach the cable inside. Good thing you know computers well. Let me know if need assistance, Goodluck!

    Thanks,

    Its actually the first time I have dissembled a laptop and thank god I didnt break it! lol...

    Thank you for your support Elijah..I just opened up the laptop base and checked the video cable connection to the motherboard. The cable was definetely not loose. If at all, it was actually pretty tightly secured. However, I disconnected the cord from the motherboard and re-connected it. I also re-aligned the cord that was running through the hinges. Like I had mentioned before, it appears as if the cords were jammed and flat around the hinge area and not sure if this was causing the video cable to not work properly and hence showing the white screen now and then since the white screen only comes up sometimes and not always. I've put everything back together and I tried  restarting the laptop a few times and so far the problem hasnt happened yet. I need to wait for a few days and see if it slowly begins to happen again. Last time when I removed the bezel and re-aligned this cord on the bottom left hinge, it worked for 3-4 days and the white screen started again after opening and closing the laptop lid over the period. This time, I moved the cord coming from the motherboard and adjusted it a bit more and I'll see..finger's crossed.

    If incase, the problem happens again, what is the next step I can try? Do I first try changing the video cable first and see how it goes? atleast the video cable is cheaper than changing the LCD. Also I doubt if the LCD can be faulty since when it works, the screen is absolutely fine with good clarity. 

    Thank you again for guiding me through this. Much obliged! Smile

  • Hi,

    Thats Good News! Hopefully it will not happen again. (I'm Crossing my Fingers too :) ) You are right in case failure came again, try changing the Video Cable (we called it LVDS Cable)

    You're Welcome,thank you for choosing DELL!

    Dell | Social Media Outreach | Global Social Media & Community

  • How's this solution working for you?  I'm having the same problem.  Have already replaced the LCD only to have the issue reappear (so to speak). 

  • hi randypittes....sorry to hear that replacing the LCD did not solve it for you! thats a shame...changing lcd would have costed you quite a bit!

    Fortunately the problem hasnt happened again yet but I dont want to get my hopes up too high as well.. It is still too early to say since this laptop hasnt been used a lot over the last week. In the past when I re-aligned the cord at the top cover near the hinge, I've noticed that the problem temporarily went away and it occurs again after the laptop lid has been opened and closed a few times (may after 30-40 times). Thats why I was guessing if it was the video cable at fault. Anyhow, if it happens again, changing the video cable will be the next thing I will try to do and its pretty cheap off ebay. I will post an update over the next few weeks.

    What model are you using? Is it the same as me - 'Dell Inspiron 15 N5030'?

  • Same exact model.  I inspected the cables and plugs when I had it apart -- everything looks fine.  Problem is intermittant, like yours.  Works fine on an external monitor.  So, you replaced the LVDS cable and the problem hasn't returned?

    It would seem that the video chip is fine if it runs an external monitor?  It's also interesting that once you plug in the VGA cable the LCD works fine again.

    In any case, please let me know if replacing the cable is still a good solution for you.

    Thanks,

    Randy

  • wow...ur problem is the same as mine! In a way, its good to see that I am not alone!

    I found the exact same weird behaviour as well, i.e "the LCD screen all of sudden begins to work after you plug the external monitor!!". I couldnt understand that...I thought it either works or not but this is confusing. I was using this as a temporary solution for a while but after a few more days, even this stopped working and the screen began to remain white all the time even when the external monitor was connected. That is when I started taking it apart to have a look inside..

    First off, let me confirm that I have not yet replaced the LVDS cable yet. All i did at the moment was I opening the case and I noticed that the cable running from LCD to the motherboard appeared to be jammed and completely "flat" near the left side hinge area. I thought maybe this jammed cable was disrupting the signal from the MB to LCD...not sure, but that was my guess. So all I did was. I re-aligned this cord near the hinge so that it doesnt get jammed when the lid is opened or closed. But if the white screen comes up again, then I will try to change the cable next and see how that goes..just doing one step at a time slowly since I am still a rookie with fixing computers..

  • Took the laptop apart again and fiddled with the harness.  Some correlation between my fingers manipulating the harness and the screen going out.  It's worth a  few bucks to try a new harness.  I found some after-market versions on eBay for under $15, so we'll give it a shot.  If it's not the LCD or harness it pretty much leaves the video chip.  I could take a heat gun to it, but that could be a one-way trip.  But at this point, what the hell?

     

  • hi randypittes...my happiness was short lived! :-( the problem started again. The past few days, the screen started to flicker and thats when I knew that in a few days the white screen will being to appear. Now the white screen has started to show up once again. So whatever I did before didint work obviously. Still its weird that it worked temporarily.

    How did you go about your problem? What do you mean by "harness"? Do you mean the bezel (the plastic frame around the LCD screen)? Did you find a solution yet? I am rooting for you man..hopefully you found a fix!

  • Hi, I have a similar problem that throughout yalls research you may have something I dont. My screen cracked on my computer and I had to buy a replacement. During the time until I got the screen we hooked it up to a monitor and to our tv and could play it fine. We replaced the screen and now all that comes up is a white screen with different color lines running up and down and a loud beeping noise. I checked online also and saw where someone said it could be a connection problem so I took the screen out put in the old one and it loaded fine so I unplugged it and hooked up the new one and there was a perfect screen so I shut the computer down b/c it updated and went to restart it and it turned white with lines and beeping again. so again I hooked the old one up hit the power button, unplugged it, hooked up the new screen and it worked perfect but everytime I shut it down I have to go through the same process. I've called dell they have no clue b/c they've never heard of it happening. I called the people that I got the screen from and they say it is a computer problem not the screen. I dont know what to do. If you  know anything please help.

  • Hello.  I replaced the video data cable and haven't had an issue since.  At this point I think it's fair to assume that the cable itself was bad.  I bought the replacement cable off eBay for around $12-$15.  Here's a link:

    www.ebay.com/.../140706426618

    It was worth the money just to give it a shot.  I figured if it worked, great.  If not, I'd only be out a little bit of time and $12.  So far, so good.

  • thanks for the update randy and its good that the problem hasnt happened again after you changed the video cable. I will order one off ebay soon and hopefully this should fix it..cheers!

    Hi brandi_m_f, I'm not sure what your problem can be...the thing I am not sure about is the beeping noise. As far as I know, I dont think a loose video cable or lcd connection causes a beeping noise..so the problem can be something else. then again I am not a techkie and I could be wrong..could it be a problem with the motherboard? hopefully someone experienced here can shed some lights for you..