HDMI port not working for Inspiron 15 (N5010)

Laptop

Laptop
Laptop computer Hardware and Software discussion

HDMI port not working for Inspiron 15 (N5010)

This question has suggested answer(s)

My HDMI port is not working

I have tried to use my HDMI port to connect my laptop to various monitors and TV's. They do not even reconize that they are connected. I have used the same monitors and TV's to connect other laptops that I have so i know that they work fine. I have used the VGA port on my laptop to connect it to a TV and it works fine but not for the HDMI port.

Anyone have any idea on how to fix this so i can connect my laptop up to a TV.

All Replies
  • Look up Connect a tv in windows Help for specific instructions. When connecting a monitor or tv you must  switch to external monitor. Don't forget to select the correct hdmi input on the tv, too.

  • I have the same problem and I look forward to a helpful response to your question.

    I've connected via HDMI and changed the display settings on my laptop, but no connection to additional display.

  • Click Here to get some information on how to hook up HDTV with HDMI cable.


    Below, jimco has put together a good troubleshooting list for HDMI issues.
    Thank you for putting this list together.

    jimco

    I have collected dozens of tips from people about what worked for their particular combination of model, operating system, & graphics device.
    Here are my general instructions, compiled from many posts left on the Laptop Audio discussion board.

    Preliminary steps:

    1. Plug the laptop into a power source. Some of the models have a power management scheme that will not allow for HDMI audio while running on batteries. Later, after you get your HDMI audio working, if you find that it still does not work on batteries you can change your power management settings in the Control Panel.

    2. Turn off the computer and TV before connecting the HDMI cable. Later, after you get your HDMI audio working, if you disconnect the cable while the computer is running and lose your audio, try closing and then re-opening whichever program you were using that generates audio.

    3. Every time you try a different solution you should reboot the computer. HDMI audio is extremely finicky and seems to usually need a reboot.

    Make the Connection:

    1. Connect the HDMI cable to the computer and TV.  If the TV has a "DVI/HDMI" port do not use it. Use a port for HDMI only.

    2. Turn on the TV and select the HDMI port you are using. Adjust the TV settings to receive HDMI audio if any.

    3. Turn on the computer. (Optional, some people close the laptop lid immediately after hitting the power button but I am not sure why. Most people should not need to do this.)

    4. Optional. Some models do better if the TV is set to be the primary display. To set, repeatedly press Fn+F8 (or ctrl+alt+F4) to cycle through the settings (laptop display only/laptop display plus external display/external display only). Reboot the laptop.

    5. Go to Start>Control Panel>Sound>Playback tab. Make "HDMI" the default device. (If "HDMI" is not there, right click in the white area and look under "Show Disconnected Devices" or "Show Disabled Devices" and see if it is there.)

    Post Connection Problems:

    1. If there is still no option to select "HDMI' as the default audio playback device, try re-installing or updating the graphics driver, or even try an older version. The graphics driver is the driver for HDMI audio, not the regular audio driver. Some people with Intel graphics had better results by uninstalling the graphics driver, rebooting, and letting Windows look for a driver -- instead of downloading the driver from the Dell support site.

    2. Try disconnecting and then reconnecting the HDMI cable.

    3. If you are using Windows Media Player or Windows Media Center but get no HDMI audio even after it is selected as the default playback device, go to

    Control Panel>Sound>Playback tab>Audio/Playback device>HDMI>properties>Advance>Exclusive Mode and uncheck "exclusive mode".

    4. Try a different HDMI cable.

  • Good luck. I had the same issue with my 15Z. It was workiing fine one day, then one day it's like I dont have anything plugged in. Tech support took 3 HOURS on my computer via remote operate, fixed the problem. Sure enough, bout 2 weeks later I plug in to watch a movie, again it's not working. I really regret spending the money on this computer.

  • well i'm also having the same problem except for that, when i first connected my samsung 32" led tv with my dell n5010 (ati m5470) it worked, then after a few min. it flickered and then there was no signal message in tv and no detection on my laptop.  

  • I also have a DEll Inspiron n5110 and finnaly got around to buying a HDMI cable. No matter what I try I can't get an image on my TV. Do I need to load additional drivers for this port, has anyone managed to get the HDMI output working.

  • I have had mine work on my old Hannspree, not very clear though, nut new Sony Bravia KDL723 is flashing on and off, vey odd, will phone both Sony and Dell and see if there is a solution.

  • I tried to connect my laptop to hd tv via hdmi through the amplifier but no transmission although it worked for a couple of times. pls advise how to repair the problem.

    I think something went wrong with the hdmi port in my inspiron laptop. 

  • Your HDMI port is out of order and need to change. the easier way is to buy a USB to HDMI Adapter(converter) and then connect your HDMI cable to the Adapter and directly to the TV HDMI port. I tried it it works GREAT,

  • Hi guys,

    After 2 months DELL solved mine Inspiron 7520 HDMI problem (didn't work - TV not recognized)...

    They just changed the mother board and now all is ok...

    So, the problem that HDMI didn't work was a hardware problem...

    I think there is a mother board (or Intel HD) series with problem....

    If anybody has the same problem I recomend to insist with DELL to substitute the motherboard...

  • Just uninstall AMD drivers.reebot. Then install 13.1-not include driver. then 12.6 then reeboot..Its work

  • please tell me more about your solution ...........

  • 1 fist  dounload drivers 13.1


    if 64 bit windows  http://sites.amd.com/us/game/downloads/Pages/radeon_win8-64.aspx

    if32 bit http://sites.amd.com/us/game/downloads/Pages/radeon_win8-32.aspx

    2 . download  12.6 http://support.amd.com/us/gpudownload/windows/previous/Pages/radeonaiw_vista64.aspx

    3. uninstall  current version drivers

    4.install  13.1

    5 install 12.6 

    6.reboot