Inspiron 6000 Video & Windows 7

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Inspiron 6000 Video & Windows 7

This question is not answered

I just bought a used Inspiron and upgraded it to Windows 7 and am generally very pleased with the performance. However, I'm unable to find a video driver for the ATI x300 that will load.  I've tried several different ones (Vista 32-bit, most recently) and while the ATI Catalyst program says it completes successfully I can't find any instance of it anywhere and when I look at Device Manager it doesn't show up.  The generic driver does work okay - I'm at 1680x1050 resolution.  However, the video performance is slow - especially playing DVD's and because of this I get a speed index of 1.0 when I run the performance utility.

I've seen other posts where people had similar problems and Windows 7 eventually found the correct driver by itself and downloaded it.  That hasn't happened for me yet and I'd really like to get the improved video performance the people who have the correct driver running have posted about.  I don't think Windows 7 is officially supported by Dell on this model but everything I've read says there is a driver out there somewhere that will work.

Thanks in advance,

BB

All Replies
  • There might be an optional update in Windows Update available. 

    dgkpcon in another post mentioned the Mobility Modder (this was respect to another system but it should be doable with your model). Download it and follow their step by step guide. (Near the bottom of the page).

    Philip Yip

     

    Windows Reinstallation Guide and Related Wikies See here for other wikies such as Customising and Using Windows 8.1, Dell Wireless Cards and Unofficial Drivers.

  • I don't think ATI ever released Vista drivers, much less Windows 7 drivers, for the X300.  You might try one of the driver modification websites to see what others have done.  One thing is for certain - neither the ATI nor the Intel video on this model will support Aero on either Vista or 7.

  • I will give you some other notes on the install. I managed to install 7 on the Inspiron 1300 okay. The procedure on the Inspiron 6000 should be much the same.

    Using the following 5 32 bit Vista Drivers for the Inspiron 6400.

    The first thing I did was download the vista drivers from the Inspiron 6400. 

    1. Dell Notebook Software

    2. Intel Chipset

    3. Ricoh Chipset

    3. Intel Proset Wireless 2200* (got the vista driver from the intel website/you might have a different wireless card)

    4. Touchpad*

    So I noticed in the device managed all the devices were okay except video (like you). I would try the fix I mentioned above in your case before attempting this (as I think you might get a better driver for an ATI card this way).

    Mine was the integrated Intel in the Inspiron 1300. I downloaded the XP driver (in your case it will be R106547). Double click the file and then it will extract to C:\Dell\Drivers\R106547. It will then try and install and likely fail. Press [Windows] and [Pause|Break] then go to Device Manager, right click the Video device under Display Adapters and select "Update Driver Sofware..." then select "Browse my Computer for Driver Software", tell it to go to look in C:\Dell\Drivers\R106547. It should install the video driver. You should reboot when its done. As ejn stated aero will post likely not work so for the sake of performance you should set 7 to classic mode. Right click the desktop and select personalise then select Windows Classic (unless of course the aero works). You should be able you change the resolution now (right click the desktop and select screen resolution).

    Now unfortunately the Vista version of Dell Quickset for the Inspiron 6400 won't install on the Inspiron 1300 or 6000 despite the fact that they have the same XP version of Dell Quickset.

    To get Dell Quickset to work, it is a bit complicated but worthwhile.

    Download R151309 the XP version of Dell Quickset for the Inspiron 6000. Right click the file and select properties, then change the compatibility to XP.

    Everything seems fine till you reboot. If you reboot now the brightness meter will work but the volume meter displays but not does change as you change volume. So you must right click Dell Quickset and check again that its compatibility mode is set to XP again.

    Now everytime you reboot Quickset won't start automatically even if you put in the startup folder. When you launch Dell Quickset you will get a UAC prompt. It will otherwise work. This is very annoying and you may forget to launch Dell Quickset manually at startup. To resolve this use task schedular. Start it via a search from the start menu.

    Go to actions > Create Basic Task. 

     

    Follow the wizard, Name: Dell Quickset, <Next>  Trigger: When I log on <next>  Action: Start Program <next> select program, navigate to C:\Program Files\Quickset and click on the Quickset Icon. 

    The next step is to find Dell Quickset in the Task Schedular Library. Double click it and edit its general properties.

    Check run with highest privileges. Now go to the triggers tab edit triggers

    Change "Specific User" to "Any User" and make sure enabled is checked at the bottom left. Click <OK>.

     Quickset should now work as it should. This should have your system working as well as it did with XP.

    Philip Yip

     

    Windows Reinstallation Guide and Related Wikies See here for other wikies such as Customising and Using Windows 8.1, Dell Wireless Cards and Unofficial Drivers.

  • Okay, I've tried both the Mobility Modder procedure and the Dell Driver download (provided by natakut4 along with the quickset instructions) and I'm still not getting anywhere.  The Mobility Modder said it modified the driver correctly (I'm working with v10.2) and I ran through the Catalyst installation but had the same result as I'd had previously.

    Now, here's one more thing that might be (probably is) relevant.  The first time I tried to install an ATI Catalyst package I thought might work, I got an error saying that another installation was in progress and that it had to abort.  I was downloading and installing some Windows 7 updates at the same time which I probably shouldn't have done.  I got in too big a hurry.  

    So, every time I've tried any version of Catalyst since then it appears to go through the process then comes back with "Installation Completed but with the following warnings."  When I look at the file it doesn't show any warnings, and I can't find any evidence of Catalyst or anything else ATI installed on the computer.  

    Anyway, thank you very much for the suggestions and I'll keep hammering away.  Is there a way to "undo" all changes that may have been made from a previous attempt at installing Catalyst?  That might be what I need to do but haven't found anything but the "uninstall" process which seems to have no effect.

    Thanks!

  • I finally got somewhere!  I downloaded and installed the Intel Graphics Driver (R128346) from dell.com and that seemed to work.  From there I spent some time on Intel's site and determined that tbere isn't a WDDM driver for my chipset because the specs weren't in place until after the 915GM chipset family was introduced.  I did see a post from somebody somewhere saying that Windows Update did take an ATI X300 driver for his Inspiron 6000 running Windows 7, but based on what I'm reading I've gotten about as far as I can.  

    If there were a way to get a newer driver and use Aero that'd be wonderful, but from what I'm reading I don't know that it's possible.

  • Go to start > All Programs > Windows  Update 

    Click any optional updates.

    Did you try also:

    Downloading the XP driver (in your case it will be R106547). Double click the file and then it will extract to C:\Dell\Drivers\R106547. It will then try and install and likely fail.

    Press [Windows] and [Pause|Break] then go to Device Manager, right click the Video device under Display Adapters and select "Update Driver Sofware..." then select "Browse my Computer for Driver Software", tell it to go to look in C:\Dell\Drivers\R106547.

    It should install the video driver. You should reboot when its done.

    As ejn stated aero will post likely not work so for the sake of performance you should set 7 to classic mode. Right click the desktop and select personalise then select Windows Classic (unless of course the aero works). You should be able you change the resolution now (right click the desktop and select screen resolution).Check Windows Update & Optional Updates again.

    Philip Yip

     

    Windows Reinstallation Guide and Related Wikies See here for other wikies such as Customising and Using Windows 8.1, Dell Wireless Cards and Unofficial Drivers.