Hybrid graphics (switchable graphic cards / nVidia Optimus) on Dell Vostro 3700

Laptop

Laptop
Laptop computer Hardware and Software discussion

Hybrid graphics (switchable graphic cards / nVidia Optimus) on Dell Vostro 3700

This question has suggested answer(s)

Hi guys,

I have a Dell Vostro 3700 with an i5-560M processor (which according to Intel's site has integrated video capabilities) and a nVidia GeForce GT330M video card. I am using Windows 7 64bit. I tried to install the switchable version of the nVidia drivers (which I am getting from the Dell site) but I cannot do that. During the installation process, I am only given the option to install the nVidia sound card. When using the driver version for discrete nVidia video cards, the install process goes without any problem. I am using the latest BIOS version (A10).

From the documentation ( http://support.dell.com/support/edocs/systems/Vos3700/en/SM/Bios.htm#System_Setup_Options ) , it seems that in BIOS there should be an option for "Hybrid Graphic" which would allow to enable / disable that feature. However, my BIOS doesn't show that option. Rumors are that older BIOS versions (A08) do have that option available, but couldn't find any confirmation (or infirmation) on that.

Do any of you guys have that option available in BIOS?

I am not sure at this point, since I couldn't find anything relevant in a short research, but it seems that hybrid graphics might be only made available in certain hardware configurations, simply having an integrated and discrete video card doesn't  make it available by default. Does anybody have more info on this? Also, does anybody know how can I tell if my model has this feature? By reading Dell's product descriptions I cannot any difference between Vostro 3700 configurations that would let me know which one of them supports hybrid graphics.

Any input would be much appreciated.

All Replies
  • I'm having exactly the same setup like yours, Vostro 3700 + Windows 7 64bits + i5-560M + Nvidia GT330M.

    After install Nvidia driver from Dell support site months ago, this NB goes to GT330M when the power is plugged, and it goes to Intel integrated HD when running on battery power.  I'm kind of like it, bcoz it makes sense to preserve some more power on battery mode.

    Today, I'm check the update drivers from support.dell.com, noticed exactly the same confusing "discrete/R292774" and "switchable/R289195" drivers, totally not sure which one I should go for....? And there is also a driver for Intel HD/R287485....  Just to be clear, I did type in my service tag to get all these info.

    P.S. Florin101:  Want to know if you'd ever experienced Windows 7 x64 just sudden/random reboot itself, no bluescreen, no sign of warning?!

  • @tt18qc, thanks for your post. It seems that your laptop works exactly the way I would like mine to work, related to graphics. What BIOS version are you using? If you go to the following address http://support.dell.com/support/topics/global.aspx/support/my_systems_info/en/details?c=us&cs=19&l=e and enter your service tag, what does it show for graphics?

    Related to drivers, in your case you should go for the switchable version of the nVidia drivers. I think you should also install the Intel HD graphics driver.

    No, I didn't experience any reboots on my Vostro laptop, but I did experience the exact behavior you are describing on my older Dell Inspiron 1520 with Win 7 x64. The reboot didn't seem to be related to anything (heat, installed programs, continuous usage time etc). Sometimes it rebooted only once every two weeks, sometimes it rebooted even twice a day. Didn't have the time to reinstall the Windows on that machine to say if that would fix it, since I was doing all my work on it and was quite dependent on it. In fact, one of the reasons I bought the current Vostro laptop was so that I can get the chance to fix the older one. Didn't have the time for that though.

     

  • @florin101, I'm using A10 BIOS as well.  The weird thing is, there is NO video card info under my service tag sys info?!  Probably that's the same reason why I got so many drivers update from support site, bcoz the system somehow lost my 3700's setup info.....  Hmm

    I'd already tried that Intel HD graphics HD driver, it says I already had a newer version installed?!  Indifferent

    The mysterious reboot seems to be more frequently occurred on Dell's machines than other brands.  Some other forum has threads suggesting different gestimations about the cause of it.  Non of each are convincing enough to me, so fingers crossed for both of us.

    BTW, if this info helps, I did a HDD wipe when I firstly  got the 3700, I didn't use image disk to restore windows 7, instead, did a step by step drivers installation.  Bcoz I don't like to load too many bundle softwares I never need.  And that 330M/Intel video switching feature just come up right after I installed video drivers from support site, fyr.

  • @tt18qc, I have also performed a clean install. My machine simply doesn't install the Intel HD or the nVidia switchable drivers from the Dell's drivers page (which as you, I am accessing using my service tag number). The only graphics drivers that I can successfully install are the nVidia discrete from Dell's site or the latest nVidia driver from nVidia's site (which is discrete by default).

    By browsing multiple forums on the subject it seems that on some Vostro 3xxx models the integrated Intel graphics card is disabled at hardware level. Interestingly, it seems that models purchased from late 2010 summer do have hybrid graphics enabled, but mine doesn't, even though I purchased it in November 2010. I bought it in Romania. Maybe Dell doesn't consider Eastern European markets as being important and decided to send older models in here. What really bothers me though is that you cannot tell from a model description if it hybrid or not, so I believe it is a bit of a lottery.

    On a different subject, searching drivers by service tag number is not very precise. Unlike yours, the system information page does display a graphics card for my system: GRAPHICS : NVIDIA GEFORCE GT 330M, 1GB G

    However, I still get all the available graphics drivers (Intel Hd / nVidia switchable / nVidia discrete) on the downloads page.

    To be honest I keep my laptop plugged for most of the time, so I don't worry very much about power consumption. The reason why I would have liked to be able to switch video cards is because I am also experiencing this very annoying issue http://en.community.dell.com/support-forums/laptop/f/3518/p/19335374/19806802.aspx and I was thinking that by switching to the integrated card would make the system produce less hit and the issue would happen less.

    Finally, a question. @tt18qc, do you have the "Hybrid Graphic" section in BIOS which I describe at the beginning of this thread?

  • @Florin101:


    1. In my A10 version BIOS, there is no hybrid graphic options available

    2. Just fyr, my Nvidia video bios version is 70.16.5A.01.05.00

    3. I did read some threads regarding fan noise in 3700, luckily, I didn't experience it so far.  I use a wood made, gate-shaped, big size coaster to add some space for cool air to flow through it's underneath vent. My 3700's fan works in low gear in 90% of the time, 10hrs uptime everyday.

    4. Just to check with you about DDR3 memory spec, my 3700 comes with DDR3 1066, but my order info says it should be DDR3 1333.  I know i5-560M only works upto 1066, but still feels cheated. Angry

  • @tt18qc, the Dell Support Center application reports that my nVidia bios version is 70.16.5a.1.5 , which I suspect is the same as yours, it was just the application stripping some zeroes. So the nVidia video cards might actually be identical. My integrated Intel graphics card is probably disabled from another place.

    I also keep my laptop in ideal conditions for ventilation: wooden desk, plenty of space around it. Also I only have the laptop for 2 month, so dust shouldn't be a problem. The very annoying thing is that heat itself is not the problem, but rather the way the cooler is programmed to work. At a certain temperature it continuously starts and stops (see the movie in the link from my previous post). If at that point if I give it some CPU intensive task (like compressing a big folder), the processor heat will increase and the cooler will enter in a new state of continuous running and that is much more silent.

    According  to the Dell Support Center application, my memory is indeed DDR3 1333MHz, but as you said that is not very useful as it is being used at 1066.

  • @Florin101: I got my Nvidia BIOS version from my BIOS setup, not from support site.  And I physically check my DDR3 spec under the hood, it's 1066, although Dell order system, support site, says it's 1333.  Overall speaking, I keep support site info just as a reference, for reason obvious.

  • Checked the nVidia BIOS version from the system's BIOS setup and I can confirm it is the same as in your case. Didn't yet opened my laptop, so I cannot confirm if physically they are marked as 1333 or as 1066.

    I didn't use the Dell support site to get the information I have previously posted, but rather the Dell Support Center 3.0 application (not the best name I believe), which installs locally on the computer and which I hope that actually checks the system on the displayed info: http://support.us.dell.com/support/downloads/download.aspx?c=us&cs=04&l=en&s=bsd&releaseid=R289543&formatcnt=0&libid=0&typeid=-1&dateid=-1&formatid=-1&source=-1&fileid=431067

  • has anybody here been able to verify if the older bioses actually did have the options to choose between the nvidia/intel video cards?

    where to find old dell bios'?

  • Hello, 

    My friend have same issue on his vostro 3700 (switching gfx and no bios option to change that).

    After mobo change by service guy, bios version is A09, we've try to downgrade it to A07 but there is still no option for hybrid graphics.

    It's really annoying when cards are switching and previous version of his bios/mobo was ok.

     

    He's struggling with heat issue on this laptop.

    Service first change heat pipes then mobo and problem is still occuring.

     

    @ZDOE

    http://search.dell.com/results.aspx?c=us&l=en&s=gen&cat=sup&k=vostro+3700&rpp=12&p=1&subcat=dyd&rf=all&nk=f&ira=False&~srd=False&ipsys=False&advsrch=False

    If you wanna downgrade just open cmd as admin, type source of the bios file (example: C:/bios.exe) and add /forceit. C:/bios.exe /forceit

    It's your own risk as always:)

  • doodah people - that's great info about the /forceit! cheers.

    (though i'm now sorted without all this - in my system the service switched the mobo to one where there is NO hybrid graphics. some might think this a downgrade, i consider it an upgrade because the video driver is now upgradeable and the apps that couldn't handle the hybrid suddenly work. of course they did this without consulting me or telling me about it, and to an nvidia version that's not supported by drivers that dell makes available.)

  • Did you a "downgrade" to A01 Bios ??

    As you said , this sounds like a upgrade to me too =) , this sould let me use the nvidia drivers graphics on Linux ...

    Plz,  tell me more about this .... you just   "cmd  and  C:\dell_bios_A01.exe /forceit! " and rebooted ???? and everything worked ? Like a Charm ?

  • What's the part number of the replaced motherboard? I'm seriously thinking of replacing mine, so far I've found 3 available motherboards for the 3700.

    WTW8F - "Discrete, Non SGC, WINERY 17"

    PN6M9 - "UMA, Intel Integrated, WINERY 15"

    V954F - "UMA, WINERY 17"

    Maybe a Dell Tech can confirm which MB was in is the earlier versions of the 3700.

  • This is a link to NVIDIA's website and it scans your system to see which is the correct driver EVEN IF IT'S NOT ON DELL'S LIST OF DRIVERS

    It cleared up problems on my system, and I suspect it'll clear your problems up as well.

    http://www.nvidia.com/Download/Scan.aspx?lang=en-us