XPS M1340 screen dims when cover (screen) fully opened

Laptop

Laptop
Laptop computer Hardware and Software discussion

XPS M1340 screen dims when cover (screen) fully opened

This question has suggested answer(s)

Had this problem appear within two months of receiving my XPS M1340 and Dell replaced the screen under warranty. Well, now about 14-15 months after replacement, it is happening again. At first I thought he screen was going out completely, but upon further investigation, I can report the following:

If I only open the screen about 100 degrees, everything works fine. But if I open it further, the image disappears. I was playing around in bright sunlight and realized that the image is still being "dimly" displayed, like in shadow. So I assume the backlight for the screen is going off. I did some disassembly and it appears the wire harness is being pinched in the hinge. Like I said, as long as I don't fully open the cover, everything works fine.

So my question is has anybody experienced this issue? Do you think replacing the harness will fix the problem? Just a connector that keeps working loose? Other ideas?

All Replies
  • The first step would be check the condition and seating of the connector(s) on the existing cable (the one to the mainboard -- the screen itself on this model doesn't come apart in a way that can be put back together).

    If the cable is damaged, replacing it may not be easy because of the way the screen is fused together with adhesive.  If the cable is damaged and can't be easily repaired, you will need to replace the entire top half of the system.

     

  • Thanks or the insight; not very assuring. If the screen eventually fails completely, I guess I'll hook it up to a monitor and use it as a desktop. After 4 Dells, this will probably be my last.

  • I know this is late, but thought I'd let you know. I also read that you can't take apart the "edge to edge" display on the Studio XPS 1340 and have to replace the whole assembly. Not true at all! As a matter of fact it comes apart faily easily IMO. All internal components are replaceable. I called Dell about the same issue with a defective cable at the left hinge assembly, shorting the inverter when the lid is jiggled or partially closed. Dell support told me it was the inverter failing (which I knew was not the case) and gave me a few options,all of which were over $350.00 to fix.

    The problem was the LCD cable harness had been worn at the hinge point from friction. The cable (part # G635M) was under $50.00 online and the repair took me just over an hour. Must note... My job is a laptop and cellular phone repair tech, but the repair is not extremely complex. Be patient and careful and organized when taking apart and search online for disassembly guide to help.

    I was dissapointed in a comment made by Dell's service tech over the phone. They stated that it's an inverter and unfortunately the inverter is soldered in and can't be replaced. Fact is the inverter IS NOT soldered in and can most certainly be replaced. Though it wasn't the problem with mine and I already knew this.

    I'm not sure why Dell makes it seem so impossible to repair this LCD assembly?? It's honestly no harder than any other model I've worked on.

  • I had a similar issue with my laptop. The screen would flicker and I eventually herd a 'hiss' and it 'died'. I actually could see a faint image and it worked with an external monitor. I replaced the inverter (20 bucks on ebay, found instructions to take everything apart on google) and it worked like a CHARM.

    THEN 1 week later the same thing. I thought the laptop was doomed and that some connection to the motherboard was messed up. Took it apart again, and found that the left hinge connector to the inverter was very loose -- i easily pulled it out with no resistance. I snapped it back in, gave the left hinge cable a little more slack, and seems to be fine now.

    I think what is happening is that whoever replaced the screen installed the cable way too taught. When you open the screen all the way, the cable going to the inverter gets tugged on, losing connection. Try opening it back up and firmly connecting it and giving the wire some slack. Also may be that the wire has become exposed from friction and gets grounded on the metal frame. Electrical tape should fix that.

    pfz