Latitude E6410 - Unable to connect to an external monitor - Video - Laptop - Dell Community

Latitude E6410 - Unable to connect to an external monitor


Laptop computer Forums (Audio, General Hardware, Video)

Latitude E6410 - Unable to connect to an external monitor

This question is not answered


I bought a Dell Latitude E6410 and installed Windows Server 2008 R2. I am not able to connect to the external monitors or projectors. I tried installing windows 7 64-bit drivers from both Dell and Nvidia, but it didn't work. After installing these drivers and and re-starting the machine, my display stopped working (nothing comes on the screen). My graphics card is an Quadro NVS 3100M. Would anyone know ways to get the external display to work for a Win Server 2008 R2?

All Replies
  • Sorry for the delay in getting back to you.  The notebook may not be totally compatible with Server 2008,  The Dell Notebook System software is generally required for full functionality of the system.  Here is a link to the drivers download page.  The DNSS file can be downloaded for  XP, Vista and Win 7 if you decide to reinstall.


    Specialize in Laptops, Mobile Devices

  • That is a horrible answer. I have a requirement to run Windows 2008 R2 on my Dell E6410 for a proof of concept presentation next week. It's kind of worthless if I can't hook it to an projector for presentation.

    Any suggestions (and no I can't just install Windows 7).

    Thank you in advance for any help.


  • I actually resolved this issue by installing the SP1 for Windows 2008 R2, which is currently in beta. It solved all my problems. You might want to try this as well. Details below:           

  • Today, I had to give a presentation to my team which was on my laptop. But I could not give it due to the technical issues I had while connecting my laptop to the projector. My company has given a Dell Latitude E6410 which has Windows XP Operating System and has NVIDIA NVS 3100M video adapter. I tried to connect to the dell projector DELL 2300 MP but it is not displaying anything. It just displays 'No Signal'. It would be great, if anybody can help me in resolving this issue.