Latitude E-series do not recognize KVM switch as external monitor

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Latitude E-series do not recognize KVM switch as external monitor

This question has suggested answer(s)

I plug my computers (desktop and laptop) into a KVM switch in my office when I'm setting them up.  With the Latitude E-series I've been having to set the laptops on the desk next to me so I can look at the screen because they will not detect my monitor through the Belkin KVM switch.  I have only had models with Intel graphics but they have all done this. 


It won't allow me to switch to presentation mode and the Intel display control panel shows no external monitor detected.  Even when they are plugged into a docking station they still don't work.  I'm using the VGA output in all cases.

 

Is there some way to make this work?

All Replies
  • I don't know the answer, but I am having the same problem with my Latitude E6500 laptop and a IOGear Single-Link DVI-D KVM switch. I have the switch plugged into my laptop via a DVI-to-VGA adapter. When I try to switch my laptop over to use an external monitor via Fn-F8, I get a dialog titled "Display Devices" with its contents stating "LCD Only" and "Presentation Mode is disabled". Very irritating, and googling has so far not given me a solution to how to make this work.

  • I also am experiencing conectivity problems.  My current configuration is as follows.

    Latitude E6400 laptop.  Using the onboard Mobile Intel 4 Series Express Chipset Family.  Video output is through the VGA port.  OS is XP Professional.

    Current video / chipset driver is version 6.14.10.5029 dated 1/21/2009.  Current BIOS is A17.

    I'm trying to connect a Belkin Titan 17" LCD Rack Console with Built in PRO3 KVM Switch.  Cable connections are via the VGA port for video and USB port for mouse/keyboard.

    Symptoms differ depending on the sequence I choose at powering the systems up but include the following.

    No video shown on the KVM but mouse and keyboard function.

    Video displayed on KVM but no mouse / keyboard functions. (only experienced this once.)

    No video and no mouse / keyboard function.

    I have tested the laptop on a conventional monitor and it works fine.  I have tested the KVM on a different laptop (a Dell Latitude D630) and it worked fine.

    I receive the same "LCD Only" and "Presentation Mode is Disabled" issues as you have stated..

     

  • The KVM switch you have is the source of this issue -  it did not provide Full-time/ Active DDC communication between the connected display monitor and the connected system via the KVM switch channels.   Please google "Full-time All DDC", you will find more information about it. 

  • I've had similar problems using a Kinimax 2 port KVM switch with a Dell Latitude 620 (XP) and a Sony VAIO (Win7).  No problems with the USB KB and mouse, but the computers will not recognize the VGA monitor unless I first plug the monitors directly into the computers, bring up the monitor and then reconnect through the KVM switch.  At that point, all works nicely; I can switch back and forth between the two computers.  The problem reappears if I have to reboot one of the computers.  At that point, either the laptop ot the switch "forgets" how to see the monitor and I have to go though the cable switching dance again.  Does anyone have a solution.  I tied the fn-F8 buttons on the latitude, but it doesn't help.  I get a window that says presentation mode off, but I can't do anything with it. 

  • I also cannot get the E6400 to work with a KVM.  My  configuration is:

    1. Latitude E6400 laptop.  Using the onboard Mobile Intel 4 Series Express Chipset Family.  Video output is through the VGA port. 
    2. OS is XP Professional.
    3. Current video /  chipset driver is version 6.14.10.5029 dated 1/21/2009. 
    4. BIOS is A24.
    5. Trendnet KVM TK407
    6. ConnectPRO VGA-EDID (VGA-toVGA DDC/EDID Emulator)

    No video shown on the KVM monitor, but mouse and keyboard function.

    The ConnectPRO adapter is supposed to do  the Full-time Active DDC.

    Mine is a 4 port KVM currently connected to 2 desktops, and they work fine.

    I receive the same "LCD Only" and "Presentation Mode is Disabled" issues as others have stated.

    The E6400 laptop does just not work unless it is hooked up directly to a monitor.  If you hook it directly up to a monitor, the Fn F8 function will then give you the option of LCD and External display.

     

  • Found a solution to this, but it involves a new KVM switch.  The ConnectPro UR-12 or OR-14 KVM works perfectly with this laptop.  It has full-time DDC support.  This KVM requires that you physically push a button to switch between systems, but at least it works.  Best price found was at http://www.provantage.com.

  • I also am experiencing conectivity problems.  My current configuration is as follows.

    Latitude E6410 laptop.  Using the onboard Mobile Intel 4 Series Express Chipset Family.  Video output is through the VGA port.  OS is XP Professional.

    I'm trying to connect a AirLink AKVM-U42 witha ViewSonic 22" LCD.  Cable connections are via the VGA port for video and USB port for mouse/keyboard.

    No video shown on the KVM but mouse and keyboard function.

    I have tested the laptop on a conventional monitor and it works fine.  I have tested the KVM on a different laptop (a Dell Latitude D630) and it worked fine.

    I receive the same "LCD Only" and "Presentation Mode is Disabled" issues as you have stated..

    I would perfer not to replace my KVM or buy an expensive Active DDC Emulator Adapter.......

    What the heck was Dell thinking when they made this a feature????  I tried an HP laptop running Windows 7 and it works fine with my KVM.

     

  • Thank you to the poster that mentioned the Active DDC requirement and the poster who mentioned the cable switching workaround.  This gave me the idea to add an old-school Parallel Electromechanical VGA switch for the video from my Dell Lattitude E6410.  I also needed an additional VGA cable.  I have to switch both boxes now, but it works and was a much cheaper solution than buying a new couple hundred dollar KVM switch with Full Time Active DDC.  The VGA switch I added is made by QVS and has been sitting in my "parts box" for a dozen years.  No Model number.

    DellE6410(VGA)-->QVSSwitchBox-A

    Linkskey(VGA)-->QVSSwitchBox-B

    QVSSwitchBox-Out-->1920x1080p Monitor

    Everything else for the Linkskey remained the same except that the VGA cable remains disconnected from the E6410 laptop.  The USB and Audio remains connected so that my mouse, keyboard and audio switch through the Linkskey switch, while the video switches through the old mechanical switch.

    There is a similar CablesToGo brand mechanical switch on NewEgg now for less than $10.  Search "VGA Switch."

    Good Luck!

  • I just recently acquired a brand new Latitude E6330&docking station, I'm facing equivalent video issues with a Lindy KVM 32330.

    Why don't we get Dell to sort our this issue, buy modifiying it's bios version to support this missing DDC communication signal?

    I have escalated this issue to the technical support...we never know...