split screen problems

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

split screen problems

This question is not answered

Hi,

I have a Vostro 1710 running vista business. Recently, the display has starte freezing an upon restart it would have a split screen on the display. The same thing is being shown on the top and the bottom of the screen being seperated by a thin bar. On the right of the screen is about an inch thick black band.

I have tried reinstalling my video drivers but when it restarts, it gets past the windows loading bar and then it freezes again.

Please help?

All Replies
  • Does the same fault show on an external monitor? If it does, then the video chip is faulty and the mainboard will need to be replaced.  If it does not, then the display panel is faulty and will need to be replaced.

    This model is known to have a faulty nVidia video chip in it and the warranty has been extended by one year to cover these:

     

    http://en.community.dell.com/blogs/direct2dell/archive/2008/08/18/nvidia-gpu-update-dell-to-offer-warranty-enhancement-to-all-affected-customers-worldwide.aspx

     

     

  • I managed to fix it actually. It turns out that for some reason the intel on board chip wasnt being recognised anymore. It was being picked up as standard VGA graphics adapter. I ran the microsoft update and everything was fixed when it restarted.

    I will deffinately keep hold of that link though. As luck would have it my warranty has run out by a few days.

  • Ok. Explain my situation and results.

    Dell Vostro 2510 bought today $60 off Kijiji,  suppose to have a white screen, starts and shuts down and fan doesn't work, that is what was told at time of purchase.

    I took the guys word for it and know a white screen is a screen cable unplugged.

    He lied. Once I got it apart I notice water damage in several spots below the keyboard and further around the keypad area of motherboard. I cleaned it all and put quickly together for a test after clearing the cos by removing battery Clip to motherboard and shorting out the terminals for 5 seconds.

    The laptop started and had a split screen top half and bottom half with cursor and text on both halves and no fan at any time. I pulled the CPU out and found a pin bent, Un Fn believable! !! After carefully straightening the pin I cleared the cmos this time by shorting out the pins of battery clip and turning laptop on while shorting out pins. No difference, split screen with 2 or 3 inches of black on the right and some lines or little squares about the screens as well as 2 cursors and 2 sets of text in each screen.

    I removed the cable to the screen from the motherboard and booted, then wiggled the screen cable in and out a few times while laptop was on but nothing happened.

    I plugged the screen plug back into the motherboard and boom the screen is back to normal and only issue now is to get the fan running.

    Hope this list of events give you somewhere to start.

    I don't know what relieved the problem but I did suspect a short from the Inverter getting to the screen but maybe a bad connection to it but all is great and gonna work on a direct line to the fan somehow.. 

    Thanks guys.

    East Coast Canada Rules!!

    Posted this Reply December 2013

  • Ok. Explain my situation and results.

    Dell Vostro 2510 bought today $60 off Kijiji,  suppose to have a white screen, starts and shuts down and fan doesn't work, that is what was told at time of purchase.

    I took the guys word for it and know a white screen is a screen cable unplugged.

    He lied. Once I got it apart I notice water damage in several spots below the keyboard and further around the keypad area of motherboard. I cleaned it all and put quickly together for a test after clearing the cos by removing battery Clip to motherboard and shorting out the terminals for 5 seconds.

    The laptop started and had a split screen top half and bottom half with cursor and text on both halves and no fan at any time. I pulled the CPU out and found a pin bent, Un Fn believable! !! After carefully straightening the pin I cleared the cmos this time by shorting out the pins of battery clip and turning laptop on while shorting out pins. No difference, split screen with 2 or 3 inches of black on the right and some lines or little squares about the screens as well as 2 cursors and 2 sets of text in each screen.

    I removed the cable to the screen from the motherboard and booted, then wiggled the screen cable in and out a few times while laptop was on but nothing happened.

    I plugged the screen plug back into the motherboard and boom the screen is back to normal and only issue now is to get the fan running.

    Hope this list of events give you somewhere to start.

    I don't know what relieved the problem but I did suspect a short from the Inverter getting to the screen but maybe a bad connection to it but all is great and gonna work on a direct line to the fan somehow.. 

    Will try updating the cmos which is v4 to v6 but laptop keeps getting hot. Hmm. ..

    Thanks guys.

    East Coast Canada Rules!!

    Posted this Reply December 2013