Latitude D810 Radeon X600 need video driver update for XP SP3

Laptop

Laptop
Laptop computer Hardware and Software discussion

Latitude D810 Radeon X600 need video driver update for XP SP3

  • I installed Windows XP SP3 and I don't rotate the screen from 1920x1200 to 1200x1920.
    - Dell D810 with X600 video card
    - Windows XP SP3
    - Dell WFP2407 (1920x1200) monitor with DVI cable (with Port Replicator)
    I installed all driver (video driver date: 2005!) and display BIOS update. I tried setting the driver properties.
    Thanks: George Varga
    Message Edited by George_V on 08-27-2008 12:12 PM
  • Looks like I'm suffering from the same basic issue as George_V...

     

    My set-up: Inspiron 9300 with 64Mb ATI Mobility Radeon X300 card driving internal 1440 x 900 screen + external 20" Dell 2005FPW at 1050 x 1680 (portrait); both screens 60Hz/32-bit colour.

     

    All functioning perfectly under Windows XP Home Edition (SP2) and without any video driver updates since Jan '06... until I installed XP SP3, today.

     

    'Display Properties' needed re-setting, as might be expected... but I found I was unable to rotate the image on the external monitor from the default landscape to portrait.

     

    When using the ATI utility, pressing 'Rotate 90 degrees' weirdly just shrinks the external monitor res to 1024 x 768 and pops the alert: "The requested Rotation mode is not supported by your current display mode (resolution and/or refresh rate and/or colour depth). Please change the current display mode and try again."

     

    Also, when changing the res back to 1680 x 1050, I get columns of half-inch black lines all over the screen. Although these disappear when I reduce the colour depth to 16-bit. (A video RAM issue, maybe?)

     

    My first conclusion was incompatibility between the ATI Utility and SP3. So I downloaded the latest driver (posted only Aug 20th '08) from the ATI/AMD site: 'ATI Catalyst Mobility 8.8 Display Driver for Windows XP Professional/Home Edition'.

     

    But when I went to install it, simply got the alert: "Unfortunately, this software update cannot be installed on your system. Please contact your notebook manufacturer for driver updates."

     

    Any guidance out of this blind alley would be welcome, then, notebook manufacturer Dell.

     

    Thanks.

     

    Paul

  • all of us with that family of video card are having that problem right now.

     

    This is a known issue with your current driver and SP3.  While ATI has updated their drivers and made them available to consumers of consenting manufacturers, Dell apparently hasn't QA'd the driver yet.  Essentially, we cannot (easily and officially) update our driver to the known working version.

     

    We'd all love it if this was pushed down the pipe and through to ATI, Dell.

     

    Thanks for your attention