Latitude D610 Multi-display problem

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Latitude D610 Multi-display problem

  • I think I'm looking at a driver conflict here.  First system specs (pulled from aida32):

     

    Summary

    --------------------------------------------------------------------------------
          
      Computer: 
       Operating System   Microsoft Windows XP Professional 
       OS Service Pack   Service Pack 3 
       Internet Explorer   7.0.5730.13 
      
      Motherboard: 
       CPU Type   Mobile Unknown, 1900 MHz (6.5 x 292) 
       Motherboard Name   Dell Inc. Latitude D610 
       Motherboard Chipset   Unknown 
       System Memory   1015 MB 
       BIOS Type   Phoenix (10/02/05) 
       Communication Port   Communications Port (COM1) 
       Communication Port   ECP Printer Port (LPT1) 
      
      Display: 
       Video Adapter   Mobile Intel(R) 915GM/GMS,910GML Express Chipset Family (128 MB) 
       Video Adapter   NVIDIA Quadro NVS 55/280 PCI (64 MB) 
       Video Adapter   NVIDIA Quadro NVS 55/280 PCI (64 MB) 
       3D Accelerator   nVIDIA Quadro NVS 280 PCI 
       Monitor   Plug and Play Monitor [NoDB] (12452HA000903) 
       Monitor   Plug and Play Monitor [NoDB] (12456HA013566) 
      
      Multimedia: 
       Audio Adapter   Intel 82801FB ICH6 - AC'97 Audio Controller 
      
      Storage: 
       Disk Drive   Hitachi HTS541210H9AT00 
       Optical Drive   PBDS DVD+-RW DS-8W1P 
      
      Partitions: 
       C: (NTFS)   56753 MB (34448 MB free) 
      
      Peripherals: 
       USB Device   Dell Wireless 350 Bluetooth Module 
       USB Device   Generic USB Hub 
       USB Device   Generic USB Hub 
       USB Device   USB Composite Device 
       USB Device   USB Human Interface Device 
       USB Device   USB Human Interface Device 
       USB Device   USB Human Interface Device  



      

     

    There's some debug info available from the same program, but I'll need to parse it to get rid of the unnecessary bits.

    Basically what I'm trying to do is run the laptop LCD plus 2 screens from a videocard in a D/Dock.  The onboard video is the Intel 915, the Nvidia Quadro PCI is in the dock.  Newest available Intel and Nvidia drivers are installed.  When I go into the BIOS and tell it to use the docking station card as primary, the 2 screens connected to it work fine, but obviously the onboard LCD is disabled.

    When I set the onboard video card as primary in the BIOS, the machine boots with the card in the docking station disabled, "Input not supported" flashing on my external screens.  Going into XP's video properties, I can see the Nvidia card and the screens connected, but when I go to activate them it gives an error saying the driver was designed for an older version of Windows and to install the updated drivers.  (This is obviouly not an accurate error message because they are freshly downloaded from nvidia's website, and the video works fine when using the dock's card as primary)

    Going a step further, I then uninstalled the intel graphics drivers.  Reboot, and BAM!  video on three screens.  Only because the Intel drivers aren't installed, the LCD won't go above 640x480 resolution with 4bit color.

    I've tried uninstalling both video adapters, reinstalling drivers and rebooting in various combinations over the past few days.  I figured it was related to the Intel drivers in some way, so I tried installing the version from Intel's website (8 whole revisions newer than what Dell offers), but since they're not made by Dell, the Intel installer gives me an error telling me to download the 'approved' drivers from my manufacturer's website.

    I've since updated the BIOS, hoping the newest revision would help, but it seemed to do nothing.  Any insight into this problem would be greatly appreciated.  I'm not sure what else to try.

  • Ok, giving an update to bump this and for my own tracking purposes.  I'm now 100% sure it's a driver issue, and fairly sure it's from the NVidia drivers.

     

    I have a second partition that has linux on it.  Set up X to use all three screens and it's working fine.  I'd still like Windows to do the same thing, but I've heard that the newest version of Nvidia's drivers refuse to work with other chipset because it can cause problems with SLI.   I don't really need SLI (even if the nerfed PCI version of the card is able to do it) because it's not a gaming machine. 

     

    So, does anyone know of a generic driver that will work with an NVidia Quadro NVS 280 PCI and will co-exist with another chipset?  I've tried the oldest Quadro drivers available straight from Nvidia, but it does the same thing.  I'm going to take this up with Nvidia support in the meantime.