Screen Problem - Inspiron 1000

Laptop

Laptop
Laptop computer Hardware and Software discussion

Screen Problem - Inspiron 1000

  • MY wife's laptop had this problem this morning which I couldn't correct before leaving for work.  It was working fine last night and early this morning, however, after working on it this morning, the screen went all crazy.  It was totally illegible with a white background and vertical lines.  I rebooted it and when the logon screen came up, the screen was still white but I could make out some of the graphics, like the logon icon and such, but they were really distorted and there was almost no color.
     
    I  tried rebooting several times, but it did not fix the problem.  I didn't have time to hook it up to the desktops monitor to see if the video card was OK.  Any ideas what this could be? 
     
    I'm looking at replacement LCD screens and they are not cheap.  If its a video card, I can just replace that.  However, I am pretty sure this cheap laptop has it integrated into the main board.
     
    Any help is appreciated!
  • Try the external monitor. If it displays the same fault, you likely have a failure in the video circuitry, which on this model means a replacement system board. Again, on this model that's probably terminal - the cost of a board is more than the system is worth at this point (on the order of $400+).


    If the external monitor is OK, reseat the ribbon cable inside the system (between the panel and mainboard). If that doesn't fix it, the LCD panel needs repair or replacement.
  • I had my wife plug the desktops montior to the laptop and it appears fine on that screen.  Now, how do I go about reseating the ribbon cable?
  • There's no manual for the i1000, but the 1200/2200 is the same:


    http://support.dell.com/support/edocs/systems/ins2200/en/SM/index.htm
  • Thanks for the link with the manual, it was most helpful. 
     
    After I read how to take apart the display, I called a buddy of mine whose a computer tech.  He suggested that I try to fiddle with the video cable to see what happens.  I tried it and got the screen to stablize somewhat.  This verified to me that the main board was probably still good and the problem was with the LCD.  So I proceeded to take the screen apart to get a part number and when I touched the top of the cable where it connects to the screen, the image was fine, it was back to normal.  I let go and it was all screwy again.  So I pulled the tape, disconnected the cable and reconnected it and all is now fine.
     
    My buddy says this happens all the time with fine connections and sometimes all that is needed is to disconnect the cables to "rebrandish" the connections.
     
    Anyway, the laptop is working normally and I wanted to share this experience.  Hopefully, it may prove useful to someone else with the same problem.
     
    Thanks for all your assistance!