Forums

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Inspiron e1405 - <Fn+F8> is stuck on external display only

  • I have an issue with my Inspiron e1405, for some strange reason it is stuck on external display only and my laptop screen is off. I know that if you cycle through the <Fn+F8> key it should switch between:

     

    1) Internal Display

    2) External Display

    3) Both Displays

     

    But this isn't what is happeneing now. Each time I press the <Fn+F8> key... my external display flickers on/off for a fraction of a second and then only the external display remains on after each attempt. It never cycles the display as listed above (and how it worked in the past).

     

    Has anyone else had this problem? Does anyone know a quick solution?

     

    1) I have so far tried to power cycle the laptop (Shut Down and restart inside Windows XP Pro SP2).

    2) I have tried this on battery alone, on AC power alone, and with both plugged in.

    3) I have tried to cycle through the Fn+F8 keys with an external display connected and without an external display connected.

    4) I have gone into the display settings in the Windows control panel and tried to switch display settings from 1 or 2. Each time the external display identifies as #1. I have even tried to enable both and set it to extend my desktop across both screens.

    5) I know the screen isn't dead because it was working when i switched it from Internal display to external display. Since then it has always been stuck on External display only.

     

    If my laptop screen was dead... i would expect a state where my laptop screen is blank and my external screen to be blank for at least one out of 3 attempts as i cycle thru the 3 settings of <Fn+F8>

     

    Regards

    Message Edited by dafazman on 04-21-2008 09:57 PM
  • What is your display adapter?  (Intel, ATI, nVidia)  Have you updated the driver?

     

    Try this link for more info:

     

    http://www.fixya.com/support/t356513-presentation_mode_off

     

    Hope it helps.

    Anita  :o)

  • Turns out it was an issue with the power switch located under the top cover. I replaced that part and all was good in the world.

     

    Regards,