SODIMM Thermistor, Result Code: 3900-0626, temp=0C, min=10C, max=100C - General Hardware - Laptop - Dell Community

SODIMM Thermistor, Result Code: 3900-0626, temp=0C, min=10C, max=100C


Laptop computer Forums (Audio, General Hardware, Video)

SODIMM Thermistor, Result Code: 3900-0626, temp=0C, min=10C, max=100C

  • I'm getting the following diagnostic failure on my Latitude C800 (1GHz, A23 BIOS):

    SODIMM Thermistor - Sensor Range Test                      : Fail
      Result Code: 3900-0626
      Msg: Temperature sensor out of range, temp=0C, min=10C, max=100C

    I reached this result after the following events:

    • I recently started observing that Win2K chkdsk was finding and fixing bad attributes and cross-linked files on a regular basis.  The more I used the system, the more it found later.  Using some disk diag tools, I was able to find the affected files and, sure enough, I was losing some.  One of these incidents left the system unbootable, which I repaired using chkdsk from Win2K's recovery console.
    • I ran chkdsk -r, and the disk portion of the disk diagnostics looking for bad blocks, and the 90/90 test, repeatedly, in case there was some intermittant failure in the disk.  It's checked out perfectly every time.  I also ran the full suite of diagnostics once and got no errors.
    • Next, suspecting possible OS/driver problems, I backed up everything, and reinstalled Win2K from the recovery CD (a clean install with a new partition), and nothing else.  No change in symptoms; I still got chkdsk errors after copying a bunch of files around.
    • I ran all of the diagnostics repeatedly.  Once I started doing that, I find that I get the above diagnostic failure a large percentage of the time, but not 100% of the time.  All of the other diagnostics, particularly memory, cache and disk, run repeatedly without error.

    Does anyone have any further insight on this one?  For example, if this points to a specific piece of hardware, what is it, and what's its part number?

    I've looked at other forum articles with similar diagnostic failures.  Most appear to be associated with a bad BIOS version (A19?), but it appears that we're long past that, and I believe they all reported "temp=255C" or such, not 0C.  One other forum article suggests it might be the CPU/heat sink, but it's not clear whether the solution was simply adding heat conducting paste or completely replacing the CPU/heat sink with new ones as well.  And simply based on the title of the failing diagnostic ("SODIMM Thermistor"), I would blindly guess that the problem was closer to memory (which checks out fine) than the CPU (but I don't have sufficient internal system knowledge on this system to know).  So I seem to be at a dead end without some further insight.

  • To my knowledge the C800 does not have a thermal sensor on/near the RAM slots. For that matter neither does my C610, i8200 and C640. So you will always get a failure. Are you sure you are running the right Dell diagnostic program for the C800???
  • Thanks for the response.  I'm running "Diagnostics: Dell 32 Bit Diagnostics, Diagnostics, English, Multi System, A1102", release date 05/16/2002, file CD110210.exe (the floppy version) that I got from the download page associated with my system's service tag.  So I believe these are the right diagnostics, and they included the failing test.  The ambiguous forum thread that I referred to is here:  It mentions this same diagnostic failure on a C800, and the diags continue to offer this test after the successful fix, which the system then passes.  If there really is no SODIMM thermistor on this system, then perhaps it's part of the system failure mode that the diagnostic is lead to believe that there is, and doesn't default the test away as it "should".  But that's another guess.  Any other ideas?
  • I'm beginning to suspect a diagnostic bug here. After repeated experiments, it appears that the SODIMM Thermistor test NEVER fails if 1) all diags are run; OR 2) all of the thermistor diags (3 are offered) are manually run in order. It appears that the SODIMM Thermistor test ALWAYS fails if 1) just the first fan test is manually run; THEN 2) just the SODIMM Thermistor test is manually run immediately thereafter. Several steps can prevent the diag failure: 1) completely power off the system (both battery and AC) immediately before manually running the SODIMM Thermistor test; or 2) run the SMBIOS diag between the fan test and the SODIMM Thermistor test. I'm guessing that something isn't getting properly reset when going straight from the fan test to the SODIMM Thermistor test. It may be significant that the automated setup doesn't allow the three thermistor tests to be run separately, only as a group.

    In any case, that appears to put me back to square one on trying to diagnose the original problem.