I lost my internet connection... HELP!!! - General Hardware - Laptop - Dell Community

I lost my internet connection... HELP!!!


Laptop computer Forums (Audio, General Hardware, Video)

I lost my internet connection... HELP!!!

  • All,

    I have a 600M notebook and I was just using it this afternoon at work to connect to the internet with no problem. When I got home, I plugged in the network cable and I cannot access the internet.

    It is not my ISP connection problem. I have Comcast at home. My desktop has no problem connecting. And it is not my network cable either. I swapped the cable from my desktop and still my notebook cannot connect. I also notice that I got a green light and an orange light at the RJ45 jack when the cable is connected. That means it should be working. But I cannot ping any site and I cannot access any site with Internet Explorer.

    Does anyone know why I cannot connect? I tried almost everything and I am pulling my hair on this problem.

    Any help will be very much appreciated.



  • It's possible that your internet connection settings were somehow changed. If you normally just plug into a network and open a browser (internet explorer or netscape), then try this:

    Go to control panel from your start button. Click on network and internet connections, then on internet options. On the connections tab, set it to never dial. On the LAN settings button, set it to automatically detect settings. Click OK enough to get back to your desktop and give it a whirl.

    Hope that helps.

  • Thanks for the reply. But I already have automatic detect and DHCP Enabled. Nothing was changed between office and home.  This is not making sense. I use computer a lot and I have never seen this before.

    Please help.


  • Get to a command prompt then type IPCONFIG /ALL and report back what it says for your network card's IP address.
  • When I typed in ipconfig, I usually see 4 items listed.  But now, I only have the Autoconfiguration IP Address and the Subnet Mask. Both Connection-specific DNS Suffix and Default Gateway are blank.
  • Ahhhhh, after hours of argony, I just found out that it is Comcast's devious scheme.  Since I connect my desktop and notebook with a hub, I have to use two IP addresses. They won't allow me to connect until I pay the additional fee of $4.95.  I will change my hub to a router.

    By the way, I think we need more competition on broadband ISP.  Comcast is ripping us off.


  • I don't think it's Comcast's fault on this one, unless of course if they were the ones who provided your hub. Normally in such circumstances wherein you are dealing with multiple connections a wireless router is preferable over an ethernet hub anytime so you don't have to pay for the additional IP address(es).

  • It is Comcast's fault - lately they have implemented a custom way of negotiating IP address renewal that some routers do not handle.
  • >It is Comcast's fault - lately they have implemented a custom way of negotiating IP address renewal that some routers do not handle.

    Yupe, I found that out too. I have a Linksys Cable/DSL router sitting on my shelf. I switched that with the hub. My desktop can still connect to the internet, but my 600M cannot. I checked and double-checked. On the router, I already set to enable DHCP.

    Also, when I do ipconfig on my desktop, I noticed that the IP address is still the same IP address that Comcast has been assigning to me. It cannot be right. If I am using a router, the IP address on the desktop should be assigned by the router. I called Comcast Tech Support to help me to reset the mac address. The Support guy refused and he acted quite rude. Then he said if it involves a router, I have to call Linksys. They cannot help me and then good-bye.  I think he knows what's going on and he is not telling me their little devious scheme.

    John, do you know how to defeat that?