Run CPU at full speed?

Laptop

Laptop
Laptop computer Hardware and Software discussion

Run CPU at full speed?

  • How can I either bypass or disable the power saver feature in my Inspiron 8200's cpu? Its a 1.8 ghz P4 that never runs faster than 1.2 ghz, the default idling speed. I rarely run this computer on battery power and want it to run at full capacity.

    I've tried all the Control Panel power options and have disabled the feature from the bios. None of these attempts have affected the cpu speed. Is there another setting somewhere?

    Thanks..
  • Goto System setup(BIOS) by pressing F2 when you get to the dell logo screen.

    In the BIOS goto the "Power Management" Screen it should be the 6 th page.

    There Change the Intel Speedstep option to disabled.

    This will stop the Energy saving feature on the laptop.

     

     

  • I went into the bios and disabled Energy Saving in the AC setting before I came here for help, leo. I'm sure I saved the change properly. I really thought that would do it, but my cpu speed is still only 1.2 ghz.

    I'll disable the battery setting to see if that makes any difference.

    Is there anything else I can try?
  • Run a forum search on "speedstep". It will tell you everything you need to know.
  • tried setting the power scheme to always on or desktop in control panel>power options?
  • Tried SpeedswitchXP? www.diefer.de
  • Thanks to all of you for the suggestions..The power option is set to 'always on'.

    I've installed SpeedSwitch, but I haven't had any success in getting it to speed this bugger up. SpeedSwitch identifies only my idle speed, 1200 mhz, as the maximum speed, when its actually 1800 mhz. I've tried it with different energy saver settings; enabled and disabled in the bios. When energy saving is enabled, AIDA identifies the cpu correctly, its idle speed, maximum speed and current speed of 1200 mhz. When I disable it, AIDA merely identifies the cpu as a P4 that runs at 1200 mhz.

    Does this mean I have a faulty chip, or am I missing something?
  • If you are running on battery, that is normal. If on AC, you should be able to set it to the maximum and it should read that. If you have disabled Speedstep in the BIOS, you will be stuck on the low speed.
  • I'm doing all of this while on AC power. Nothing I've tried has accelerated the cpu speed beyond its 'energy saver' idle rate of 1200 mhz, even briefly.

    According to what I've read, there should be two different ways to force this cpu to run at 1800 mhz, its maximum rate.

    One way involves SpeedSwitch, the software utility, and the other way is implemented with bios settings. I've tried them both, and have also tried combinations of bios settings with SpeedSwitch installed and running.

    With Speedstep fully enabled in the bios, SpeedSwitch should identify and force the cpu to its maximum speed, but it can't find a capacity for any speed over 1200 mhz. According to the explanations inside the bios, I should be able to 'lock' the cpu speed to its highest rated level by disabling Speedstep, but disabling it has no effect.
  • How about your power supply? Could you by chance be using one of the 70 watters instead of the 90 watt? That could cause these symptoms.
  • The power supply is 70 watts, schmeig. If that's causing the problem, can it be replaced with a 90?
  • My 8200 with the 2 ghz processor requires the 90 watt power supply for full speed and I thought that all of the 8200 series did as well. It will run at 1.2 ghz with the 70 watt supply. You can order the supply from Dell Parts, but you will have to do it by phone. It's not available over the web. It should cost around $30 without the cord that plugs into the wall. With that cord, it's a bit more.

  • You want to enable speedstep in the BIOS.  Disabling it forces the processor to run at MINIMUM speed.  Once this is done, be sure to install the latest chipset and processor drivers from the Dell download site for your system and set power saving schemes in Windows to enable Full processor speed (not max battery or Low Power).  Also, regardless of settings, full speed will not be reached unless an application requires it (for testing you can run n! 1000000000 on the windows calculator). 
  • Dell provides a Speedstep Patch for Windows XP. I don't know exactly what it does, but the readme says it fixes some bugs in Microsoft's Speedstep implementation in Windows XP.
    Also try to "measure" the CPU clock in SpeedswitchXP with the "realtime calculation" option, bacause some BIOS versions are known to report the wrong CPU speed.
    To "test" the performance of your CPU, you can download PCMark2002 (not 2004) from www.futuremark.com. The CPU bench you'll get can be used to etsimate the CPU speed, knowing that a P4-2400 does approx 5500 points, your 1.8 should do 4000. (I don't own a P4 myself, so some P4(-m) owner maybe can confirm these values).

    Message Edited by HMKrieps on 02-07-2004 11:37 PM

  • I have the Speedstep patch and will install it later today. According to its description, its purpose is to correct the problem I'm having, so my situation isn't a strange new one. If it doesn't work, I'll order a 90 watt power unit. If that combination doesn't work, I may make a discus out of this thing. :)

    At this point, all of the Speedstep settings are at default in the bios. My descriptions of those settings have probably caused some confusion. One of them actually locks the cpu speed to its slowest and another locks it to its fastest. If I get Speedstep working properly, I believe I should be able to control it with SpeedSwitch, the utility, with default bios settings.

    I may be proven wrong, but I think I'm close to a solution. Thanks again to all of you for the help.