Dell WD15 w/XPS 13 9360 - No Video - General Hardware - Laptop - Dell Community

Dell WD15 w/XPS 13 9360 - No Video


Laptop computer Forums (Audio, General Hardware, Video)

Dell WD15 w/XPS 13 9360 - No Video

This question is not answered

Hello All,

I have a Dell XPX 13 9360 laptop with a WD15 dock that I want to use two Dell 2316M monitors.

The dock connects up to the laptop fine - I am getting ethernet, USB and power from the dock via the Thunderbolt port. But, I am getting no video output from it. The laptop does not recognize that there are additional displays connected. The monitors are on the correct input and the monitors work on their own respectively (tested by connecting to another machine).

I have tried installing the drivers from Dell (Thunderbolt, ASMedia USB, Intel Graphics, etc.), but nothing makes it work. I attempted to install the Firmware, but it fails.

The laptop is Windows 10 Pro.

Does anyone have any suggestions to make this work?

All Replies
  • Hmm, video is typically the easiest thing to get working because the USB-C port just has a DisplayPort output wired to it, so there are no special dock drivers to make that work.  In terms of the firmware update that failed, if you're referring to the WD15 firmware I'm linking below, what's the exact failure error?  That firmware update involves restarting your PC and having it update the firmware while it boots, and it would be a good thing to get working because one of the listed fixes pertains to the DisplayPort MST hub that controls the video outputs.  Link:

  • If the firmware update doesn't change anything, can you confirm the wattage of the AC adapter you've got connected to the WD15?  If you're trying to use it with an XPS 13 9360, either the 130W or 180W adapter would be fine, but I ask because some people here have tried to use these docks with random other Dell AC adapters they've got around that don't always provide enough power.  If even that fails, considering you've already updated your drivers, it's possible the dock is just defective -- any chance you've got another system to test it with?  The only other thread I've seen where somebody couldn't get video output to work was caused by him trying to use the dock with a non-Dell PC that didn't have a video output wired to its USB-C port to begin with, and no dock can fix that, but the XPS 13 definitely does.  But other than that limitation, like I said, video is usually the easiest thing of all to get running.

    The only other idea that comes to mind would be updating the system BIOS, but I don't think that should be necessary, and there are actually a few threads here right now about the latest XPS 13 9360 BIOS update causing intermittent USB device dropouts with the TB16 Thunderbolt dock, but the WD15 uses the same USB controller, so it might affect your dock as well.  Therefore I'd hold off on that until checking the previous items.

  • Yes... that is the firmware update that I tried - I get the following error;

    "Multi Stream Transport (MST) Hub #1 Firmware:   Failed

    (Error code 0x000000ff)"

  • It is a 180W power supply... updated system BIOS. It could be that I just have a bad one... I will test it out on another laptop Monday... and try another dock out on this computer (I have an almost identical setup at work.

  • Ok, if video isn't working AND the firmware update failed specifically on the DisplayPort MST hub, which is what controls the video outputs, that strongly suggests to me that you have a defective unit.  Sorry! :(

  • Yeah... I have a feeling. I do have pretty much an identical setup like this at work, so I will take this laptop/WD15 and test both out on that known good setup.

  • I experienced the same error after running the firmware update on the WD15 - and losing video through the unit in the process. It was working fine before the firmware update. What I suspect happened is that the first part of the update worked but after the reboot my virus checker removed the files that would have completed the firmware update (as it thought they were suspicious). I can't be sure this happened but it did delete something. Now I am stuck with a WD15 that works ok apart from video - and can't re-run the firmware update. Very frustrating.